The officially official Devuan Forum!

You are not logged in.

#1 2019-10-03 02:28:43

bgstack15
Member
Registered: 2018-02-04
Posts: 83  

[SOLVED] Devuan snapshot repos, like Debian?

An alternate title is: Devuan ceres libldb2 and its reverse dependencies

Pardon me, as I'm still learning the debianized way to do things.

Tonight, I was running OS updates on a Devuan ceres installation, and it removed freeipa-client, because sssd appears to be dependent on libldb1 but other parts of freeipa-client depend on libldb2, and those packages are conflicting. Yes, of course I know this is the rolling release "unstable" release.

My errors are this:

[bgstack15-local@ltb-013|/home/bgstack15-local/dev]$ sudo apt-get install freeipa-client sssd-ad-common sssd sssd-ad sssd-ipa samba-libs libsmbclient libldb2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 freeipa-client : Depends: python3-sss but it is not going to be installed
 sssd : Depends: python3-sss (= 2.2.2-1) but it is not going to be installed
        Depends: sssd-common (= 2.2.2-1) but it is not going to be installed
        Depends: sssd-krb5 (= 2.2.2-1) but it is not going to be installed
        Depends: sssd-ldap (= 2.2.2-1) but it is not going to be installed
        Depends: sssd-proxy (= 2.2.2-1) but it is not going to be installed
 sssd-ad : Depends: sssd-common (= 2.2.2-1) but it is not going to be installed
           Depends: sssd-krb5-common (= 2.2.2-1) but it is not going to be installed
           Depends: libldb1 (>= 0.9.21) but it is not going to be installed
 sssd-ad-common : Depends: sssd-common (= 2.2.2-1) but it is not going to be installed
                  Depends: libldb1 (>= 0.9.21) but it is not going to be installed
 sssd-ipa : Depends: sssd-common (= 2.2.2-1) but it is not going to be installed
            Depends: sssd-krb5-common (= 2.2.2-1) but it is not going to be installed
            Depends: libldb1 (>= 0.9.21) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Boiling it down even further, I got to the real problem:

[bgstack15-local@ltb-013|/home/bgstack15-local/dev]$ sudo apt-get install freeipa-client sssd-ad-common sssd sssd-ad sssd-ipa samba-libs libsmbclient libldb2 python3-sss sssd-common sssd-krb5 sssd-ldap sssd-proxy sssd-krb5-common libldb1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libldb2 : Breaks: libldb1 (< 2:2~) but 2:1.5.5-2 is to be installed
E: Unable to correct problems, you have held broken packages.

Is it possible to use a Devuan snapshot repository, like I have read about for Debian?

Or is there a way I can help whoever is responsible for libldb1 so that ew can get 2:2 version published so I can log back into my system with my domain account?

Last edited by bgstack15 (2019-10-03 10:41:30)


This space intentionally left blank.

Offline

#2 2019-10-03 03:08:27

bgstack15
Member
Registered: 2018-02-04
Posts: 83  

Re: [SOLVED] Devuan snapshot repos, like Debian?

Answered my own question!

This is what I get for doing unattended upgrades in a rolling release. I realize it's entirely my fault.

I have successfully downgraded components necessary so I can get a running sssd client and I can getent passwd bgstack15 again. Thankfully, these components do not require the custom rebuilt packages for devuan. I'm not entirely sure what I would have done in that case.

# set this source:

deb   https://snapshot.debian.org/archive/debian/20190901T043449Z/ unstable main

Run commands

sudo apt-get -o Acquire::Check-Valid-Until=false update
sudo apt-get install freeipa-client=4.7.2-3 freeipa-common=4.7.2-3 python-ipaclient=4.7.2-3 sssd=2.2.0-4 python3-sss=2.2.0-4 sssd-ad=2.2.0-4 sssd-common=2.2.0-4 sssd-ipa=2.2.0-4 sssd-krb5=2.2.0-4 sssd-ldap=2.2.0-4 sssd-proxy=2.2.0-4 libsss-idmap0=2.2.0-4 sssd-ad-common=2.2.0-4 sssd-krb5-common=2.2.0-4 libipa-hbac0=2.2.0-4 libsmbclient=2:4.9.11+dfsg-1 samba-libs=2:4.9.11+dfsg-1 libwbclient0=2:4.9.11+dfsg-1
References

https://unix.stackexchange.com/question … cal-mirror
https://duckduckgo.com/?q=debian+releas … is+expired
https://snapshot.debian.org/


This space intentionally left blank.

Offline

Board footer