The officially official Devuan Forum!

You are not logged in.

#1 2019-09-11 17:36:12

Eaglet
Member
From: Россия
Registered: 2018-06-24
Posts: 10  
Website

Fail start pulseaudio in KDE Beowulf (Devuan 3)

Hi, my friends!

I have problem with autostart pulseaudio after login in KDE 5 Beowulf (Devuan 3), pulseaudio not autostart.
I resolve this problem only add this command in autostart in System Setting application: /usr/bin/pulseaudio --start --log-target=syslog

Friends, please, resolve this problem for all in next update Beowulf (Devuan 3).

King regards, thanks!

Offline

#2 2019-09-11 17:41:39

jmarinho
Member
Registered: 2019-04-02
Posts: 1  

Re: Fail start pulseaudio in KDE Beowulf (Devuan 3)

Hi
Try commenting the line "autospawn=no" on /etc/pulse/client.conf.d/00-disable-autospawn.conf file like the comments on that file suggest.

Offline

#3 2019-09-11 17:46:12

Eaglet
Member
From: Россия
Registered: 2018-06-24
Posts: 10  
Website

Re: Fail start pulseaudio in KDE Beowulf (Devuan 3)

jmarinho wrote:

Hi
Try commenting the line "autospawn=no" on /etc/pulse/client.conf.d/00-disable-autospawn.conf file like the comments on that file suggest.

Ok! Thanks you! I try!
Developers Devuan can resolve this problem.

King regards.

Last edited by Eaglet (2019-09-11 17:46:55)

Offline

#4 2019-09-21 17:33:00

kapqa
Member
Registered: 2019-01-02
Posts: 64  

Re: Fail start pulseaudio in KDE Beowulf (Devuan 3)

thanks, this helped me too, on XFCE4. just upgraded from ascii to beowulf. nice!

Offline

#5 2019-09-22 14:53:44

kapqa
Member
Registered: 2019-01-02
Posts: 64  

Re: Fail start pulseaudio in KDE Beowulf (Devuan 3)

what i noticed is that upon booting there is a quite delay with showing several lines

unknown lvalue something autospawn '" '"
unknown lvalue something autospawn '" '"
unknown lvalue something autospawn '" '"
unknown lvalue something autospawn '" '"
unknown lvalue something autospawn '" '"
unknown lvalue something autospawn '" '"


sorry for not being too precise here

Offline

#6 2019-12-03 20:11:31

devujan
Member
Registered: 2019-10-26
Posts: 5  

Re: Fail start pulseaudio in KDE Beowulf (Devuan 3)

Solved it:

Add the line

/usr/bin/pulseaudio --start "$@"

below the line

"set -e"

in /usr/bin/start/-pulseaudio-x11

This starts it automatically for all users on the system, when they log on.
If you have some time you should file a bug for that - as pulseaudio under KDE in beowulf is mute by default without it...

Offline

#7 2019-12-04 14:40:49

devujan
Member
Registered: 2019-10-26
Posts: 5  

Re: Fail start pulseaudio in KDE Beowulf (Devuan 3)

Additionally pulseaudio wants ofono to be installed.
When having it installed you get something like:

pulseaudio: modules/bluetooth/backend-ofono.c:376:hf_audio_agent_register_reply:Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.34" (uid=1010 pid=3528 comm="/usr/bin/pulseaudio --start ") interface="org.ofono.HandsfreeAudioManager" member="Register" error name="(unset)" requested_reply="0" destination="org.ofono" (uid=0 pid=2904 comm="/usr/sbin/ofonod ")

in /var/syslog.
To get this to work edit
/etc/dbus-1/system.d/ofono.conf

and add
...
  <policy group="bluetooth">
    <allow send_destination="org.ofono"/>
  </policy>
...
below
<policy user="root">
...
  </policy>

Make sure the users of the desktop are members of the group "bluetooth".

Offline

Board footer