The officially official Devuan Forum!

You are not logged in.

#1 2019-08-07 20:30:13

Dutch_Master
Member
Registered: 2018-05-31
Posts: 96  

ASCII on RPi1 fails to boot

Right, way back I bought some original Raspberry Pi's. Regrettably the project I'd intended them for failed to materialize, so they're shelved. Recently, I decided to re-purpose at least one of them, so I grabbed the latest Raspbian image, loaded it onto an SD card, inserted the card in the slot, powered the thing up and presto, everything worked as expected. Including the cr@p that is systemd and makes the RPi1 so painfully sssllloooowwww sad

So I looked for and found the Devuan RPi images (plural, yes) and loaded the appropriate one onto the same SD card, put it back into the same RPi1 and... Nothing. Not an inkling of life in the system, only a red led indicating power is present. This is the 6-6-2018 image in the embedded section.

Anyone to provide me a systemd-free Devuan image* for the RPi1 please? TIA!

*I don't mind if it's based on Beowulf or Ascii, as long as it's stable! And it'd be totally perfect if it's running OpenRC as init system, but that might be a bit too much to ask. wink

Offline

#2 2019-08-16 00:41:55

d1str0
Member
Registered: 2019-04-22
Posts: 9  

Re: ASCII on RPi1 fails to boot

Sounds like a problem when flashing the image. Maybe a corrupted SD?
I'm not sure how similar is a Raspberry Pi B+ compared to the original Raspberry but I had one with Devuan Jessie working. I took the SD card and successfully flashed Devuan Ascii with this image: https://ftp.nluug.nl/pub/os/Linux/distr … pi1.img.xz using this command

xzcat devuan_ascii_2.0.0_armel_raspi1.img.xz | sudo dd of=/dev/sdb
sync

This is the output of neofetch:

   ..,,;;;::;,..                   root@devuan 
           `':ddd;:,.              ----------- 
                 `'dPPd:,.         OS: Devuan GNU/Linux ascii armv6l 
                     `:b$$b`.      Model: Raspberry Pi Model B Plus Rev 1.2 
                        'P$$$d`    Kernel: 4.14.44+ 
                         .$$$$$`   Uptime: 6 minutes 
                         ;$$$$$P   Packages: 274 
                      .:P$$$$$$`   Shell: bash 4.4.12 
                  .,:b$$$$$$$;'    CPU: ARMv6-compatible rev 7 (v6l) (1) @ 0.7 
             .,:dP$$$$$$$$b:'      Memory: 17MB / 465MB 
      .,:;db$$$$$$$$$$Pd'`          
 ,db$$$$$$$$$$$$$$b:'`             ████████████████████████ 
:$$$$$$$$$$$$b:'`                   
 `$$$$$bd:''` 
   `'''` 

Maybe tomorrow I could try the same SD on a Raspberry Pi 1 if I can get one.

Offline

#3 2019-08-16 04:36:50

Dutch_Master
Member
Registered: 2018-05-31
Posts: 96  

Re: ASCII on RPi1 fails to boot

Thx for the reply. I doubt the SD card was/is corrupted, as I mentioned the official Raspbian image worked fine on the same SD card. But it's encouraging you got it working, so I'll try again later (perhaps over the weekend). Thx!

Offline

Board footer