The officially official Devuan Forum!

You are not logged in.

#26 2019-02-08 16:37:38

Geoff 42
Registered: 2016-12-15
Posts: 266  

Re: Xen and the art of VM

Other USB devices

Having got a memory stick working I tried a portable DVD drive

usbip port
Imported USB devices
Port 00: <Port in Use> at High Speed(480Mbps)
       LaCie, Ltd : unknown product (059f:0643)
       1-1 -> usbip://
           -> remote bus/dev 001/005

This worked and I was able to play an audio CD through VLC, once I had added myself to the group "cdrom". "eject" also worked.

Later I tried to put a video DVD in... Unfortunately this hung Dom0!

The DVD was mounted in Dom0 and then an info request came from DomU and then an attach request. This attachment seemed to complete and then there was a "general protection fault: 0000 [#1] SMP NOPTI" followed by a traceback from usbip-host on Dom0 and then the kernel went into a loop of tracebacks. Time to hit the power switch...

I spotted a USB bluetooth dongle for £1 in a charity shop, so I bought it. My Dom0 machine hasn't got bluetooth installed, but I attached it through to the Beowulf DomU and bluetoothctl show returns some plauseable looking data. I have yet to work out how to get it to actually do anything useful, despite having read man bluetoothctl!

Agent registered
[bluetooth]# help

is more informative, but bluetoothctl seems to have to be run as root to actually report anything.

[bluetooth]# discoverable on
Failed to set discoverable on: org.bluez.Error.Failed

The Bluetooth dongle could be seen, but I was not sure what to do with it. Connman was also able to see the dongle.

The next thing I tried was an external USB disk drive, a Samsung M3 Portable, which is USB 3 and, I recall 2TB. Unfortunately this did not work. I seemed that it was possible to connect it through to DomU but then it disconnects with the error :-

[ 5286.237272] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?

USBIP seems to work in the general case, but some more extreme uses cause it problems. I think that it was problems with USBIP rather than Xen.



Board footer