The officially official Devuan Forum!

You are not logged in.

#1 2019-01-03 11:20:48

dxrobertson
Member
Registered: 2017-05-04
Posts: 141  

Install Wireless Firmware During Net Install

I am trying to install Devuan from the Net Install but need to use non-free wireless firmware.  No access to ethernet.  I have the Debian driver .deb file (firmware-atheros_20161130-4_all.deb) as well as the individual firmware files extracted, stored on a usb drive.  I am installing Devuan from a usb drive (and have this second usb drive containing my firmware).

The install runs fine until it gets to the point where it asks if you want to install drivers from a cd, or whatever.  I say yes, my firmware usb drive is inserted, and the installer returns and says it cant find the drivers.

I can pick the option near the end of the install list to drop to a shell.  I can fdisk -l and see my usb is recognized.  I can even mount the usb and see my driver firmware files.

How do I "tell" the install process where my firmware files are, within the usb drive?  What is the installer looking for, a .deb file?  I could try and manually copy the firmware from my usb to their appropriate directory in /lib/firmware within the shell, then I suppose I would have to do a modprobe?  would this work?

Note that during the network configuration stage of the install my wireless is not recognized thus the reason I need to install my firmware to complete the net install.

Offline

#2 2019-01-03 12:32:12

dxrobertson
Member
Registered: 2017-05-04
Posts: 141  

Re: Install Wireless Firmware During Net Install

NEVER MIND.

After digging a little deeper, it turns out the needed firmware is already available in the install /lib/firmware.  And proceeding further into the network config, I was able to get wireless configed and connected . 

Sorry about that.

Offline

#3 2019-01-03 17:09:03

kuleszdl
Member
Registered: 2018-11-03
Posts: 32  

Re: Install Wireless Firmware During Net Install

Exactly. Currently, the firmware files are already there on the install media and loaded without asking the user, see also:

https://dev1galaxy.org/viewtopic.php?id=2475

Offline

Board footer