The officially official Devuan Forum!

You are not logged in.

#1 2018-10-10 19:42:44

Altoid
Member
Registered: 2017-05-07
Posts: 145  

Request for package

Hello:

Is there a protocol/place for requesting a package update?

I am in need of a .deb application called barrydesktop, last seen in https://packages.debian.org/wheezy/barrydesktop.

---
Package barrydesktop

wheezy (oldoldstable) (utils): Desktop Panel GUI for the RIM BlackBerry Handheld
0.18.3-5: amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 s390x sparc
---

Just to see if, I tried installing it (in Devuan ASCII) but it seems that there is a dependency not satisfiable problem with a library called libbarry18.

Attempting to install libbarry18 on it's own brings forth another dependency not satisfiable problem with libglibmm-2.4-1c2a [>=2.31.22] which seems to be a more serious matter: on attempting to install it brings up that it would break an existing package (libglibmm-2.4-1v5) so that is that.   

At a loss as to what to do now.

Thanks in advance.

A.

Offline

#2 2018-10-11 13:32:00

fsmithred
Administrator
Registered: 2016-11-25
Posts: 916  

Re: Request for package

You could try compiling it for ascii. Get the source either from the page you linked or get a slightly newer upstream source from https://sourceforge.net/projects/barry
But it looks like the project didn't continue beyond 2013. The homepage shown on the debian package page no longer exists.

Offline

#3 2018-10-12 16:42:32

Altoid
Member
Registered: 2017-05-07
Posts: 145  

Re: Request for package

Hello:

fsmithred wrote:

You could try compiling it for ascii.

I sort of toyed with the idea before I realised it was way over my head.

fsmithred wrote:

Get the source either from the page you linked or get a slightly newer upstream source from https://sourceforge.net/projects/barry

I have the code that came with the *.deb I once downloaded.

fsmithred wrote:

But it looks like the project didn't continue ...

Yes.
It seems to have been abandoned.

I once contacted the developer/maintainer/website and at first it seemed that something would happen, maybe just the necessary update so that it would be useful again.
But that did not go through.

Blackberry Desktop was only available under MSWindows and unbelievably did not have an address book, so you were stuck with syncing to POS Outlook Express and nothing else.

The grace of this very simple Barry Desktop app was that you could download -> edit/modify -> upload/sync the address book/contact information and even make a backup under Linux.
Maybe that was the reason it was dumped?

I recall that there were a set of libraries (OpenSync?) that stopped working at some time so that was a problem for some part of the app, but the download -> edit/modify -> upload/sync for the addrerss book worked fine.

Edit: (5' and some memory juggling later)
I now recall that the problem was with the syncing libraries due to the demise of the OpenSync framework (or something to that effect).
But you could browse, modify and save the contact database to the unit as well as make a backup so it was really very useful.

I don't get it ...
My trusty Palm IIIxe is still running strong and if anything breaks or I happen to lose it, I have an extra one + a box of full spare parts to put one together in under 20' if needed, just need 2xAAAs.

And j-Pilot is mature and still going strong at v1.8.2 with a great following.

As for the 9320 Curve, I just cleaned up three years worth of grime and replaced the case.
Good as new.

But it seems that I'm stuck with doing the XP/OE/BBD dance in my Devuan VBox.

Thanks for your input. 

A.

Last edited by Altoid (2018-10-12 16:56:48)

Offline

#4 2018-10-12 18:46:47

fsmithred
Administrator
Registered: 2016-11-25
Posts: 916  

Re: Request for package

It's over my head, too. I tried compiling from source, but I failed.

What comes in the .deb package is not enough to recompile. You need the source code to do that.

Another possibility is to run barry in an old version of debian in a virtual machine.

Offline

#5 2018-10-12 20:55:57

Altoid
Member
Registered: 2017-05-07
Posts: 145  

Re: Request for package

Hello:

fsmithred wrote:

... in the .deb package is not enough to recompile. You need the source code to do that.

That I have from Git.

fsmithred wrote:

... run barry in an old version of debian in a virtual machine.

Hmm ...
Thought of that too, but it's more or less the same as what I have now.

I tried doing Alien on an .rpm but on installation I got some problem in a libbarry18 (?) library.
I think that is the point where the original maintainer/developer gave up.

Thanks for your input.

Cheers,

A.

Offline

Board footer