The officially official Devuan Forum!

You are not logged in.

#1 2018-09-15 14:41:41

makh
Member
Registered: 2017-10-08
Posts: 51  

<Solved> [Ascii] Problem with AptCacherNg

Hi

I am unable to use in Devuan:
https://wiki.debian.org/AptCacherNg
... It worked fine in Debian.

I get in my client machine:

Could not resolve the 'myservername'

My configuration is:
1. Both machines are on the same network.
2. Both machines can ping to each other.
3. Both machines are guest OS, within virtualbox.

Thankyou

Last edited by makh (2018-09-23 14:37:02)


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#2 2018-09-15 16:23:26

chris2be8
Member
Registered: 2018-08-11
Posts: 26  

Re: <Solved> [Ascii] Problem with AptCacherNg

First try:
ping -c 1 wiki.debian.org
on both systems. You should get something like:

$ ping -c 1 wiki.debian.org 
PING wilder.debian.org (82.195.75.112) 56(84) bytes of data.
64 bytes from wilder.debian.org (82.195.75.112): icmp_seq=1 ttl=53 time=41.9 ms

--- wilder.debian.org ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 41.989/41.989/41.989/0.000 ms

Chris

Offline

#3 2018-09-15 18:12:11

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

chris2be8 wrote:

First try:
ping -c 1 wiki.debian.org
on both systems. You should get something like:

$ ping -c 1 wiki.debian.org 
PING wilder.debian.org (82.195.75.112) 56(84) bytes of data.
64 bytes from wilder.debian.org (82.195.75.112): icmp_seq=1 ttl=53 time=41.9 ms

--- wilder.debian.org ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 41.989/41.989/41.989/0.000 ms

Chris

Hi,
Thats working!


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#4 2018-09-15 22:48:06

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

Hi

I got it working for now. But its a temporary fix:

I replaced the server-machine-name by its IP address: 192.168.AB.CDE

But my machine is basically behind the DHCP Router, so ... if address of server changes, then I have to manually edit the above values again.

I hope theres a solution to use the name instead of IP address!

Thankyou


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#5 2018-09-16 08:28:08

neutron_stz
Member
Registered: 2018-09-16
Posts: 6  

Re: <Solved> [Ascii] Problem with AptCacherNg

post contents of /etc/hostname and /etc/hosts

Offline

#6 2018-09-16 23:49:03

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

neutron_stz wrote:

post contents of /etc/hostname and /etc/hosts

Hi
Server Files:

1. 
vmdevuanr1
2.
127.0.0.1	localhost
127.0.1.1	vmdevuanr1

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Client Files:

1.
vmdevuanbeta
2.
127.0.0.1	localhost
127.0.1.1	vmdevuanbeta

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Thankyou


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#7 2018-09-18 12:38:58

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

Hi

My other settings are:

Client Machine:

cat /etc/apt/apt.conf.d/proxy
#Acquire::http { Proxy "http://192.168.15.235:3142"; }
#Acquire::http { Proxy "http://vmdevuanr1:3142"; }
Acquire::http { Proxy "http://vmdevuanr1:3142"; }

... It works with the static address only!

Output of apt update is by using:

apt update &> output.txt
WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Err:1 http://packages.devuan.org/merged ascii InRelease
  Could not resolve 'vmdevuanr1'
Err:2 http://auto.mirror.devuan.org/merged ascii-security InRelease
  Could not resolve 'vmdevuanr1'
Err:3 http://auto.mirror.devuan.org/merged ascii-updates InRelease
  Could not resolve 'vmdevuanr1'
Err:4 http://auto.mirror.devuan.org/merged ascii InRelease
  Could not resolve 'vmdevuanr1'
Reading package lists...
Building dependency tree...
Reading state information...
All packages are up to date.
W: Failed to fetch http://auto.mirror.devuan.org/merged/dists/ascii-security/InRelease  Could not resolve 'vmdevuanr1'
W: Failed to fetch http://auto.mirror.devuan.org/merged/dists/ascii-updates/InRelease  Could not resolve 'vmdevuanr1'
W: Failed to fetch http://auto.mirror.devuan.org/merged/dists/ascii/InRelease  Could not resolve 'vmdevuanr1'
W: Failed to fetch http://packages.devuan.org/merged/dists/ascii/InRelease  Could not resolve 'vmdevuanr1'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Thankyou


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#8 2018-09-18 16:22:37

chris2be8
Member
Registered: 2018-08-11
Posts: 26  

Re: <Solved> [Ascii] Problem with AptCacherNg

Try ping vmdevuanr1 and host vmdevuanr1 on the system you ran apt update on.
(The "Could not resolve 'vmdevuanr1'" message sounds as if it is the key problem.)

Chris

Offline

#9 2018-09-19 06:02:23

neutron_stz
Member
Registered: 2018-09-16
Posts: 6  

Re: <Solved> [Ascii] Problem with AptCacherNg

add following line to clients /etc/hosts file:

192.168.15.235 vmdevuanr1

and try again with hostname instead of ip

Last edited by neutron_stz (2018-09-19 06:03:52)

Offline

#10 2018-09-22 07:35:12

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

chris2be8 wrote:

Try ping vmdevuanr1 and host vmdevuanr1 on the system you ran apt update on.
(The "Could not resolve 'vmdevuanr1'" message sounds as if it is the key problem.)

Chris

Hi
ping vmdevuanr1

ping: vmdevaunr1: Name or service not known

host vmdevuanr1

Host vmdevaunr1 not found: 3(NXDOMAIN)

@neutron_stz: Actually I want it to be not hardbinded, as I am using a dhcp server. As IP changes, then I have to re-edit again!

Thankyou


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#11 2018-09-22 09:15:19

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 253  

Re: <Solved> [Ascii] Problem with AptCacherNg

Presumably, as implied by your initial note "... It worked fine in Debian.", you are also running a DHCP/DNS service combination, such that the DHCP server upon serving an IP for vmdevuanr1 registers that host name appropriately with the DNS service, so that other hosts should be able to resolve it? Which DHCP/DNS service combination are you using?

Offline

#12 2018-09-22 10:41:46

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

ralph.ronnquist wrote:

Presumably, as implied by your initial note "... It worked fine in Debian.", you are also running a DHCP/DNS service combination, such that the DHCP server upon serving an IP for vmdevuanr1 registers that host name appropriately with the DNS service, so that other hosts should be able to resolve it? Which DHCP/DNS service combination are you using?

Hi
It is a simple internet DHCP router. I am using it in default, no such special configurations!

Actually I tested this all system, and had no issue in Debian. So I went on to test on Devuan.

I also tested one more configuration: use apt-chacher-ng for the server access to the media. Strangely, for server itself, it works, for both Debian and Devuan! But for devuan client to server fails. sad


Thankyou

Last edited by makh (2018-09-22 10:44:38)


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#13 2018-09-22 16:07:43

chris2be8
Member
Registered: 2018-08-11
Posts: 26  

Re: <Solved> [Ascii] Problem with AptCacherNg

To make it work the client needs to know what IP address vmdevuanr1 has. The server will know it's own IP address, probably as 127.0.0.1, so it will work there. The client needs to either have it edited into /etc/hosts when necessary (tedious manual work) or to be able to look it up in DNS.

What does /etc/resolv.conf contain? Mine contains:

nameserver 192.168.1.1

Which tells the system to ask my internet router (at 192.168.1.1) to resolve IP addresses. Try using your router as a DNS server as well as DHCP server. If it's already your DNS server look at it's admin screens to see if there's an option for it to resolve addresses it's handed out by DHCP. Or you may need to add a suffix to vmdevuanr1 in /etc/apt/apt.conf.d/proxy

Chris

Offline

#14 2018-09-22 16:51:23

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

chris2be8 wrote:

To make it work the client needs to know what IP address vmdevuanr1 has. The server will know it's own IP address, probably as 127.0.0.1, so it will work there. The client needs to either have it edited into /etc/hosts when necessary (tedious manual work) or to be able to look it up in DNS.

What does /etc/resolv.conf contain? Mine contains:

nameserver 192.168.1.1

Which tells the system to ask my internet router (at 192.168.1.1) to resolve IP addresses. Try using your router as a DNS server as well as DHCP server. If it's already your DNS server look at it's admin screens to see if there's an option for it to resolve addresses it's handed out by DHCP. Or you may need to add a suffix to vmdevuanr1 in /etc/apt/apt.conf.d/proxy

Chris

Hi
1. Both my client and server contain:

nameserver 192.168.1.1

2. But under the same configuration; the debian server is giving the service: do I need to probe into the Router?

My Router has only two fields in DNS tab:
Enable DDNS     (Default disable)
DDNS Service Provider     (dyndns.org)
I dont know much about Networking; but nothing else seems to have DNS settings etc!

3. If you are running the same service via apt-cacher-ng; does it works for your client machines?

4. The ping and host commands work for both my debian machines!



Thankyou


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#15 2018-09-23 14:09:36

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

Adding to above:

5. From the same machine ie vmdevuanr1:

ping -c2 vmdevuanr1

... Works

host vmdevuanr1

... Fails


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#16 2018-09-23 14:21:13

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

Adding:

6. Theres also another difference in the two configurations, as I can explore:
a. In Debian I have by default installed: network-manager
b. In Devuan I have by default installed: wicd

Thankyou


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#17 2018-09-23 14:36:39

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

Solved, at last:

On Devuan Apt-cache-ng Sever:

apt install network-manager-gnome
apt remove wicd
apt autoremove

All is well that ends well... smile

Thankyou all for your kind input!


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

#18 2018-09-23 16:02:03

chris2be8
Member
Registered: 2018-08-11
Posts: 26  

Re: <Solved> [Ascii] Problem with AptCacherNg

The way I would have done it it to make all systems that act as servers have a fixed IP address. Then systems connecting to them can use that IP address (preferably an entry in /etc/hosts).

First check what range of addresses your DHCP server can hand out (eg 192.168.1.2 to 192.168.1.200). Then give the server an IP address that's not in that range. You get problems if two systems try to use the same IP address.

Or configure the DHCP server to give the relevant system a fixed IP address.

You may not need this advice now, but someone else might find it useful.

Chris

Offline

#19 2018-09-23 17:31:50

makh
Member
Registered: 2017-10-08
Posts: 51  

Re: <Solved> [Ascii] Problem with AptCacherNg

chris2be8 wrote:

The way I would have done it it to make all systems that act as servers have a fixed IP address. Then systems connecting to them can use that IP address (preferably an entry in /etc/hosts).

First check what range of addresses your DHCP server can hand out (eg 192.168.1.2 to 192.168.1.200). Then give the server an IP address that's not in that range. You get problems if two systems try to use the same IP address.

Or configure the DHCP server to give the relevant system a fixed IP address.

You may not need this advice now, but someone else might find it useful.

Chris

Hi
Thanks
But I believe there was some defect in wicd!


HP Probook 440 G2: Arch, Debian Stable
Others: Devuan, Centos, Ubuntu, Opensuse
GUI: Openbox, Xfce, Cinnamon
Chroot: Debian, Ubuntu, Fedora

Offline

Board footer