The officially official Devuan Forum!

You are not logged in.

#1 2018-08-23 09:08:19

minghia
Member
Registered: 2018-06-18
Posts: 11  

Serial port on Raspberry Pi using Devuan

We are trying to use the serial port on a Raspberry Pi 3B running Devuan and we can't seem to anything through what we think is the serial port on pins 8 & 10 on the header. Does anyone have any experience getting the serial port to work on a Raspberry Pi using Devuan?

Note I have enable-uart=1 in my /boot/config.txt and I have also disabled the WiFi and the Bluetooth.

Tony

Offline

#2 2018-09-04 03:30:45

minghia
Member
Registered: 2018-06-18
Posts: 11  

Re: Serial port on Raspberry Pi using Devuan

Solved it when I realised that by disabling the bluetooth and wifi and enabling the UART, the kernel creates /dev/ttyS0. I was trying to use /dev/ttyAMA0 which gets switched to the second UART after the enabling and disabling.

Offline

#3 2018-09-04 16:40:54

Devuoted
Member
Registered: 2017-06-01
Posts: 3  

Re: Serial port on Raspberry Pi using Devuan

Would you find the time to post details from your config.txt and cmdline.txt to show how you made this work?

Whenever I add 'enable_uart=1' to config.txt I get a kernel panic on boot.

Devuoted

Offline

#4 2018-09-05 02:39:52

minghia
Member
Registered: 2018-06-18
Posts: 11  

Re: Serial port on Raspberry Pi using Devuan

## memory shared with the GPU
gpu_mem=128

## always audio
#dtparam=audio=on

## maximum amps on usb ports
max_usb_current=1

## enable hardware-accelerated graphics
dtoverlay=vc4-kms-v3d

#dtparms=i2c2_iknowwhatimdoing

dtoverlay=pi3-disable-bt
dtoverlay=pi3-disable-wif

enable_uart=1

## kernel
kernel=kernel8.img

My cmdLine.txt is netbooting so I don't know if that is of help. But I can give to you with the IP address removed:

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/nfs rootfstype=nfs nfsroot=XX.XX.XX.XX:/root elevator=deadline fsck.repair=yes rootwait ip=dhcp plymouth.ignore-serial-consoles

.

It maybe the plymouth.ignore-serial-consoles that does it.

Offline

#5 2018-09-12 18:19:34

Devuoted
Member
Registered: 2017-06-01
Posts: 3  

Re: Serial port on Raspberry Pi using Devuan

Thanks a lot for sharing your information.

I got it to boot as it should with help of your example.

In /boot/config.txt I added the directives:
core_freq=250
dtoverlay=pi3-disable-bt
enable_uart=1


In /boot/cmdline.txt I removed
console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
and I added
plymouth.ignore-serial-consoles


Furthermore, in /etc/inittab I removed (commented out) the line:
T0:23:respawn:/sbin/agetty -L ttyAMA0 115200 vt100


The computer now boots as expected. Next step is to move it to an Internet-depraved site and see if I can get it to communicate with the 3D-printer there. :-)

Thanks for your help.

Offline

#6 2018-09-16 19:07:36

Devuoted
Member
Registered: 2017-06-01
Posts: 3  

Re: Serial port on Raspberry Pi using Devuan

So, just to follow up on my own post.

The serial port is now available and functional. I have contact with the 3D-printer in question through OctoPrint.

Thanks again.

Offline

Board footer