The officially official Devuan Forum!

You are not logged in.

#1 2018-07-20 14:32:59

Nili
Member
From: $HOME/♫♪
Registered: 2016-12-01
Posts: 47  
Website

[SOLVED] (Devuan Jessie) libuuid-perl: no longer required

Hello! Today I found that during the update process libuuid-perl wants to be removed.

#! nili ~ $ update
Hit http://pkgmaster.devuan.org jessie InRelease
Hit http://pkgmaster.devuan.org jessie-updates InRelease
Hit http://pkgmaster.devuan.org jessie-security InRelease
Hit http://pkgmaster.devuan.org jessie-backports InRelease
Hit http://pkgmaster.devuan.org jessie/main i386 Packages
Hit http://pkgmaster.devuan.org jessie-updates/main i386 Packages
Hit http://pkgmaster.devuan.org jessie-security/main i386 Packages
Hit http://pkgmaster.devuan.org jessie-backports/main i386 Packages
Ign http://pkgmaster.devuan.org jessie/main Translation-en_US
Ign http://pkgmaster.devuan.org jessie/main Translation-en
Ign http://pkgmaster.devuan.org jessie-updates/main Translation-en_US
Ign http://pkgmaster.devuan.org jessie-updates/main Translation-en
Ign http://pkgmaster.devuan.org jessie-security/main Translation-en_US
Ign http://pkgmaster.devuan.org jessie-security/main Translation-en
Ign http://pkgmaster.devuan.org jessie-backports/main Translation-en_US
Ign http://pkgmaster.devuan.org jessie-backports/main Translation-en
Reading package lists... Done
#! nili ~ $ upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
  libuuid-perl
Use 'apt-get autoremove' to remove it.
Done
The following packages will be upgraded:
  linux-base
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 19.7 kB of archives.
After this operation, 46.1 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

This is my sources list:

deb http://pkgmaster.devuan.org/merged jessie main

deb http://pkgmaster.devuan.org/merged jessie-updates main

deb http://pkgmaster.devuan.org/merged jessie-security main

deb http://pkgmaster.devuan.org/merged jessie-backports main

First time I see such a thing on the stable, A few ago when actively when i used testing, I faced very often similar situations that came out as temporary bug.

Is it a bug that I just have to wait? OR let it go libuuid-perl? To me it seems not look like a simple package that i should let out. From Debian DSA there is no news for this.

Do someone know anything about this case?
Thank you!

System runs...:

Devuan GNU/Linux 1 (jessie)
Linux coeurlinux 3.16.0-4-686-pae #1 SMP Debian 3.16.51-3 (2017-12-13) i686 GNU/Linux

P.S. update/upgrade command shortened it as alias on .bashrc.

alias update="sudo apt-get update"
alias upgrade="sudo apt-get upgrade"

Edit: Found this SECURITY THREAD about this case.
I gave the update linux-base, removed libuuid-perl and installed again. Currently it seems quiet, i'll look at it later.

This thread is solved! Thank you for the attention.

Nili

Last edited by Nili (2018-07-22 16:42:53)


OS: Devuan | WM: Openbox
Android: S8+ Hi-Res (32/24-bit 96kHz) WAV/FLAC @ mora.jp (sounds good)

Offline

Board footer