The officially official Devuan Forum!

You are not logged in.

#1 2020-09-20 19:59:11

Altoid
Member
Registered: 2017-05-07
Posts: 504  

Linux - Locale conundrum

Hello:

I have an unsolved issue of sorts involving locale settings which I have not been able to get around for the longest while.

A short explanation is in order.

My mother tongue is Spanish, my second language being English.

My exposure to IT was from the very start in English and for some reason I have never been to feel comfortable with IT in Spanish.
Notwithstanding, when I work with others in IT in my mother tongue and as trhere are words to explain most everything, I insist that the proper Spanish terms be used.
One of my pet peeves.

Being my initial exposure to IT in English all the OSs I have ever used, from DOS back in the day onwards to Linux today have been/are in English.

But ...

My time zone is GMT -03:00, my date/time format of choice is DD/MM/YYYY - HH:MM:SS and because I work in the two languages I speak (occassionally dabbling in French) I have preferred a keyboard layout that has most if not all the needed letters and symbols. ie: Latin American with the standard 105-key layout and then some (if I can remember where they are).

eg:

         | 1 2 3 4 5 6 7 8 9 0 ' ¿
Shift ° ! " # $ % & / ( ) = ? ¡
AltGr ¬ | @ · ~ ½ ¬ { [ ] } \ ¸

         q w e r t y u i o p ' +
Shift Q W E R T Y U I O P " *
AtGr @ ł € ¶ ŧ ← ↓ → ø þ " ~

         a s d f g h j k l ñ { }
Shift A S D F G H J K L Ñ [ ]
AltGr æ ß ð đ ŋ ħ̉ ̉  ĸ ł ~ ^ `

        < z x c v b n m , . -
Shift > Z X C V B N M ; : _
AltGr « » ¢ “ ” n µ   · ̣

There are sometimes problems related to the opening/saving of spreadsheets (MSOffice/Libre Office) and the /var/log/ files which can be parsed in a terminal but not be seen properly with some editors due to ISO encodings.

eg: Pluma + /var/log/auth.log, kern.log, messages ...

pluma has not been able to detect the character encoding.
Please check that you are not trying to open a binary file.
Select a character encoding from the menu and try again.

Basically, what I want is that my Linux box be 100% in English (en-GB preferred), be able to use the keyboard layout I need and be able to look at log files with an editor without problems.

Any suggestions?

Thanks in advance,

A.

Offline

#2 2020-09-21 16:09:29

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Linux - Locale conundrum

Altoid wrote:

My mother tongue is Spanish, my second language being English.

Really? I would never have guessed, your English is excellent.

Altoid wrote:

not be seen properly with some editors due to ISO encodings

Have you tried selecting UTF-8 as the encoding? Note that the log files need root permissions to view.

Altoid wrote:

what I want is that my Linux box be 100% in English (en-GB preferred), be able to use the keyboard layout I need

# dpkg-reconfigure locales keyboard-configuration

If you want English as the language but a Spanish date/time format then edit /etc/default/locale directly, for example:

LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_TIME=es_ES.UTF-8

Use locale -a to see a list of all available locale codes and see locale(1) for more on this.


Black Lives Matter

Offline

#3 2020-09-21 18:58:04

Altoid
Member
Registered: 2017-05-07
Posts: 504  

Re: Linux - Locale conundrum

Hello:

Head_on_a_Stick wrote:

... excellent.

Thanks. =-)
Methinks rather lacking in volcabulary.

Head_on_a_Stick wrote:

... tried selecting UTF-8 as the encoding?

Yes.

Head_on_a_Stick wrote:

... log files need root ...

I was opening them as root.

Head_on_a_Stick wrote:
# dpkg-reconfigure locales keyboard-configuration

Ahh .....

I was doing dpkg-reconfigure keyboard-configuration and dpkg-reconfigure locales and not dpkg-reconfigure locales keyboard-configuration.
So I was getting errors.

I'll try this and get back later on.

Thanks for your input.

A.

Offline

#4 2020-09-21 21:59:04

Altoid
Member
Registered: 2017-05-07
Posts: 504  

Re: Linux - Locale conundrum

Hello:

Altoid wrote:

... get back later on.

Apparently it is all fixed.
I'll have to see how things go with the logfiles and MSOffice/LibreOffice stuff.

~$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE
# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="latam"
XKBVARIANT="deadtilde"
XKBOPTIONS="lv3:ralt_switch,terminate:ctrl_alt_bksp"

BACKSPACE="guess"
~$ 

Took me a while because I was incorrectly setting nodeadtilde, fussing up the layout.

~$ cat /etc/default/locale
#  File generated by update-locale
LANG=en_GB.UTF-8
#LANGUAGE=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF.8"
LC_COLLATE="en_GB.UTF-8"
# LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
~$ 
~$ locale -a
C
C.UTF-8
en_GB.utf8
es_AR.utf8
POSIX
~$ 

For future reference in case anyone else comes across a similar problem, this is the keyboard layout -> http://kbdlayout.info/KBDLA/
No, I don't use a MS kb. this web page is very useful (has scan codes, virtual keys, etc.) and references to kbdla.dll which is a MS file. 8^P

Thanks for your input.

Cheers,

A.

Last edited by Altoid (2020-09-21 22:00:07)

Offline

Board footer