The officially official Devuan Forum!

You are not logged in.

#1 2020-01-08 01:20:25

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

SOLVED: Cinnamon, but not MATE, beeps on shutdown

I just built two systems: Cinnamon to use as a primary system and MATE to play around with. I noticed that on shutdown, Cinnamon beeps while MATE does not. How do I turn-off the beep?

Last edited by nobodyuknow (2020-01-10 22:37:01)

Offline

#2 2020-01-08 01:59:26

Dutch_Master
Member
Registered: 2018-05-31
Posts: 133  

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

Find and open Sound Preferences, in the "Sound Effects" tab, select "no sound" as sound-theme. Worked for me, YMMV!

Offline

#3 2020-01-08 16:25:04

GNUser
Member
Registered: 2017-03-16
Posts: 518  

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

@nobodyuknow - Try adding blacklist pcspkr to /etc/modprobe.d/blacklist (create /etc/modprobe.d/blacklist if it doesn't already exist).

Offline

#4 2020-01-09 15:34:17

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

Another alternative is to autostart this command:

xset b off

Adding it to ~/.xsessionrc should do the trick (or use Cinnamon's autostart GUI).


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#5 2020-01-09 19:47:34

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

Thanks to Head_on_a_Stick, GNUser, and Dutch_Master for their replies. I will play around with the various settings.

Offline

#6 2020-01-10 22:36:37

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

There is no .xsessionrc in my home directory, only .xsession-errors and .xsession-errors.old.

I could not determine where Sound Preferences was. There's a Sound package, but not a Sound Preferences.

So I added "blacklist pcspkr" to /etc/modprobe.d/blacklist (I did indeed have to create this file). The shutdown beep appears to have disappeared.

Offline

#7 2020-01-10 22:57:41

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

Just FYI:

nobodyuknow wrote:

There is no .xsessionrc in my home directory, only .xsession-errors and .xsession-errors.old.

You are allowed to create new files in $HOME wink


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#8 2020-01-24 23:03:26

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

The beep only partially disappeared. I'm sure there was some pattern, but I never could figure it out. So I uncommented "set bell-style none" in /etc/inputrc. But that didn't do it either. So I finally took Head_on_a_Stick's advice with respect to .xsessionrc, creating the file with trembling hands. :-). Success!

Last edited by nobodyuknow (2020-01-24 23:31:42)

Offline

#9 2020-02-01 16:35:01

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

Re: SOLVED: Cinnamon, but not MATE, beeps on shutdown

I'm posting one last time to to note that the beep did not disappear completely. Every now and then the beep will sound. Maybe someday I'll determine the pattern, but for now I'll remove my headphones before shutting-down.

Offline

Board footer