The officially official Devuan Forum!

You are not logged in.

#1 2020-01-08 00:55:40

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

SOLVED: /etc/lightdm/lightdm.conf different in Cinnamon versus MATE

Usually when a distribution has a login screen where I need to enter first the ID and then the password, I can edit /etc/lightdm/lightdm.conf to un-comment the line "greeter-hide-users=false" (obviously this applies only to lightdm users) and pre-select the user (this assumes only one user will use the system). Devuan Cinnamon is this way. However, MATE does not have lightdm.conf in that directory, with there being two files with long, but related filenames. Where is the relevant file?

Last edited by nobodyuknow (2020-03-07 20:15:25)

Offline

#2 2020-01-08 01:56:17

Dutch_Master
Member
Registered: 2018-05-31
Posts: 133  

Re: SOLVED: /etc/lightdm/lightdm.conf different in Cinnamon versus MATE

I'm running Mate, it's there: /etc/lightdm/lightdm.conf Did you install the default gtk-greeter for lightdm? (you should, as it's a dependency IIRC)

Offline

#3 2020-01-09 19:50:17

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

Re: SOLVED: /etc/lightdm/lightdm.conf different in Cinnamon versus MATE

Thanks for the reply. Install the default gtk-greeter? I just did a standard install. I tried adding "greeter-hide-users=false" to both of the files, but that did nothing.

Offline

#4 2020-01-09 20:01:52

rolfie
Member
Registered: 2017-11-25
Posts: 253  

Re: SOLVED: /etc/lightdm/lightdm.conf different in Cinnamon versus MATE

I just use Mate in ASCII and Beowulf. There is no difference, you find the lightdm.conf in /etc/lightdm. There you need to uncomment:

[Seat:*]
#type=xlocal

....

#greeter-session=example-gtk-gnome
greeter-hide-users=false

That works fine and display a list of full usernames on the login screen.

I have just done an apt install lightdm, there are no options.

rolfie

Last edited by rolfie (2020-01-09 20:02:57)

Online

#5 2020-03-07 20:15:06

nobodyuknow
Member
Registered: 2017-09-10
Posts: 46  

Re: SOLVED: /etc/lightdm/lightdm.conf different in Cinnamon versus MATE

First, thanks to everyone who responded. I had emergencies, so I left this for a while.

I installed lightdm and gtk-greeter. With the former, I was pleasantly surprised that I was prompted as to which display manager I wanted, slim or lightdm, though slim was advertised as a simple login manager. I rebooted because I wanted to see the behavior of the login screen. It was the familiar lightdm one. I tried to login, but it immediately returned me to the login screen. I looked at the desktop selector, which was set to default xsession. I selected MATE and everything was back to normal. Now lightdm is not magic to me.

Offline

Board footer