The officially official Devuan Forum!

You are not logged in.

#1 2019-07-29 05:37:58

dajun
Member
Registered: 2019-07-29
Posts: 2  

vbox for 3.0 ?

I installed virtualbox from ascii-backports,
now I changed sources.list to beowulf, made upgrade and dist-upgrade, but got problem of vbox:

# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 virtualbox-ext-pack : Depends: virtualbox (>= 5.2.24-dfsg-0~) but it is not installed or
                                virtualbox-5.2 but it is not installable
                       Depends: virtualbox (< 5.2.24-dfsg-z) but it is not installed or
                                virtualbox-5.2 but it is not installable

# apt remove virtualbox-ext-pack
...
137 not fully installed or removed.
After this operation, 130 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 163966 files and directories currently installed.)
Removing virtualbox-ext-pack (5.2.24-2~bpo9+1) ...
/var/lib/dpkg/info/virtualbox-ext-pack.prerm: 4: /var/lib/dpkg/info/virtualbox-ext-pack.prerm: vboxmanage: not foun                                                                                                                          d
dpkg: error processing package virtualbox-ext-pack (--remove):
 installed virtualbox-ext-pack package pre-removal script subprocess returned error exit status 127
Errors were encountered while processing:
 virtualbox-ext-pack
E: Sub-process /usr/bin/dpkg returned an error code (1)


~# apt install virtualbox
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 virtualbox : Depends: virtualbox-dkms (>= 5.2.24-dfsg-4~bpo9+1) but it is not going to be installed or
                       virtualbox-source (>= 5.2.24-dfsg-4~bpo9+1) but it is not going to be installed or
                       virtualbox-modules
              Depends: python3 (< 3.6) but 3.7.3-1 is to be installed
              Recommends: virtualbox-qt (= 5.2.24-dfsg-4~bpo9+1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@pc:~# dpkg -l |grep python3
iU  libpython3-stdlib:i386                      3.7.3-1                            i386         interactive high-level object-oriented language (default python3 version)
ii  libpython3.5:i386                           3.5.3-1+deb9u1                     i386         Shared Python runtime library (version 3.5)
ii  libpython3.5-minimal:i386                   3.5.3-1+deb9u1                     i386         Minimal subset of the Python language (version 3.5)
ii  libpython3.5-stdlib:i386                    3.5.3-1+deb9u1                     i386         Interactive high-level object-oriented language (standard library, version 3.5)
ii  libpython3.7:i386                           3.7.3-2                            i386         Shared Python runtime library (version 3.7)
ii  libpython3.7-minimal:i386                   3.7.3-2                            i386         Minimal subset of the Python language (version 3.7)
ii  libpython3.7-stdlib:i386                    3.7.3-2                            i386         Interactive high-level object-oriented language (standard library, version 3.7)
iU  python3                                     3.7.3-1                            i386         interactive high-level object-oriented language (default python3 version)
iU  python3-distutils                           3.7.3-1                            all          distutils package for Python 3.x
iU  python3-gi                                  3.30.4-1                           i386         Python 3 bindings for gobject-introspection libraries
iU  python3-lib2to3                             3.7.3-1                            all          Interactive high-level object-oriented language (2to3, version 3.6)
ii  python3-minimal                             3.7.3-1                            i386         minimal subset of the Python language (default python3 version)
ii  python3-pkg-resources                       40.8.0-1                           all          Package Discovery and Resource Access using pkg_resources
ii  python3.5                                   3.5.3-1+deb9u1                     i386         Interactive high-level object-oriented language (version 3.5)
ii  python3.5-minimal                           3.5.3-1+deb9u1                     i386         Minimal subset of the Python language (version 3.5)
iU  python3.7                                   3.7.3-2                            i386         Interactive high-level object-oriented language (version 3.7)
ii  python3.7-minimal                           3.7.3-2                            i386         Minimal subset of the Python language (version 3.7)

I thought packages from ascii-backports should be in beowulf, but it is not, and there is no beowulf-backports

Offline

#2 2019-07-31 07:16:58

SmokeyGrey
Member
Registered: 2019-04-15
Posts: 15  

Re: vbox for 3.0 ?

Virtualbox was removed from Debian Buster in April
https://tracker.debian.org/news/1038163 … m-testing/
virtualbox: might not be suitable for stable releases due to lack of cooperation from upstream on security support for older releases

Offline

#3 2019-08-01 03:26:32

dajun
Member
Registered: 2019-07-29
Posts: 2  

Re: vbox for 3.0 ?

thanks SmokeyGrey,
finally I uninstalled all virtualbox* and upgraded to 3.0, will try vbox from official site later.

Offline

Board footer