The officially official Devuan Forum!

You are not logged in.

#1 2016-12-04 05:41:58

mlsmith
Member
Registered: 2016-11-25
Posts: 60  

Multiple Sound Cards

Can't hear sound? You likely have more than one sound card and ALSA chose the wrong one at boot. To correct this, you could create a .asoundrc file in your home directory specifying the default card. Unfortunately, Firefox may not recognize this file so you would continue to have no sound in Firefox. To remedy this, you will need to specify via modprobe in which order to load sound drivers so that your preferred card is selected first by ALSA.

First, run the following command to see which order ALSA assigned your cards:

cat /proc/asound/cards

In my case I got:

0 [HDMI ]: HDA-Intel - HDA Intel HDMI
HDA Intel HDMI at 0xe0510000 irq 61
1 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xe0514000 irq 59

Now, tell the kernel to load PCH as the default:

sudo bash -c 'echo "options snd_hda_intel index=1,0" > /etc/modprobe.d/alsa.conf'

You can verify the driver name to use above by running

lsmod | grep snd

Reboot the computer and you should have sound!

Last edited by mlsmith (2016-12-05 03:25:52)

Offline

#2 2016-12-17 11:21:00

Geoff 42
Member
Registered: 2016-12-15
Posts: 366  

Re: Multiple Sound Cards

If you have 2 different devices sharing the same module, then you can use the "enable" parameter to disable the one that you don't use. So that if you have both HDMI and PCH, with your speakers plugged into the PCH outlets, and your HDMI device appears first, then you set the entry in /etc/modprobe.d/alsa-base.conf  to :-

# Disable the HDMI card which shows up first, but enable PCH
options snd-hda-intel enable=0,1

http://forums.debian.net/viewtopic.php?t=110572#p525601

Geoff

Last edited by Geoff 42 (2016-12-17 11:22:28)

Offline

#3 2018-08-29 04:59:54

Sawyer
Member
Registered: 2018-08-26
Posts: 2  

Re: Multiple Sound Cards

Thank You for your fix. 

    bash -c 'echo "options snd_hda_intel index=1,0" > /etc/modprobe.d/alsa.conf'

everything looked fine after devuan install with the sound card drivers and alsa, but no sound.  Pulseaudio could not find a device, after 3 days of working on it i tried the above line and... Ego zero, Internet 1, and victory is mine smile Thanks again.

Last edited by Sawyer (2018-08-29 05:13:56)

Offline

#4 2020-03-06 12:03:21

GlennW
Member
Registered: 2019-07-18
Posts: 29  

Re: Multiple Sound Cards

Thanks, this has helped me too. :-)

cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf6080000 irq 76
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf6900000 irq 78
 2 [UA25EX         ]: USB-Audio - EDIROL UA-25EX
                      Roland EDIROL UA-25EX at usb-0000:09:00.3-1, full speed

I want the usb device to be the one, but the hdmi is always there, very quietly. Thank you

Offline

#5 2020-03-06 23:10:12

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 979  
Website

Re: Multiple Sound Cards


Black Lives Matter

Offline

#6 2020-03-08 14:33:28

SmokeyGrey
Member
Registered: 2019-04-15
Posts: 22  

Re: Multiple Sound Cards

This. Setting alsa settings through ~/.asoundrc is better than messing with modprobe if you aren't using pulseaudio. To summarize the archwiki,

Run aplay -l

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device0ID [Device 0 Name], device 0: Multichannel [Multichannel]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Device1ID [Device 1 Name], device 0: Multichannel [Multichannel]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Find your desired device, we will pick Device 0
Create ~/.asoundrc with the contents

pcm.!default {
    type hw
    card Device0ID
}

ctl.!default {
    type hw
    card Device0ID
}

I can put together a more advanced guide if you want to set different input and output devices.

Regarding firefox not recognizing .asoundrc, I cannot reproduce the issue, but my .asoundrc is closer to

pcm.!default {
    type plug
    slave {
        pcm "hw.Device0ID"
    }
}

ctl.!default {
    type hw
    card Device0ID
}

Edit: I actually do remember firefox causing me trouble now that I think about it. Here's a previous post I made. It seems like firefox expects a plug device as default. http://dev1galaxy.org/viewtopic.php?pid=16014#p16014

Last edited by SmokeyGrey (2020-03-08 15:06:28)

Offline

#7 2020-03-24 06:26:57

aus9
Member
Registered: 2020-03-24
Posts: 37  

Re: Multiple Sound Cards

Hi

there is some good info here. I am an alsa guy but still tend to use PA as I use firefox.

Here is an alternative GUI to disable HDMI in PA where you are using 3.5mm leads from analog sound device.

first here is my aplay without any swapping...clean install

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Note the name is Generic for both cards.....now run the pavucontrol GUI
as per screenshot...for those interested. But no need to click as I describe it

top line  HD Audio Generic 
bottom line same name

but the top line is for first detected card, that is card with index=0 which is HDMI

so pulldown the top line to choose Off

hope that helps the newbies.

https://imgur.com/yAhgb7L

and the card 1 for analog should be stereo duplex unless you are using multiple connectors to a surround sound system

Good Luck

Offline

#8 2020-03-24 09:57:19

aus9
Member
Registered: 2020-03-24
Posts: 37  

Re: Multiple Sound Cards

@GlennW

If the info does not yet help you...try this
create a file to blacklist you internal sound module, on reboot only your inserted USB device is detected. I have not forced it to index=0 but here is my test result

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

If I want internal sound then I use root powers to modprobe as per

#  /sbin/modprobe snd_hda_intel

that changes my indices but who cares.....anyhow here is file contents

cat /etc/modprobe.d/blacklist-intel.conf 
blacklist snd_hda_intel

The reason we blacklist....is because USB devices take time to settle and time taken by udev etc.

EDIT
I should add....having come from a debian based distro...that uses a package called
alsa-base
--> that had alsa-base.conf in my old distro modprobe.d dir
with various configs to stop USB devices grabbing anything nice

Last edited by aus9 (2020-03-24 09:59:48)

Offline

#9 2020-03-30 07:10:15

GlennW
Member
Registered: 2019-07-18
Posts: 29  

Re: Multiple Sound Cards

Thank you aus9, I did that (both /etc/modprobe.d/alsa.conf and /etc/asound) and it worked/s quite well. Finally Pulse free and plenty of noise when I want it. :-)

Thank you

Offline

Board footer