The officially official Devuan Forum!

You are not logged in.

#1 2018-09-25 12:21:01

Registered: 2017-05-07
Posts: 222  

X server configuration - Unresolved symbol warning in Xorg.0.log


I had been looking at my Xorg.0.log file to see about weeding out a problem I have.
Before I got down to that specific issue, I checked some (WW) entries that I thought could be easily fixed.

groucho@devuan:~$ cat /var/log/Xorg.0.log | grep WW
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    32.572] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    32.592] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    32.592] (WW) Disabling Keyboard0
[    32.592] (WW) Disabling Mouse0
[    34.150] (WW) Unresolved symbol: fbGetGCPrivateKey
[    34.223] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[    34.223] (WW) NVIDIA:     is an unsupported configuration.  The driver will continue
[    34.223] (WW) NVIDIA:     to load, but may behave strangely.
[    34.223] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[    34.223] (WW) NVIDIA:     X server.
[    36.666] (WW) NVIDIA(0): Not registering RandR
[    36.736] (WW) NVIDIA(1): Not registering RandR
[    36.860] (WW) NVIDIA(2): Not registering RandR

Of all of them, the last ones from [34.223] on, regarding Composite, Xinerama and RandR were accounted for and their origin known as they are properly documented in the xorg.0.log.

This one ...

[    32.572] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

... was solved here.

These two ...

[    32.592] (WW) Disabling Keyboard0
[    32.592] (WW) Disabling Mouse0

... were solved by editing xorg.conf.

1.  by removing the InputDevice definitions in the "ServerLayout" Section.

Section "ServerLayout"
    Identifier     "layout0"
    Screen      0  "ScreenLeft" LeftOf "ScreenCenter"
    Screen      1  "ScreenCenter" 0 0
    Screen      2  "ScreenRight" RightOf "ScreenCenter"
#  InputDevice    "Keyboard0" "CoreKeyboard"
#  InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"

2. by removing the respective "InputDevice" sections. (completely removed, an "InputDevice" section cannot exist in xorg.conf if it is empty.)

#Section "InputDevice"
# generated from default
# Identifier     "Keyboard0"
# Driver         "libinput"

#Section "InputDevice"
# generated from default
#    Identifier     "Mouse0"
#    Driver         "libinput"
#    Option         "Protocol" "auto"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"

This is because the default settings for "AutoAddDevices" and "AutoEnableDevices" in the "ServerFlags" section are "True" so there is no need for any InputDevice definitions in the xorg.conf file unless there is a specific reasson to do so. ie: the Xserver having problems detecting some hardware ie: touchpads, pen tablets or other input devices.

The perils of doing copy+paste from web examples of xorg.conf are quite evident here.  :^ /
They are usually not very well explained and many times out of date. ie: for previous versions of Xserver.

The remaining (WW) entry in the log file is this one:

[    34.150] (WW) Unresolved symbol: fbGetGCPrivateKey

I'm running a fully up to date Devuan ASCII with two NVidia cards for three monitors and using proprietary drivers.

I have searched all over the web and have found a great deal on posts/instances in which this same error is cited (as an entry in a
Xorg.0.log file) but not specifically and I have not been able to find out why it is there and if has some significance.

After all, it is labelled as a warning ie: (WW).

It seems to be innocuous as my NVidia cards are working properly (save for an artifacts issue reserved for another post).

I'd appreciate if someone could give me some insight on this.

Thanks in advance.


Last edited by Altoid (2018-09-25 12:23:27)


Board footer