The officially official Devuan Forum!

You are not logged in.

#1 2018-07-14 13:40:14

From: Melbourne
Registered: 2017-06-16
Posts: 1  

[SOLVED] Raspberry Pi Zero Wifi using ascii (2.0)

After dd'ing the image for the Raspberry Pi Zero onto an uSD card and booting,
I discovered that the Wifi driver didn't work, dmesg showing:

brcmfmac: F1 signature read @0x18000000=0x1541a9a6
brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43430-sdio.bin for chip 0x00a9a6(43430) rev 0x000001
usbcore: registered new interface driver brcmfmac
brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.txt failed with error -2
brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

I finally tracked it down to the fact that the above mentioned
"brcm/brcmfmac43430-sdio.txt" is required, yet absent.

To have working Wifi do the following (at least it works for me anyway):

1.  Download both bin and txt files ( brcmfmac43430-sdio.bin,
    brcmfmac43430-sdio.txt ) from: … aster/brcm


996b7ef7cbdb8ea3855fa516acb57630ff03a449fd3bb23e84789f2f04b4faf5  brcmfmac43430-sdio.bin
e4ce7ad5ce72406f958ed758539b65d958d1c0eb3e46e3f8e9f02b510d88e0b0  brcmfmac43430-sdio.txt

2. Back up existing /lib/firmware/brcm/brcmfmac43430-sdio.bin

3. Place 2 downloaded files in /lib/firmware/brcm. Of course this can be done
on the SD card itself from another system by mounting the 2nd partition of the

If I can track down where this issue originates, I'll file a bug (I'm guessing
Debian proper).


#2 2018-07-23 09:27:25

Registered: 2017-09-16
Posts: 11  

Re: [SOLVED] Raspberry Pi Zero Wifi using ascii (2.0)

Hello all together!

I've downloaded the files, you've described (from the same link) today. The checksum of the bin-file still matches, but this one from the txt-file doesn't? (This makes me a little bit wondering, as they are dated from February 15th?) And of course, if they where copied to the described place, my pi-zero has no WLAN-interface? Some questions remain:

- Can someone provide a working version of the txt-file?
- Is it possible, that something else was going wrong?

The image I've used was devuan_ascii_2.0.0_armel_raspi1.img.xz from the download-zone-site.

Greetings, FM_81


Board footer