The officially official Devuan Forum!

You are not logged in.

#1 2018-06-03 13:12:40

ks
Member
Registered: 2018-05-08
Posts: 12  

Minor problem with laptop installation

A while ago I installed Ascii beta on a laptop after having used Centos for many years. Everything went better than I expected, and I'm thrilled. Except:

Depending on where I use the laptop I have either ethernet with a static IP or wifi with a dynamic IP (dhcpd on the lan). Wicd seems unable to deal with this.

The damn thing totally ignored both my settings for eth0 in /etc/network/interfaces and those in
/etc/wicd/wired-settings.conf, always demanding an ip address from the nearest dhcp server (which would stop me from ssh'ing into the laptop when using eth0). In the end I resorted to just creating an empty
/etc/wicd/wired-settings.conf file for wicd, and left the /etc/network/interfaces for when I plug in a cable.

For this works, but I have no idea if what I did is even remotely correct.

Offline

#2 2018-06-03 14:34:03

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 260  

Re: Minor problem with laptop installation

In general, and as you probably know, the interfaces file is used by the ifupdown network management system, whereas wired-settings.conf is used by the wicd network management system. The former is more passive, and only operates on interfaces as explicitly commanded, e.g. # ifup eth0.

wicd is actively managing the interfaces it is told to manage; it's a daemon program that discovers changes to interface status and acts on these. Especially, if you have told wicd to manage eth0 it will do so, but if you haven't, it won't. I think wicd by default will configure itself to manage eth0 upon installation, but it's certainly the first thing to confirm.

If wicd is set to manage eth0, then it will do so according to wired-settings.conf. There's barely any magic involved at all, though in some cases mis-behaviour would be due to some bug rather than configuration mistakes. So let's see yours.

Offline

#3 2018-06-03 18:38:17

ks
Member
Registered: 2018-05-08
Posts: 12  

Re: Minor problem with laptop installation

Ok, I just played around with it again, and I remembered that when I originally became somewhat frustrated with it at first it worked for a while, but if I switch between wired and wireless more than once it loses the ability to connect to the wired eth0. Even if I switch OFF wireless it can no longer do wired. So in the end I just reinstalled my zero size wired-settings.conf to have wicd ignore the wired netcard (Don't know if it has anything to do with it but I often can see up to a dozen accesspoints, some of them open [no passwd required]).

Here's the wired-settings.conf that worked temporarily:

[wired-default]
afterscript = None
dhcphostname = is.work-lanname
postdisconnectscript = None
dns_domain = workplace.tld
gateway = 192.168.0.64
use_global_dns = False
lastused = True
encryption_enabled = False
beforescript = None
ip = 192.168.0.8
broadcast = None
netmask = 255.255.255.0
usedhcphostname = 0
predisconnectscript = None
enctype = None
default = 1
dns2 = 192.168.0.64
search_domain = None
use_static_dns = True
dns3 = None
profilename = wired-default
dns1 = 192.168.0.63

Here's my manager-settings.conf:

[Settings]
backend = external
wireless_interface = eth1
wired_interface = eth0
wpa_driver = wext
always_show_wired_interface = False
use_global_dns = False
global_dns_1 = None
global_dns_2 = None
global_dns_3 = None
global_dns_dom = None
global_search_dom = None
auto_reconnect = True
debug_mode = 0
wired_connect_mode = 1
signal_display_type = 0
should_verify_ap = 1
dhcp_client = 0
link_detect_tool = 0
flush_tool = 0
sudo_app = 0
prefer_wired = False
show_never_connect = True

Maybe you see something in there, if not, I'll keep my current setup with the 0-size wired-settings.conf

Offline

#4 2018-06-03 19:08:37

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 260  

Re: Minor problem with laptop installation

Well, if things work as is, then you may well leave it at that.

Otherwise, the one thing I could pick up was the missing broadcast address in wicd-wired-settings.conf, which might make a difference; perhaps it causes the networking stack to fail in its ARP. You should probably assign that to 192.168.0.255 or whatever is correct for your subnet.

And otherwise^2, I think the "proper" way to avoid wicd managing eth0 would be to avoid the wired_interface = eth0 assignment in wicd-manager-settings.conf, and instead make that wired_interface = (or remove it, perhaps). For myself, I use wicd-curses rather than editing the configuration files directly.

Offline

Board footer