The officially official Devuan Forum!

You are not logged in.

#1 2018-01-13 22:26:44

Altoid
Member
Registered: 2017-05-07
Posts: 34

[Solved] LinSSID permission (?) problem

Hello:

I have installed LinSSID 2.7 but it will not run from 'Menu' -> 'Internet' -> LinSSID. 
It asks for my PW and when I enter it and continue, it stalls/waits for a while and then nothing.

I can only run it successfully from the terminal via 'su'.
I have not set up 'sudo' (would rather always have a PW prompt).

Even though it starts and runs properly, when run as root there's some authentication failed output on the terminal:

root@devuan:/home/groucho# linssid
Xlib:  extension "RANDR" missing on display ":0.0".
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
root@devuan:/home/groucho# 

I know about the "RANDR" missing as it is disabled by the X server.

root@devuan:/home/groucho# cat /var/log/Xorg.0.log | grep WW
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    28.862] (WW) NVIDIA: The Composite and Xinerama extensions are both enabled, which
[    28.862] (WW) NVIDIA:     is an unsupported configuration.  The driver will continue
[    28.862] (WW) NVIDIA:     to load, but may behave strangely.
[    28.862] (WW) NVIDIA: Xinerama is enabled, so RandR has likely been disabled by the
[    28.862] (WW) NVIDIA:     X server.
root@devuan:/home/groucho# 

But I have no idea of the authetication protocols.

I have installed gnome-system-tools to have a GUI for groups and users management but I do not see a group for LinSSID. 

Base info:

groucho@devuan:~$ uname -a
Linux devuan 3.16.0-4-amd64 #1 SMP Debian 3.16.51-3 (2017-12-13) x86_64 GNU/Linux
groucho@devuan:~$ 

I'd appreciate a lead on this.

Thanks in advance,

A.

Last edited by Altoid (2018-03-21 12:17:03)

Offline

#2 2018-01-24 01:27:05

MiyoLinux
Member
Registered: 2016-12-05
Posts: 555

Re: [Solved] LinSSID permission (?) problem

Altoid,

Do you have gksu installed?

If so, can you open the terminal and enter...

gksu linssid

(not sure if that's the right command...use whatever command you used with su)

Does it work that way?

If it does, you could change the Exec= command for it in /usr/share/applications

Exec=gksu linssid

(or gksu "whatever-the-command-is")

Last edited by MiyoLinux (2018-01-24 01:30:47)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#3 2018-01-24 02:19:40

Altoid
Member
Registered: 2017-05-07
Posts: 34

Re: [Solved] LinSSID permission (?) problem

Hello:

I finally found out that the problem was related to a bug in a Qt5 library, libQt5XcbQpa.so.5.10.0.
It wreaked absolute havok in quite a few Qt5 based applications (Master PDF Editor, LinSSID, VLC Media Player and others).

See here:
https://bugreports.qt.io/browse/QTBUG-65235

I found out the details by checking in dmesg:

[groucho@groucho ~]$ dmesg | tail
[ 4504.398528] linssid[25147]: segfault at 8 ip 00007ff9488216fc sp 00007ffe49995f10 error 4 in [color=red]libQt5XcbQpa.so.5.10.0[/color][7ff9487e0000+154000]
[ 4590.791671] vlc[25397]: segfault at 8 ip 00007f4e28eca6fc sp 00007f4e401b2720 error 4 in [color=red]libQt5XcbQpa.so.5.10.0[/color][7f4e28e89000+154000]
[groucho@groucho ~]$

This was/will be solved with a new release of the QT5 files.

Cheers,

A.

Offline

#4 2018-01-31 22:30:52

Altoid
Member
Registered: 2017-05-07
Posts: 34

Re: [Solved] LinSSID permission (?) problem

Hello:

Sorry ...
I have to quote myself.  8^ /

Altoid wrote:

... the problem was related to a bug in a Qt5 library, libQt5XcbQpa.so.5.10.0.

This is what you get when you use two very different (sans systemd) distributions.
PCLinuxOS which is my rolling option and Devuan which installed as soon as I could download it.
The problem with the Qt5 library was in PCLinuxOS, so disregard my previous post.

The problem in the OP is still there.

Indeed, I can run LinSSID from a terminal via kksudo and it will open and work properly.

But it leaves this trail on the terminal screen (the Qt part confused me as a similar one was present in my other installation).

[groucho@groucho ~]$ gksu linssid
Xlib:  extension "RANDR" missing on display ":0".

gksu-run: 0977a691650adf37a6e3a38f67f0a763

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Qt: Session management error: None of the authentication protocols specified are supported
[groucho@groucho ~]$ 

Any ideas as to how to fix this?
Must be a permission problem (?) as LinSSID has to run IWScan which nees root access.

Thanks in advance.

A.

Offline

#5 2018-03-01 16:23:27

Altoid
Member
Registered: 2017-05-07
Posts: 34

Re: [Solved] LinSSID permission (?) problem

Hello:

Altoid wrote:

Hello:
Sorry ...

Bump ...

Anyone?

Edit 20180321:

Evidently not.  =-/
No matter.

With the help of one of the admins at the Xfce forum, I finally managed to track down the problem to the *.desktop file launching LinSSID.
It was using gksudo in the command line but as I have chosen not to use sudo and restrict myself to using su (as done in PCLinuxOS), the app would not launch.

A duh moment?
Indeed, but ...
Needing LinSSID admin privileges to run, shouldn't the installation routine check for sudo being present and if not, make the exec use su instead?

In any case, changing the command to

gksu linssid

fixed the issue.

Cheers,

A.

Last edited by Altoid (2018-03-21 12:24:49)

Offline

Board footer