The officially official Devuan Forum!

You are not logged in.

#1 2017-11-10 20:58:59

Monti
Member
Registered: 2017-09-25
Posts: 27

Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Hi guys

I have set Wicd Network Manager to automatically connect to our home wifi, but nothing happens.

Wicd is starting automatically, but to get the list of wifi networks I have to press 'Switch Of Wi-Fi' twice before it actually turns of. Then I turn it on again and press 'Refresh'. Now the list of different wifi networks appears where our network with the 'Automatically connect to this network' checkbox is checked. If I press 'Connect' it connects.

The wifi signal strength is 100%

Does anyone know what is happening here?

Interfaces in /etc/network only shows:

auto lo
iface lo inet loopback

wlan0 adapter is Broadcom BCM4312 802.11b/g LP-PHY

configuration is:

configuration: broadcast=yes driver=b43 driverversion=3.16.0-4-amd64 firmware=666.2

Thanks

Last edited by Monti (2017-11-10 21:01:34)

Offline

#2 2017-11-11 02:16:45

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 389
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Did you check on your connection "always connect automatically" and "never connect" on all others?
Wicd seems to work better when you don't actually get into it (the gui).

Offline

#3 2017-11-11 14:25:15

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Thank you for your reply @fungus

Right out of the box Wicd seems kind of broken. That is, if there is no compatibility issue with the Broadcom BCM4312 adapter.

I have tried to check the 'Never connect to this network' on all the other networks but it does not make any difference.

For the record and repeating details in my initial post:
- At start no wifi networks appear in the Wicd networks window
- Pressing 'Refresh' button does not seem to initialize anything. So no networks appear
- One have to press 'Switch Off Wi-Fi' twice to make it turn off
- When turning on again and then pressing 'Refresh' button networks appear
- Signal strenght with desired wifi network is mostly showing 100%, but has been noted going down to 88%

For a non-technical person doing the steps above would be counter intuitive. Which applies to my better half who is going to use the computer smile

People ask me which OS i would recommend and until Devuan arrived I have been uncertain what to recommend. I am currently using FreeBSD my self coming from MS Windows and have not been willing to use time learning a systemd system. My point is that having Wicd working as it should would be a good thing for non-tech people when switching between different wifi networks and wired.

I am not sure what you mean when you say "Wicd seems to work better when you don't actually get into it...".

Until Wicd would work without issues the closest alternative for me would be to do a manual configuration. So I can ask if the configuration below would be correct and recommended?:

In /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/network/wpa-psk-tkip.conf

In /etc/network/wpa-psk-tkip.conf:

ctrl_interface=/var/run/wpa_supplicant

network={
	ssid="xxxxxxxxx"
	key_mgmt=WPA-PSK
	proto=WPA
	pairwise=TKIP
	group=TKIP
	psk="xxxxxxxxx"
}

Thanks

Offline

#4 2017-11-11 15:12:18

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 389
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Wicd and wicd-gtk gui are different/separate.  As long as it is configured right and the gui is not employed it seems to be reliable, till something changes.  You want to log in to a different network, changed parameters on the router, etc.
As soon as you open up that damn thing having lost the connection you could be there playing with it for 45' and just about when you get it right all this lag till it shows as connected have forced you to retry again.
Connman in my experience is a bit better with wifi than wicked wicd.

In another distribution (OpenRC) I use plain network-manager which also has a tui for setting up network while on the console.  It is bulletproof.  You set everything once and forget it exists.  No wicd no connman nothing fancy.

I believe some of this stuff suffer from remaining weirdness from systemd-debian.  But wicd was just as crappy in Debian too.  Actually I haven't noticed any change in crapiness in Wicd for years.  Someone else with much more technical abilities can probably explain all this better.  I would rather deal with other things than making a connection to my simplistic lan.  It is a pain in the neck, I think we can agree on this.

Offline

#5 2017-11-11 15:17:10

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 389
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

1  I don't know if anyone else has experienced this, but I have set in various locations the wifi with wpa/wpa2 and a passphrase, hidden ssid.  I enter the same parameters on wicd and it will not log in.  I try wep on the client side and it works. without changing anything on the host.  Then I let it run for a while, look back and has switched on its own the parameters to the right ones WPA2.

This is why I hate wicd

2  I let it discover the parameters on its own in terms of IP, dns, gateway etc.  I read the information of the connection and I make sure on the router that this particular ID is reserved for this MAC.  I go to wicd-gtk and enter the fixed ip, gateway, etc.
I reconnect, it is picking up a different IP even though nothing is connected to the previous one and I have explicitly told it to go to this IP.

It is alive I tell you!

Last edited by fungus (2017-11-11 15:21:07)

Offline

#6 2017-11-11 18:49:42

cynwulf
Member
Registered: 2017-10-09
Posts: 107

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

It was always better to configure via wpa_supplicant / /etc/network/interfaces

https://wiki.debian.org/WiFi/HowToUse#wpa_supplicant

(wicd and networkmanager are turds)

Offline

#7 2017-11-11 19:57:12

greenjeans
Member
Registered: 2017-04-07
Posts: 377
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

FYI wicd is just specific about which routers it likes, and those it doesn't like. There are also unresolved conflicts with other programs in the repo, using the Aurora theme engine for instance will screw wicd up BAD, I have no idea why but as yet no warning about that in the package description, Aurora has had problems with multiple programs for years, and needs to be dropped or fixed. Damn shame as it's very pretty.

Some routers wicd will put up the list and will try to connect, but hang up at the IP address portion, anytime you see wicd hanging up on that last step for more than a few seconds, click cancel and then try again and it will usually connect.


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Please donate to support Devuan and init freedom! https://devuan.org/os/donate

Online

#8 2017-11-11 20:21:39

MiyoLinux
Member
Registered: 2016-12-05
Posts: 309

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

That's why I switched over to connman and cmst on my latest releases... ;p

Seems to be much less finicky... wink


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#9 2017-11-11 20:59:12

greenjeans
Member
Registered: 2017-04-07
Posts: 377
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

MiyoLinux wrote:

That's why I switched over to connman and cmst on my latest releases... ;p

Seems to be much less finicky... wink

Reminds me, I need to download your latest and check out all the cool stuff i'm gonna steal for next version of Vuu-do wink


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Please donate to support Devuan and init freedom! https://devuan.org/os/donate

Online

#10 2017-11-11 21:45:31

MiyoLinux
Member
Registered: 2016-12-05
Posts: 309

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

greenjeans wrote:
MiyoLinux wrote:

That's why I switched over to connman and cmst on my latest releases... ;p

Seems to be much less finicky... wink

Reminds me, I need to download your latest and check out all the cool stuff i'm gonna steal for next version of Vuu-do wink

You can't...'cause I stole stuff from you. LOLOL! big_smile


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#11 2017-11-11 22:18:07

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Thanks a lot for your additional elaboration @fungus.

And thanks a lot to the rest of you too. Appreciate the humor @greenjeans and @MiyoLinux big_smile

Appreciate getting things into perspective. I'll look into the different alternatives starting with wpa_supplicant

Offline

#12 2017-11-12 00:45:42

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 389
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Has it ever crossed your minds (Vuu-Yo & Mi-Do) to collaborate and just produce one distribution with 2 variations (Light & Extra) ?
Some of us fans are getting a bit dizzy.

Offline

#13 2017-11-12 22:42:58

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Hello Guys,

I am wondering why the script S03wicd is located at all folders from rc2.d to rc5.d ? I have understood it as all the folders represent runlevels during boot.

Also, I am wondering how to permanently turn of the Wicd service startup?

Would for example:

update-rc.d wicd disable

disable wicd on all runlevels? Then again, would:

update-rc.d wicd enable

enable on all levels? Or is this a overly complicated way of doing it? The latter meaning affecting many files.

Thanks

Last edited by Monti (2017-11-12 23:23:02)

Offline

#14 2017-11-13 06:09:12

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 389
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

I believe that those are the defaults in most init systems to configure and make a connection, if it is not already on from the previous level, and then to logoff the network (however it is continued) before shutdown or reboot.
One of the reasons that "some" distributions are taking too long to boot and get to a login screen (console or DM) is that if it takes too long to login to network it stays in that stage till some time-limit is reached.
At least that was my experience and that is what I think.

You want to disable wicd so you don't have networking until you decide to connect or to stop using wicd and use a different method?  If you were to remove wicd I believe part of the procedure would be to remove it from the init system as well, as if you install something else it is probably preconfigured in some default way within the init system.

Last edited by fungus (2017-11-13 15:58:51)

Offline

#15 2017-11-13 12:12:52

fsmithred
Administrator
Registered: 2016-11-25
Posts: 471

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

In Debian and Devuan (and many other derivatives), runlevels 2-5 are the same.

To disable wicd in all runlevels:

update-rc.d -f wicd remove

To reverse the above:

update-rc.d wicd defaults

Another way to do it is to install sysv-rc-conf and un-check all runlevels on the wicd line. (use arrow keys and space bar)

Offline

#16 2017-11-13 14:13:19

cynwulf
Member
Registered: 2017-10-09
Posts: 107

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Still not clear on what you're trying to achieve here.

From your second post it's clear that you have stanzas in /etc/network/interfaces for a wlan0 device and it's all configured to connect to the access point using wpa_supplicant configuration?  Then you've installed wicd as well and setting that to run as a daemon?  wicd won't be able to claim the wlan0 device and manage the connection as you've already configured and connected it in /etc/network/interfaces

The best way to stop wicd running on startup is to just remove the package, which will disable and remove it's rc scripts automatically.

Offline

#17 2017-11-13 21:29:22

greenjeans
Member
Registered: 2017-04-07
Posts: 377
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

Boot-up Manager is in the repo if you need an easy GUI way to disable items from startup, I use it in Vuu-do to turn off bluetooth, cups etc.


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Please donate to support Devuan and init freedom! https://devuan.org/os/donate

Online

#18 2017-11-13 23:13:16

MiyoLinux
Member
Registered: 2016-12-05
Posts: 309

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

fungus wrote:

Has it ever crossed your minds (Vuu-Yo & Mi-Do) to collaborate and just produce one distribution with 2 variations (Light & Extra) ?
Some of us fans are getting a bit dizzy.

I kept hoping greenjeans would address this. LOLOL!

Personally, I see Vuu-do and Miyo as two separate entities.

Greenjeans and I have different styles and end-goals...

I put out an .iso periodically; greenjeans updates his .isos more often.
I try to offer users a minimal system; greenjeans offers users an even more minimal system.
I try to offer a "somewhat" modern look; greenjeans keeps his UI more classic.
I like to see if I can stretch the bounds of Openbox just a little at a time; greenjeans likes to improve Openbox's classic experience.
I recently ventured into LXQt; greenjeans offers Mate.

I think both Vuu-do and Miyo probably appeal to different types of people...and that's a good thing. The end result is that people are using Devuan.

I personally bow to greenjean's ingenuity. He has done things that I would never have thought of or considered. Could we collaborate? Sure. Should we collaborate? I think there are different people who are looking for what both of us try to offer, so with that in mind, I think a Vuu-yo or Mi-do would be more of a hindrance to the end-users rather than a help.

My friend greenjeans and I aren't in competition with each other. If he gets 1,000 downloads a week, and I get 1...that's a win for Devuan. smile

More importantly, there is Crowz, Nelum, and Star...who offer Devuan Openbox distros...all of whom I'm in awe of (and I mean that).


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#19 2017-11-13 23:53:55

greenjeans
Member
Registered: 2017-04-07
Posts: 377
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

MiyoLinux wrote:

I kept hoping greenjeans would address this. LOLOL!

You are way more eloquent than I am, so I waited you out!

Couldn't have put it better. I LOVE your style, your sense of the aesthetic, color choices, the excellent Miyolinux Dark OB theme, and your ability to reach outside the repo to find new and innovative solutions like Obmenu-generator and the Numix themes.

I think our work the last few months has really complimented each other, I know mine is vastly improved due to the Miyo influence.

But in the end, more is better, even if it's a bunch of one-man shows like we got going. Makes for a healthy, diverse, and robust development environment. I'm super happy with what's happening here, and looking forward to ascii and beowulf for new challenges.

I keep hoping i'll log on one day and see "Fungi-Linux" on the list wink


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Please donate to support Devuan and init freedom! https://devuan.org/os/donate

Online

#20 2017-11-14 03:10:54

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 389
Website

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

greenjeans wrote:

I keep hoping i'll log on one day and see "Fungi-Linux" on the list wink

You never know when a mushroom may pop-out, maybe in the fall, maybe in the spring, after a flood, or after a fire, you just don't know.

miyo wrote:

1  I put out an .iso periodically; greenjeans updates his .isos more often.
2  I try to offer users a minimal system; greenjeans offers users an even more minimal system.
3  I try to offer a "somewhat" modern look; greenjeans keeps his UI more classic.
4  I like to see if I can stretch the bounds of Openbox just a little at a time; greenjeans likes to improve Openbox's classic experience.
5  I recently ventured into LXQt; greenjeans offers Mate.

1  In terms of a system upgrade I think it is irrelevant, for a distro that is rolling and running.  Have I told you of my experiment of using an old wheezy image to install then converted to ceres?  It worked!  But since your custom work is not in the system it would be missed.  Have you (pl) thought of creating patches that would compliment an existing installation?  Sometimes "your fans" after installing and doing their own modifications they don't want to reinstall, and not everyone goes luting and scavenging on live systems and distros to transfer stuff back to the cabin (like some people we know smile.
2  I am with miyo on that one, GJ is a bit too extreme in that respect on my taste.  There are certain things that I want running before I get to console or wake up old tired X for his breakfast.  So based on your systems the best I have gotten getting to the DM and logged in is 178MB  But I don't see why there can't be variations and compromises or cohabitation.
3  I am with GJ this time.  I appreciate your artistic icon work and space age surroundings, I believe you have been watching too many refracta scary sci-fi movies, but I am a back to the roots with wood and stone kind of person.  Putting bullet holes on NatBo cans is all the artistic expression I desire, and a bit of guitar sliding. 
4  If I ever get the courage to start hacking source-code it would be the openbox source, but I don't see the two approaches in conflict with each other, it is more of a compliment to each other in this respect.  Your menu work (miyo) is an art in itself.  My own evolution of the dynamic menu has been to be long and skinny, an icon and three-four letters is all it takes.  For example rtlf (is gksudo leafpad), rslv (is a script feeding the quickest of openic dns servers into resolv.conf).
5  I always thought that qt was a little too flaky for me, then I tried redcore, a little birdy told me to.  MAAAAANNN...  get me out of there.  Mate, nowhere as bad as other desktops, gives me the feeling of being in a white room, like an interrogation room or a surgery room.  Creepy cold and painful.  Nothing like the good old fluffy couch called lxde.  But when it is time for work nothing beats openbox.  I've tried i3 for 43', awesome for 3hrs, jwm ...  been there seen that, ...  I forget the rest.

Devuan is just like an old VW bug (for west of the Atlantic) or a Peugeot 106 for the East.  Both boring but there is so  much you can do with  it.  Between the 200hp buggy and a stripped out rallycross monster 106 there is definitely some character.

You have empowered people to hack their own in a period where systemd had taken the fun away.  In the past few years with debian everytime you turned your head around systemd had thrown your work away and replaced it with its defaults.

PS  What I liked out of the whole experience with redcore was the music while entering the desktop  (hint hint hint).

Last edited by fungus (2017-11-14 03:22:04)

Offline

#21 2017-11-18 21:21:24

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

fungus wrote:

I believe that those are the defaults in most init systems to configure and make a connection, if it is not already on from the previous level, and then to logoff the network (however it is continued) before shutdown or reboot.
One of the reasons that "some" distributions are taking too long to boot and get to a login screen (console or DM) is that if it takes too long to login to network it stays in that stage till some time-limit is reached.
At least that was my experience and that is what I think.

You want to disable wicd so you don't have networking until you decide to connect or to stop using wicd and use a different method?  If you were to remove wicd I believe part of the procedure would be to remove it from the init system as well, as if you install something else it is probably preconfigured in some default way within the init system.

First sorry to all you guys for my late follow up, and thanks to you @fungus.

Regarding runlevels, thanks for the elaboration. Good to know.

Regarding Wicd, you are correct. Disable Wicd as a step towards trying wpa_supplicant instead.

Offline

#22 2017-11-18 21:39:29

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

fsmithred wrote:

In Debian and Devuan (and many other derivatives), runlevels 2-5 are the same.

To disable wicd in all runlevels:

update-rc.d -f wicd remove

To reverse the above:

update-rc.d wicd defaults

Another way to do it is to install sysv-rc-conf and un-check all runlevels on the wicd line. (use arrow keys and space bar)

Thank you @fsmithred

If I understand the manual correctly, when using the 'remove' command I have to remove the /etc/init.d script first, otherwise an error message. Do you agree?

I don't remember where, I believe I read that if using the 'disable' command instead it would stop the startup, but when a upgrade of Wicd happens, it would be overwritten and go back to default as before. I am guessing/asking if this would happen with 'remove' and removal of wicd script in /etc/init.d too. Which makes me think of maybe a complete uninstall of Wicd would be better in that regards. If ending up using wpa_supplicant that is.

Last, thank you for mentioning sysv-rc-conf and user guide smile

Last edited by Monti (2017-11-18 22:24:34)

Offline

#23 2017-11-18 23:09:51

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

cynwulf wrote:

Still not clear on what you're trying to achieve here.

From your second post it's clear that you have stanzas in /etc/network/interfaces for a wlan0 device and it's all configured to connect to the access point using wpa_supplicant configuration?  Then you've installed wicd as well and setting that to run as a daemon?  wicd won't be able to claim the wlan0 device and manage the connection as you've already configured and connected it in /etc/network/interfaces

The best way to stop wicd running on startup is to just remove the package, which will disable and remove it's rc scripts automatically.

Still not clear on what you're trying to achieve here.

Sorry about that. A personal "get to know" process on my part was revealed here smile

Besides of trying to get to know Wicd's behavior I was wondering how to do a manual config-file configuration.

When it comes to Wicd and/with /etc/network/interfaces I now know that the only entry allowed is the loopback interface.

Regarding wpa_supplicant stanzas I believe the configuration it self in /etc/network/interfaces was wrong by using a EPA-TLS configuration. EPA-TLS does not apply to our network smile

For the record I believe this configuration after disabling Wicd would be correct:

auto wlan0
iface wlan0 inet dhcp
        wpa-ssid myssid
        wpa-psk ccb290fd4fe6b22935cbae31449e050edd02ad44627b16ce0151668f5f53c01b

Manual on this page with link initially provided by you: https://wiki.debian.org/WiFi/HowToUse#W … d_WPA2-PSK

Regarding stopping Wicd from running on startup by just removing package this seems to be the way to make it completely consistent. But it does not seem very flexible. After starting using FreeBSD I have grown fond of doing manual configurations, so the first thing has been trying to learn about the capabilities of Devuan in this regard. I will check out sysv-rc-conf and Boot-up Manager too....

Last edited by Monti (2017-11-19 00:43:59)

Offline

#24 2017-11-18 23:15:17

Monti
Member
Registered: 2017-09-25
Posts: 27

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

greenjeans wrote:

Boot-up Manager is in the repo if you need an easy GUI way to disable items from startup, I use it in Vuu-do to turn off bluetooth, cups etc.

Thanks for the tip @greenjeans . Appreciate it.

Offline

#25 2017-11-18 23:21:25

fsmithred
Administrator
Registered: 2016-11-25
Posts: 471

Re: Wicd not auto connecting.. - Have to turn of/on/refresh to get list

'update-rc.d remove' will remove the symlinks. You do not need to remove the init script. I'm not sure if the symlinks will be regererated with normal updates, but. I just checked, and wicd is still installed here and turned off since I installed the system almost two years ago.

Offline

Board footer