The officially official Devuan Forum!

You are not logged in.

#1 2017-09-09 11:44:52

ilnanny
Member
Registered: 2017-09-09
Posts: 5

Locale Ita

Hello everyone .
I have a small problem with the localization of the Italian language.
I have configured local-gen, I added a line containing ":" $ {LANG: = it_IT.UTF-8} "; export LANG" in / etc / profile
I reconfigured everything with dpkg-reconfigure locales
installed all the packages in the Italian language.
But when I reboot I can not get the localized system in Italian.
Someone can help me figure out where I'm wrong. Thank you.
Sorry for my bad English.

*Prompt:

# locale-gen
  it_IT.UTF-8... done
Generation complete.
---------------------------------
# locale -a
C
C.UTF-8
POSIX
it_IT.utf8

--------------------------------

Last edited by ilnanny (2017-09-09 11:48:37)

Offline

#2 2017-09-09 13:01:15

fsmithred
Administrator
Registered: 2016-11-25
Posts: 444

Re: Locale Ita

I do it this way:

export LANG=it_IT.UTF-8
export LC_ALL=it_IT.UTF-8

Offline

#3 2017-09-09 13:12:31

ilnanny
Member
Registered: 2017-09-09
Posts: 5

Re: Locale Ita

fsmithred wrote:

I do it this way:

export LANG=it_IT.UTF-8
export LC_ALL=it_IT.UTF-8

I wrote it as root and restarted, but the result is always the same.

Offline

#4 2017-09-09 13:17:13

ilnanny
Member
Registered: 2017-09-09
Posts: 5

Re: Locale Ita

I solved by inserting in the .bashrc file of my user the string:
export LANG=it_IT.UTF-8
export LC_ALL=it_IT.UTF-8

even though this does not seem to me a user-friend result.
Can I put "solved" in the title?

Last edited by ilnanny (2017-09-09 13:17:34)

Offline

#5 2017-09-09 13:47:17

fsmithred
Administrator
Registered: 2016-11-25
Posts: 444

Re: Locale Ita

You can edit your first post to mark it solved, but there may still be a problem to solve.

For the devuan live-isos, I put those lines in /etc/profile.d/tt_locale.sh where they will affect all users. It should work for one user if you add those lines to ~/.profile.

If you chose Italian during the installation, you shouldn't need to do this. Which iso did you use for the installation?

Offline

#6 2017-09-09 13:57:39

ilnanny
Member
Registered: 2017-09-09
Posts: 5

Re: Locale Ita

fsmithred wrote:

You can edit your first post to mark it solved...

I used this live:
devuan_jessie_1.0.0_amd64_desktop-Live.iso ( https://devuan.c3l.lu/devuan_jessie/desktop-live/ )
I chose the Italian during installation (using refracta)
then as usual I've copied backup files for thunar and xfce, which I use both in gentoo and debian, but are just the xfce4 panel configurations and the custom thunar menu.

Last edited by ilnanny (2017-09-09 13:58:51)

Offline

#7 2017-09-10 13:24:15

fsmithred
Administrator
Registered: 2016-11-25
Posts: 444

Re: Locale Ita

Did you boot the live media in Italian (second option in the boot menu) or did you boot into English and then choose Italian during the installation?

Does /etc/profile.d/zz_locale.sh exist in the installed system?

Offline

Board footer