The officially official Devuan Forum!

You are not logged in.

#1 2017-08-11 20:02:52

GNUser
Member
Registered: 2017-03-16
Posts: 141

heimdall not working on Devuan Jessie [SOLVED]

TL;DR version: There is nothing wrong with your Devuan Jessie install or with your Samsung phone. You just need a more recent heimdall than what's in the Jessie repository smile Link to what you need is at the end of the post.

So, I got one Samsung Galaxy S5 for myself and one for the wife, with intention of installing TWRP recovery and LineageOS 14.1 on them. First step is to install TWRP via heimdall.

To test whether heimdall is working, put your phone in "Download mode" (with phone off: volume down + home + power), connect it to your GNU/Linux box, and run this in a terminal as regular user (i.e., without sudo):

heimdall print-pit

My heart sank when, on my Devuan system, this is what happens after the above:

ERROR: Failed to send request to end PIT file transfer!
ERROR: Failed to download PIT file!
Ending session...
ERROR: Failed to send end session packet!
Releasing device interface...

I got the idea in my head to try a newer heimdall package from Debian Stretch, Buster, or Sid. This is what I get with those:

heimdall: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./heimdall)
heimdall: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./heimdall)

The issue here, as you may have guessed, is that the newer packages are compiled against a glibc version that's newer than Jessie's (glibc is forwards-compatible but notoriously not always backwards-compatible).

What you need to do is to compile heimdall from source (to get latest version), on Devuan/Debian Jessie or older distro (so that the package is compiled against Jessie's glibc or older).

I did the above and all errors went away when I used the resulting binary. The phones are now loaded with TWRP and LineageOS cool

If you don't know how to compile or don't feel like the hassle...
Here is the .deb: heimdall-flash_1.4.2_amd64.deb
If you prefer just the binary, here is is: heimdall 1.4.2 amd64

Enjoy,
Bruno

Last edited by GNUser (2017-08-12 00:10:17)

Offline

Board footer