The officially official Devuan Forum!

You are not logged in.

#1 2017-07-17 08:21:56

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 497  
Website

Qupzilla will not upgrade

Although a newer version of qupzilla exists in ceres, and I have upgraded to ceres, 2 pkgs are held back and would cause breaks if upgraded.
Qupzilla and its dependency.  From 1.8.* in stable and ascii 2.1.2 is in ceres but cannot install.  http://dev1galaxy.org/viewtopic.php?pid=3398#p3398

Why is it even there if it is not installable?

Offline

#2 2017-07-17 14:20:35

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 497  
Website

Re: Qupzilla will not upgrade

It will not install in sid either

Offline

#3 2017-07-17 15:14:18

fsmithred
Administrator
Registered: 2016-11-25
Posts: 912  

Re: Qupzilla will not upgrade

Ceres and Sid have the same version. It's probably because qupzilla was built with newer qt5 libraries that haven't made it into the repo yet. Wait a few days or a few weeks and things should catch up.

Offline

#4 2017-07-17 16:16:34

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 497  
Website

Re: Qupzilla will not upgrade

Yes, that is what I have figured since.  The dependencies listed by qupzilla 2.1.2 don't yet exist in sid or ceres.  The maintainer should have held it back before placing it there.  It seems as things relatively unrelated to systemd get passed to unstable from sid without being tested that they would install and if the Debian sid maintainer hasn't done his/her/their job right ceres just follows suit.

Offline

Board footer