The officially official Devuan Forum!

You are not logged in.

#26 2020-05-23 09:44:51

pcalvert
Member
Registered: 2017-05-15
Posts: 75  

Re: Migrating from Buster to Beowulf - feedback needed

I migrated a new Debian Buster system to Beowulf, and things went well (for the most part). There is a problem, though. After the desktop appears, there is constant, non-stop disk activity. Running top shows a couple of CPU hogs:

udevd      20 to 30 % CPU
udisksd    14 to 20% CPU
udevd      1 to 2 % CPU

Based on a hunch, I uninstalled gvfs and the problem went away.

Phil

Last edited by pcalvert (2020-05-23 10:19:15)


“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln

Offline

#27 2021-01-06 22:19:17

little
Member
Registered: 2017-06-08
Posts: 25  

Re: Migrating from Buster to Beowulf - feedback needed

Having trouble with a Debian Buster VPS migrating to Beowulf. Dependency issues when trying to install eudev. See below. (some sections omitted for brevity). To be clear, I am following the docs from devuan.org (https://www.devuan.org/os/documentation/dev1fanboy/en/buster-to-beowulf ). Not the earlier instructions in this thread.

root@vps:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  aspell-eu-es
Use 'apt autoremove' to remove it.
The following packages have been kept back:
  libcolord2 libudev1 udev util-linux
The following packages will be upgraded:
  base-files bsdutils ca-certificates distro-info-data fdisk libblkid1 libfdisk1 libmount1 libpcsclite1 libprocps7 libsmartcols1 libuuid1
  mount procps python3-reportbug reportbug rsyslog sysvinit-utils task-amharic task-arabic task-asturian task-basque task-belarusian
  task-bengali task-bosnian task-brazilian-portuguese task-bulgarian task-catalan task-chinese-s task-chinese-t task-croatian
  task-cyrillic task-czech task-danish task-dutch task-english task-esperanto task-estonian task-finnish task-french task-galician
  task-german task-greek task-gujarati task-hebrew task-hindi task-hungarian task-icelandic task-irish task-italian task-japanese
  task-kazakh task-khmer task-korean task-kurdish task-laptop task-latvian task-lithuanian task-macedonian task-malayalam task-marathi
  task-northern-sami task-norwegian task-persian task-polish task-portuguese task-punjabi task-romanian task-russian task-serbian
  task-slovak task-slovenian task-spanish task-swedish task-tagalog task-tamil task-telugu task-thai task-turkish task-ukrainian
  task-welsh tasksel tasksel-data tzdata util-linux-locales uuid-runtime
86 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 4,510 kB of archives.
After this operation, 644 kB of additional disk space will be used.
Do you want to continue? [Y/n]


etting up task-khmer (3.54+devuan3) ...
Setting up task-gujarati (3.54+devuan3) ...
Setting up task-northern-sami (3.54+devuan3) ...
Setting up task-belarusian (3.54+devuan3) ...
Setting up task-english (3.54+devuan3) ...
Processing triggers for systemd (241-7~deb10u5) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10) ...
Processing triggers for ca-certificates (20200601~deb10u1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.


root@vps:~# apt-get install eudev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dconf-gsettings-backend : Depends: dconf-service (>= 0.30.1-2) but it is not going to be installed
                           Depends: dconf-service (< 0.30.1-2.1~) but it is not going to be installed
 libsoup2.4-1 : Depends: glib-networking (>= 2.32.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
root@vps:~#

Last edited by little (2021-01-06 22:24:15)


give a man an init, he takes an os

Offline

#28 2021-01-06 23:54:37

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 104  

Re: Migrating from Buster to Beowulf - feedback needed

From the link you posted above:

Once this is done eudev needs to be installed. Note that if you’re using Gnome it will be removed by this command, but can be installed again after migration.

root@debian:~# apt-get install eudev

The last command is known to cause package breaks but we will fix this as part of the migration process.

root@debian:~# apt-get -f install

Did you run "apt -f install"? Or "apt-get -f install"?

Offline

#29 2021-01-07 02:15:28

little
Member
Registered: 2017-06-08
Posts: 25  

Re: Migrating from Buster to Beowulf - feedback needed

Sorry, I wasn't clear. I did. See below:

root@vps:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  aspell-eu-es
Use 'apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
root@vps:~#

Reboot I think would be unwise as it didn't install eudev. Trying to install eudev again results in the same error. The only hint is that it's holding packages, and also on a VPS (yet kvm).

Last edited by little (2021-01-07 02:15:49)


give a man an init, he takes an os

Offline

#30 2021-01-07 07:46:37

the_edge123
Member
Registered: 2020-05-19
Posts: 8  

Re: Migrating from Buster to Beowulf - feedback needed

IIRC, you may reboot and continue the migration with:

apt-get dist-upgrade

--
Fabien

Offline

#31 2021-01-07 19:27:54

little
Member
Registered: 2017-06-08
Posts: 25  

Re: Migrating from Buster to Beowulf - feedback needed

No dice. Reboot works, but apt-get dist-upgrade results in being prompted to remove the running kernel. I don't agree to that, and then it breaks down.

I'm afraid I need to find a different VPS vendor. One that supports custom ISOs. For what it's worth, I migrated an identical Jessie or Stretch (forget now) Debian to Devuan some years ago with this vendor. Back then, the only trick was adding /etc/inittab. Now with Buster it's resulting in below.

Removing linux-image-amd64 (4.19+105+deb10u8) ...
Removing linux-image-4.19.0-13-amd64 (4.19.160-2) ...
E: Aborting removal of the running kernel
dpkg: error processing package linux-image-4.19.0-13-amd64 (--remove):
 installed linux-image-4.19.0-13-amd64 package pre-removal script subprocess returned error exit status 1
Removing bluetooth (5.50-1.2~deb10u1) ...
Removing bluez (5.50-1.2~deb10u1) ...
dpkg: initramfs-tools-core: dependency problems, but removing anyway as you requested:
 initramfs-tools depends on initramfs-tools-core (= 0.133+deb10u1).

Removing initramfs-tools-core (0.133+deb10u1) ...
Removing udev (241-7~deb10u5) ...
dpkg: initramfs-tools: dependency problems, but removing anyway as you requested:
 linux-image-4.19.0-13-amd64 depends on initramfs-tools (>= 0.120+deb8u2) | linux-initramfs-tool; however:
  Package initramfs-tools is to be removed.

  Package linux-initramfs-tool is not installed.
  Package initramfs-tools which provides linux-initramfs-tool is to be removed.
 linux-image-4.19.0-13-amd64 depends on initramfs-tools (>= 0.120+deb8u2) | linux-initramfs-tool; however:
  Package initramfs-tools is to be removed.
  Package linux-initramfs-tool is not installed.
  Package initramfs-tools which provides linux-initramfs-tool is to be removed.

Removing initramfs-tools (0.133+deb10u1) ...
Errors were encountered while processing:
 linux-image-4.19.0-13-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@vps:/#

Then:

root@vps:~# apt-get install eudev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 eudev : Depends: libeudev1 (= 3.2.7-6) but it is not going to be installed
         Breaks: systemd (> 220) but 241-7~deb10u5 is to be installed
 linux-image-4.19.0-13-amd64 : Depends: initramfs-tools (>= 0.120+deb8u2) but it is not going to be installed or
                                        linux-initramfs-tool
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@vps:~# apt-get purge systemd libnss-systemd
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 dbus-user-session : Depends: systemd but it is not going to be installed
 libpam-systemd : Depends: systemd (= 241-7~deb10u5) but it is not going to be installed
 linux-image-4.19.0-13-amd64 : Depends: initramfs-tools (>= 0.120+deb8u2) but it is not going to be installed or
                                        linux-initramfs-tool
 systemd-sysv : PreDepends: systemd but it is not going to be installed
                Recommends: libnss-systemd but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@vps:~# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 linux-image-4.19.0-13-amd64 : Depends: initramfs-tools (>= 0.120+deb8u2) but it is not installed or
                                        linux-initramfs-tool
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
root@vps:~#

Finally, stuck in dependency hell.

root@vps:~# sudo apt-get install libeudev1
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libeudev1 : Conflicts: libudev1 (< 1:3.2.7-6)
 linux-image-4.19.0-13-amd64 : Depends: initramfs-tools (>= 0.120+deb8u2) but it is not going to be installed or
                                        linux-initramfs-tool
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@vps:~# sudo apt-get install initramfs-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 initramfs-tools : Depends: initramfs-tools-core (= 0.133+deb10u1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@vps:~# sudo apt-get install initramfs-tools initramfs-tools-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 initramfs-tools-core : Depends: udev
                        Recommends: pigz but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@vps:~#

Last edited by little (2021-01-07 19:35:23)


give a man an init, he takes an os

Offline

#32 2021-01-07 21:46:41

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,257  
Website

Re: Migrating from Buster to Beowulf - feedback needed

Did you try installing sysvinit-core before attempting to install eudev?


Black Lives Matter

Offline

#33 2021-01-08 03:48:10

little
Member
Registered: 2017-06-08
Posts: 25  

Re: Migrating from Buster to Beowulf - feedback needed

So I bashed through a number of commands. I installed sysvinit-core, yes. I ended up removing the kernel, and then reinstalling it. Quite a mess, but I was able to get it to complete the install. At one point, it reboot with no eth0 iface, so the emergency console was used, and then after installing eudev and rebooting, everything looked right. I'll try to update this post with some steps for future reference. It was not straightforward, but it was possible. I suspect because this was a VPS.

Maybe I would've had better luck if I followed the instructions in this thread I had followed before for the RPI. Anyways, alls well that ends well.

EDIT: full guide to get migration working here: http://dev1galaxy.org/viewtopic.php?pid=26751#p26751

Last edited by little (2021-01-12 01:46:25)


give a man an init, he takes an os

Offline

Board footer