The officially official Devuan Forum!

You are not logged in.

#1 2020-09-10 13:59:54

Geoff 42
Member
Registered: 2016-12-15
Posts: 366  

Wireshark upgrade requires libsystemd0

I have just updated my laptop running chimaera and it holds back Wireshark on version 3.2.5-1 rather than upgrading to 3.2.6-1.
As far as I can see, this is because Wireshark has a dependency on  libsystemd0. I think it is wireshark-common that actually has the dependency.

Geoff

Last edited by Geoff 42 (2020-09-10 14:31:05)

Offline

#2 2020-09-10 14:20:42

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Wireshark upgrade requires libsystemd0

I think the libelogind0 package in chimaera needs a version bump, it provides libsystemd0 but wireshark-common now requires >=246.

Last edited by Head_on_a_Stick (2020-09-10 14:26:10)


Black Lives Matter

Offline

#3 2020-09-10 14:28:08

bgstack15
Member
Registered: 2018-02-04
Posts: 170  

Re: Wireshark upgrade requires libsystemd0

$ apt-cache show wireshark-common | grep -oE '^Version:.*$|libsystemd0 [^ ]+ [^ ]+'
Version: 3.2.6-1
libsystemd0 (>= 246),

Wireshark 3.2.6-1 depends on libsystemd0 version 246
The current libelogind0 is:

$ apt-cache show libelogind0 | grep -iE '^(Provides|Version):'
Version: 243.8-1
Provides: libsystemd0 (= 243.8)

Now this is for Ceres, so it's ahead of even Chimaera. Either upstream libelogind hasn't been updated yet, or we haven't gotten it into Devuan just yet. Nothing to worry about, really.

Edit: upstream elogind is at version 243.7.

Last edited by bgstack15 (2020-09-10 14:31:31)


This space intentionally left blank.

Offline

#4 2020-09-10 14:35:42

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Wireshark upgrade requires libsystemd0

https://github.com/elogind/elogind/issues/170

EDIT: so use equivs to create a fake package providing a newer version of libsystemd0 to satisfy the dependency until the new version of elogind is pushed.

Last edited by Head_on_a_Stick (2020-09-10 14:45:38)


Black Lives Matter

Offline

#5 2020-10-05 13:12:05

hagbard_
Member
Registered: 2020-10-05
Posts: 1  

Re: Wireshark upgrade requires libsystemd0

Fixed it like this:
- get the .deb of wireshark-common (apt-get get-deb-file)
- unpack the .deb (dpkg-deb -R) as fakeroot
- edit the DEBIAN/control file to lower the dependency of libsystemd0 from 246 to 243
- repack the .deb (dpkg-deb -b) as fakeroot
- install the .deb (dpkg -i)

And everything works fine.
Wireshark doesn't actually need libsystemd0 v246, except for one single thing, which is reading systemd journals, which don't exist in devuan anyways.
So it won"t be the worst idea to lower that dependency in the devuan repository, so users won't have to do the aforementioned procedure.

Last edited by hagbard_ (2020-10-05 13:14:03)

Offline

Board footer