The officially official Devuan Forum!

You are not logged in.

#1 2020-10-02 10:56:28

jdev
Member
Registered: 2020-06-09
Posts: 21  

lightdm Suspend/Hibernate/Restart/ShutDown disabled in greeter

I've installed xorg-driver-video, xorg-driver-input, openbox, lxsession, lxde-common, lxpanel, pcmanfm. The lightdm-gtk-greeter starts and I'm able to log in.

Prior to logging in, there is the greeter menu bar with the power icon and its menu items Suspend/Hibernate/Restart/ShutDown which all are disabled.

I'd like to enable these and to be able to select them without being logged in. What is to do?

Offline

#2 2020-10-02 11:33:11

rolfie
Member
Registered: 2017-11-25
Posts: 415  

Re: lightdm Suspend/Hibernate/Restart/ShutDown disabled in greeter

policykit

rolfie

Offline

#3 2020-10-02 11:38:08

jdev
Member
Registered: 2020-06-09
Posts: 21  

Re: lightdm Suspend/Hibernate/Restart/ShutDown disabled in greeter

rolfie wrote:

policykit

Somewhat more detailed would have been nice.

Offline

#4 2020-10-02 12:21:34

jdev
Member
Registered: 2020-06-09
Posts: 21  

Re: lightdm Suspend/Hibernate/Restart/ShutDown disabled in greeter

Adding session optional pam_elogind.so to /etc/pam.d/lightdm-greeter enables the menu items. See Debian Bug #932047 (lightdm: greeter session support for elogind).

Offline

#5 2020-10-03 10:03:11

jdev
Member
Registered: 2020-06-09
Posts: 21  

Re: lightdm Suspend/Hibernate/Restart/ShutDown disabled in greeter

Actually it is a missed systemd dependency that should be corrected.

Instead of session optional pam_systemd.so there has to be session optional pam_elogind.so.

Offline

#6 2020-10-03 11:56:56

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,640  

Re: lightdm Suspend/Hibernate/Restart/ShutDown disabled in greeter

This is fixed in chimaera/ceres: https://git.devuan.org/devuan/lightdm/s … /changelog

The fix is also in beowulf-proposed-updates and will be in the 3.1 point-release.

Offline

Board footer