The officially official Devuan Forum!

You are not logged in.

#1 2020-08-09 08:58:26

RJVB
Member
Registered: 2020-07-24
Posts: 8  

changing locale for Cinnamon desktop

Hi,

I'm configuring a Cinnamon desktop for a user who wants to be able to use a different language than the default system language - and I don't mean just the *input* language.

Every other DE I've tried so far provides a config thingy to accomplish this, not so Cinnamon. Googling the issue provides one "easy" answer: install the mintlocale utility.

Except that Devuan doesn't provide it, and the stock version depends on LInux Mint specifics that can undoubtedly be adapted (but not by someone like me who doesn't know Mint and hardly knows Devuan for now).

I don't know where to file a request to add this utility but in the meantime, has anyone actually managed to change the language used throughout a Cinnamon session? So far I've tried to set $LANG and $LANGUAGE in the usual shell startup scripts (.bashrc, .profile, .login) but it appears something is overwriting them.

Offline

#2 2020-08-09 11:44:28

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,000  
Website

Re: changing locale for Cinnamon desktop

RJVB wrote:

So far I've tried to set $LANG and $LANGUAGE in the usual shell startup scripts (.bashrc, .profile, .login) but it appears something is overwriting them.

How about ~/.xsessionrc?

Disclaimer: I don't use Cinnamon.


Black Lives Matter

Offline

#3 2020-08-09 13:53:49

RJVB
Member
Registered: 2020-07-24
Posts: 8  

Re: changing locale for Cinnamon desktop

I think I finally managed through a combination of changing the settings in that file and in /etc/default/locale. It worked, but it's not exactly the kind of (novice) users of an otherwise fancy and frankly quite nice looking desktop to have to jump through.

I even installed an admittedly basic version of the Gnome desktop to be able to follow instructions I found related to the gdm display manager (hoping that would ease my pains) but no such luck (and I quickly remembered why I loathe that DE so much).

Full disclosure: I'd have put that user under KDE but for some reason it starts to a black screen, I guess because the imported $HOME was configured to use a KDE Plasma4 desktop (and possibly because Devuan's KDE version isn't exactly the latest). I'd have reinstalled Plasma4 if someone still provided packages for it; it still works just fine and KF5 applications integrate seamlessly with it.

Offline

#4 2020-08-09 15:50:18

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,000  
Website

Re: changing locale for Cinnamon desktop

RJVB wrote:

I think I finally managed through a combination of changing the settings in that file and in /etc/default/locale

Probably better to use the supplied abstraction mechanism to modify /etc/default/locale:

# dpkg-reconfigure locales
RJVB wrote:

it's not exactly the kind of (novice) users of an otherwise fancy and frankly quite nice looking desktop to have to jump through

Devuan isn't really aimed at n00bs, perhaps try one of the derivatives instead.

Or you could try installing the Mint .deb package:

http://packages.linuxmint.com/pool/main/m/mintlocale/


Black Lives Matter

Offline

#5 2020-08-09 17:04:46

RJVB
Member
Registered: 2020-07-24
Posts: 8  

Re: changing locale for Cinnamon desktop

Head_on_a_Stick wrote:

Probably better to use the supplied abstraction mechanism to modify /etc/default/locale:

# dpkg-reconfigure locales

Why? The files in /etc/default aren't part of any package as far as I can see, and rightfully so as they're the official way to modify behaviour. Or maybe the abstraction mechanism is just a fancy, obfuscated way to achieve the same thing.

Devuan isn't really aimed at n00bs, perhaps try one of the derivatives instead.

That's more for installing and setting up, no? Once you have a full desktop installed I'd expect that to be as n00b friendly as the same desktop on any other distribution (and this is true for the other desktops I tested).

Or you could try installing the Mint .deb package:

http://packages.linuxmint.com/pool/main/m/mintlocale/


As I said that doesn't work because it requires mint-common which is just non-trivial enough to get to build/install. The maintainer(s) of the Cinnamon packages should have a quick look and include it by default.

I've seen screenshots of GDM providing a language choice during the login procedure and I definitely remember having used such "greeters" myself; it seems like the Unix way of doing things.

Offline

#6 2020-08-09 17:07:46

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,000  
Website

Re: changing locale for Cinnamon desktop

RJVB wrote:
Head_on_a_Stick wrote:

Probably better to use the supplied abstraction mechanism to modify /etc/default/locale:

# dpkg-reconfigure locales

Why?

Try it and see wink

RJVB wrote:

Or maybe the abstraction mechanism is just a fancy, obfuscated way to achieve the same thing.

^ This.


Black Lives Matter

Offline

Board footer