The officially official Devuan Forum!

You are not logged in.

#1 2020-07-04 16:51:07

erdos
Member
Registered: 2018-06-04
Posts: 39  

'scim' input method stopped working on beowulf

hi, I use 'scim' on beowulf to input Chinese character if needed.

It seems that 'scim' stopped working, pressing 'ctl + space' doesn't switch between english and chinese input methods anymore. I have tried to reinstall 'scim' and reboot the machine to no avail. 

Here's the output of .xsession-errors

erdos@devuan:~$ tail -50 .xsession-errors
localuser:erdos being added to access control list
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting VNCDESKTOP=devuan:1 (erdos)
dbus-update-activation-environment: setting MAIL=/var/mail/erdos
dbus-update-activation-environment: setting USER=erdos
dbus-update-activation-environment: setting SSH_AGENT_PID=2479
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting SHLVL=1
dbus-update-activation-environment: setting QT4_IM_MODULE=scim
dbus-update-activation-environment: setting HOME=/home/erdos
dbus-update-activation-environment: setting DESKTOP_SESSION=xfce
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-V7IEH8kxiU,guid=d582b50c75fd98a06cb00a415f02a314
dbus-update-activation-environment: setting COLORTERM=truecolor
dbus-update-activation-environment: setting GLADE_MODULE_PATH=:
dbus-update-activation-environment: setting GTK_IM_MODULE=scim-bridge
dbus-update-activation-environment: setting LOGNAME=erdos
dbus-update-activation-environment: setting WINDOWID=62914563
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting LIBOVERLAY_SCROLLBAR=0
dbus-update-activation-environment: setting TERM=xterm-256color
dbus-update-activation-environment: setting GTK_OVERLAY_SCROLLING=0
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting SESSION_MANAGER=local/devuan:@/tmp/.ICE-unix/2573,unix/devuan:/tmp/.ICE-unix/2573
dbus-update-activation-environment: setting GLADE_PIXMAP_PATH=:
dbus-update-activation-environment: setting XDG_MENU_PREFIX=xfce-
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:1
dbus-update-activation-environment: setting LANG=en_US.UTF-8
dbus-update-activation-environment: setting XDG_CURRENT_DESKTOP=XFCE
dbus-update-activation-environment: setting XMODIFIERS=@im=SCIM
dbus-update-activation-environment: setting XAUTHORITY=/home/erdos/.Xauthority
dbus-update-activation-environment: setting LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
dbus-update-activation-environment: setting SSH_AUTH_SOCK=/tmp/ssh-ddCH10yy4ejH/agent.2374
dbus-update-activation-environment: setting GLADE_CATALOG_PATH=:
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting QT_IM_MODULE=xim
dbus-update-activation-environment: setting PWD=/home/erdos
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/etc/xdg
dbus-update-activation-environment: setting CLUTTER_IM_MODULE=scim
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/xfce4:/usr/share/xfce4:/usr/local/share/:/usr/share/:/usr/share
dbus-update-activation-environment: setting VTE_VERSION=5402
/usr/bin/x-session-manager: X server already running on display :1
xfce4-session: Another session manager is already running

any advice?

Last edited by erdos (2020-07-06 04:30:50)

Offline

#2 2020-07-08 00:05:30

erdos
Member
Registered: 2018-06-04
Posts: 39  

Re: 'scim' input method stopped working on beowulf

I resolved my issue by creating a ~/.Xsession file in home directory:

LANG=en_US.UTF-8
export LANG
XMODIFIERS="@im=SCIM"
export XMODIFIERS
GTK_IM_MODULE="scim"
export GTK_IM_MODULE
scim -d&

startxfce4

Offline

#3 2020-07-08 20:36:17

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 841  
Website

Re: 'scim' input method stopped working on beowulf

erdos wrote:

I resolved my issue by creating a ~/.Xsession file in home directory

Probably better to add the scim stuff to ~/.xsessionrc, that should be applied to any and all graphical desktops.

The environmental variables could be exported from /etc/environment (or in their own file under /etc/environment.d/).


Black Lives Matter

Offline

Board footer