The officially official Devuan Forum!

You are not logged in.

#1 2020-06-29 12:57:21

HevyDevy
Member
Registered: 2019-09-06
Posts: 263  

Solved - xfce4 session issues

New beowulf stable bios install.

Having issues with xfce4 and loging out rebooting poweroff function.

Ive installed elogind and lightdm but when i try to logout it says

Failed to run action "Log Out..."

Session manager must be in idle state when requesting a shutdown

There is no session being saved even when i ask it too in session and startup.

 ps -ef | grep session

root      2019  1918  0 22:49 ?        00:00:00 lightdm --session-child 12 21
user     2040     1  0 22:49 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session --sh-syntax
user     2041     1  0 22:49 ?        00:00:00 /usr/bin/dbus-daemon --syslog --fork --print-pid 5 --print-address 7 --session
user     2050  2024  0 22:49 ?        00:00:00 xfce4-session
user     2414  2409  0 22:52 pts/0    00:00:00 grep session
 pstree

init─┬─Thunar───2*[{Thunar}]
     ├─accounts-daemon───2*[{accounts-daemon}]
     ├─bluetoothd
     ├─cron
     ├─2*[dbus-daemon]
     ├─dbus-launch
     ├─dhclient
     ├─elogind-daemon
     ├─6*[getty]
     ├─lightdm─┬─Xorg───2*[{Xorg}]
     │         ├─lightdm─┬─sh─┬─ssh-agent
     │         │         │    └─xfce4-session─┬─polkit-gnome-au───2*[{polkit-gnome-au}]
     │         │         │                    └─2*[{xfce4-session}]
     │         │         └─2*[{lightdm}]
     │         └─2*[{lightdm}]
     ├─polkitd───2*[{polkitd}]
     ├─rsyslogd───3*[{rsyslogd}]
     ├─udevd
     ├─upowerd───2*[{upowerd}]
     ├─wpa_supplicant
     ├─xfce4-panel─┬─firefox-esr─┬─Web Content───36*[{Web Content}]
     │             │             ├─Web Content───31*[{Web Content}]
     │             │             ├─Web Content───29*[{Web Content}]
     │             │             ├─Web Content───21*[{Web Content}]
     │             │             ├─WebExtensions───28*[{WebExtensions}]
     │             │             └─68*[{firefox-esr}]
     │             ├─panel-2-actions
     │             ├─panel-6-systray
     │             └─{xfce4-panel}
     ├─xfce4-terminal─┬─bash───pstree
     │                └─2*[{xfce4-terminal}]
     ├─xfconfd
     ├─xfdesktop───2*[{xfdesktop}]
     ├─xfsettingsd───2*[{xfsettingsd}]
     └─xfwm4

Last edited by HevyDevy (2020-06-29 13:40:31)


When all the trees have been cut down, when all the animals have been hunted, when all the waters are polluted, when all the air is unsafe to breathe, only then will you discover you cannot eat money.
~ Cree Prophecy

Offline

#2 2020-06-29 13:14:28

larsH
Member
Registered: 2020-05-05
Posts: 81  

Re: Solved - xfce4 session issues

Hi

As you probably know the default with xfce is slim and elogin. I think the problem could be with lightdm and xfce. Look here if this is the problem :-))
https://bgstack15.wordpress.com/2019/09 … r-session/

Have a nice day
Lars H

Offline

#3 2020-06-29 13:21:31

HevyDevy
Member
Registered: 2019-09-06
Posts: 263  

Re: Solved - xfce4 session issues

I dont think so, had the same issue with startxfce4 via startx. Something is not right with elogind and xfce4, i just dont know what it is.


When all the trees have been cut down, when all the animals have been hunted, when all the waters are polluted, when all the air is unsafe to breathe, only then will you discover you cannot eat money.
~ Cree Prophecy

Offline

#4 2020-06-29 13:28:47

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,559  

Re: Solved - xfce4 session issues

Maybe...

https://files.devuan.org/devuan_beowulf … _notes.txt

Power buttons are disabled on the lightdm login screen with elogind.
(See Debian bug [#932047](https://bugs.debian.org/932047))

Add the following line to /etc/pam.d/lightdm-greeter

    session   optional pam_elogind.so

Offline

#5 2020-06-29 13:31:05

larsH
Member
Registered: 2020-05-05
Posts: 81  

Re: Solved - xfce4 session issues

Hi again

I can see that a lot more of your processes are running outside the loginmanager. Is this a problem (I think of xfwm and xfdesktop)

My pstree as user for your reference:
pstree
init─┬─apache2─┬─apache2
     │         └─2*[apache2───26*[{apache2}]]
     ├─at-spi-bus-laun─┬─dbus-daemon
     │                 └─3*[{at-spi-bus-laun}]
     ├─at-spi2-registr───2*[{at-spi2-registr}]
     ├─avahi-daemon───avahi-daemon
     ├─colord───2*[{colord}]
     ├─cron
     ├─cups-browsed───2*[{cups-browsed}]
     ├─cupsd───dbus
     ├─2*[dbus-daemon]
     ├─dbus-launch
     ├─dhclient
     ├─elogind-daemon
     ├─exim4
     ├─6*[getty]
     ├─gpg-agent
     ├─gvfs-udisks2-vo───2*[{gvfs-udisks2-vo}]
     ├─gvfsd─┬─gvfsd-trash───2*[{gvfsd-trash}]
     │       └─2*[{gvfsd}]
     ├─gvfsd-metadata───2*[{gvfsd-metadata}]
     ├─polkitd───2*[{polkitd}]
     ├─rsyslogd───3*[{rsyslogd}]
     ├─saned───saned
     ├─slim─┬─Xorg───2*[{Xorg}]
     │      └─sh─┬─ssh-agent
     │           └─xfce4-session─┬─Thunar───3*[{Thunar}]
     │                           ├─agent───2*[{agent}]
     │                           ├─applet.py
     │                           ├─firefox-esr─┬─2*[Web Content───40*[{Web Cont+
     │                           │             ├─2*[Web Content───34*[{Web Cont+
     │                           │             ├─Web Content───39*[{Web Content+
     │                           │             ├─Web Content───21*[{Web Content+
     │                           │             ├─WebExtensions───29*[{WebExtens+
     │                           │             └─76*[{firefox-esr}]
     │                           ├─polkit-gnome-au───2*[{polkit-gnome-au}]
     │                           ├─volumeicon───2*[{volumeicon}]
     │                           ├─wicd-client───2*[{wicd-client}]
     │                           ├─xfce4-panel
     │                           │             ├─panel-2-actions
     │                           │             ├─panel-6-systray
     │                           │             └─14*[{xfce4-panel}]
     │                           ├─xfdesktop───2*[{xfdesktop}]
     │                           ├─xfwm4
     │                           ├─xscreensaver
     │                           └─2*[{xfce4-session}]
     ├─thunderbird───55*[{thunderbird}]
     ├─udevd
     ├─udisksd───4*[{udisksd}]
     ├─upowerd───2*[{upowerd}]
     ├─wicd───wicd-monitor
     ├─xfce4-notifyd───2*[{xfce4-notifyd}]
     ├─xfce4-power-man───2*[{xfce4-power-man}]
     ├─xfce4-terminal─┬─bash───su───bash───aptitude───4*[{aptitude}]
     │                ├─bash
     │                ├─bash───pstree
     │                └─3*[{xfce4-terminal}]
     ├─xfconfd
     └─xfsettingsd───2*[{xfsettingsd}]

Hope this is to some help
Lars H

Offline

#6 2020-06-29 13:37:38

HevyDevy
Member
Registered: 2019-09-06
Posts: 263  

Re: Solved - xfce4 session issues

okay i figured it out, in my quest to not have so many useless packages being installed when i installed xfce4 and xorg it left out 'x11-xserver-utils' using apt install --no-install-recommends

After directly installing this logging out and logging back in again the session works as it should.

This old ubuntu bug solved it.

https://bugs.launchpad.net/ubuntu/+sour … ug/1660963

Sorry for the noise!

Last edited by HevyDevy (2020-06-29 13:39:03)


When all the trees have been cut down, when all the animals have been hunted, when all the waters are polluted, when all the air is unsafe to breathe, only then will you discover you cannot eat money.
~ Cree Prophecy

Offline

Board footer