The officially official Devuan Forum!

You are not logged in.

#1 2020-06-28 15:34:26

erdos
Member
Registered: 2018-06-04
Posts: 38  

no 'X' window on Beowulf with nvidia card

hello, I couldn't log into 'X' after rebooting my Beowulf machine yesterday ( i've been running 'xfce' for a week since upgrading to beowulf last weekend on 4.9.0-12 kernel)

I have  have a nvidia geforce 9300 GE card with nvidia-legacy-340xx-driver installed.  And recently upgraded from ASCII.

boot with '4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux' from Grub menu resulted a blank screen, and
boot with '4.9.0-12-amd64 #1 SMP Debian 4.9.210-1  (2020-01-20) x86_64 GNU/Linux  gives me shell, but 'startx' doesn't launch 'X'

modprobe: Error: could not insert 'nvidia': unknown symbol in module, or unknown parameter (see dmsg).
(ee)  fatal server error
(ee)  no screens found

The only change i made to the machine since installing Beowulf was adding printer driver for a Brother laser printer.  Reinstalling nvidia 340 driver doesn't resolve the issue.

any advice?

Offline

#2 2020-06-29 01:13:08

Altoid
Member
Registered: 2017-05-07
Posts: 411  

Re: no 'X' window on Beowulf with nvidia card

Hello:

erdos wrote:

... couldn't log into 'X' after rebooting ...
... been running 'xfce' for a week ...

So the rig was working perfectly well until "adding printer driver for a Brother laser printer"?
If so, maybe it is just the old and well known cause -> effect mechanism doing it's thing here.

Q: Just where did the driver come from?

erdos wrote:

any advice?

1.
Scan through dmesg for errors and see what /var/log/Xorg.0.log has to say about X not starting.

2.
Try seeing if there's something missing, as root do:

# apt-get install -f

Please post back results.

Cheers,

A.

Offline

#3 2020-06-29 01:31:25

erdos
Member
Registered: 2018-06-04
Posts: 38  

Re: no 'X' window on Beowulf with nvidia card

Thanks for the reply!

I was able to resolve the issue by uninstalling the nvidia driver downloaded from nvidia website, and reinstalled it with apt-get.


sudo sh ./NVIDIA-Linux-x86_64-340.108.run --uninstall
sudo apt-get install nvidia-legacy-340xx-driver

However, at the end of installation, there's an error on the screen:
Errors were encountered while processing:
nvidia-persistenced
E:  Sub-process /usr/bin/dpkg returned an error code 1.

I rebooted and was able to boot both  '4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux' and
'4.9.0-12-amd64 #1 SMP Debian 4.9.210-1  (2020-01-20) kernel into XFCE desktop successfully - i was only able to launch 'X' with  4.9.0-12 kernel after upgrading to Beowulf.

the error for 'nvidia-persistenced' persists - both displaying on screen during the boot process and pops up when install new package with apt-get, trying to reinstalling nvidia-persistenced results:
E: internal error, no file name for nvidia-persistenced:amd64.

Last edited by erdos (2020-06-29 02:05:26)

Offline

#4 2020-06-29 03:08:54

erdos
Member
Registered: 2018-06-04
Posts: 38  

Re: no 'X' window on Beowulf with nvidia card

I removed and reinstalled the 'nvidia-persistenced', followed by reboot, it seems ok now, no error related to this pkg displays during boot or pkg installation smile

Offline

Board footer