The officially official Devuan Forum!

You are not logged in.

#51 2020-05-15 15:04:45

tdrnetworks
Member
Registered: 2020-02-29
Posts: 11  

Re: deb.sury.org now requires systemd

We've updated our repo today, with new upstream builds.

Currently serving:  PHP 7.2.31,    7.3.18,   and 7.4.6. 

Regards,

TDR Networks


The repo offers AMD64 debs, and DPKG sources.

### PHP Rebuilds for Devuan Jessie
deb https://pkgs.tdrnetworks.com/apt/devuan jessie main
deb-src https://pkgs.tdrnetworks.com/apt/devuan jessie main

### PHP Rebuilds for Devuan Ascii
deb https://pkgs.tdrnetworks.com/apt/devuan ascii main
deb-src https://pkgs.tdrnetworks.com/apt/devuan ascii main

### PHP Rebuilds for Devuan Beowulf
deb https://pkgs.tdrnetworks.com/apt/devuan beowulf main
deb-src https://pkgs.tdrnetworks.com/apt/devuan beowulf main

Last edited by tdrnetworks (2020-06-12 14:56:29)

Offline

#52 2020-05-16 03:19:15

szutt
Member
Registered: 2019-02-03
Posts: 23  

Re: deb.sury.org now requires systemd

Great work. Thank you ! +1

Offline

#53 2020-05-16 21:56:27

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 84  

Re: deb.sury.org now requires systemd

Great work. Thank you !

+1

Offline

#54 2020-05-31 15:17:13

Sich
Member
Registered: 2020-05-30
Posts: 4  

Re: deb.sury.org now requires systemd

tdrnetworks wrote:

### PHP Rebuilds for Devuan Beowulf
deb https://pkgs.tdrnetworks.com/apt/devuan beowulf main
deb-src https://pkgs.tdrnetworks.com/apt/devuan beowulf main

Hi, i have certificat issue when I try to add this repo :

Err:5 https://pkgs.tdrnetworks.com/apt/devuan beowulf Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 213.155.26.146 443]
Reading package lists... Done                         
E: The repository 'https://pkgs.tdrnetworks.com/apt/devuan beowulf Release' does not have a Release file.

An idea ?

Offline

#55 2020-05-31 23:27:10

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 84  

Re: deb.sury.org now requires systemd

Try it with http:// instead of https://.  I don't know this but I think there may be a problem with the ssl cert.

I saw this error yesterday and used the above workaround, and it worked.

Offline

#56 2020-06-01 00:07:22

Ron
Member
Registered: 2018-04-22
Posts: 234  

Re: deb.sury.org now requires systemd

nixer wrote:

Try it with http:// instead of https://.  I don't know this but I think there may be a problem with the ssl cert.

There doesn't seem to be a problem with the cert.

https://www.ssllabs.com/ssltest/analyze … tworks.com

Offline

#57 2020-06-01 07:53:02

Sich
Member
Registered: 2020-05-30
Posts: 4  

Re: deb.sury.org now requires systemd

nixer wrote:

Try it with http:// instead of https://.  I don't know this but I think there may be a problem with the ssl cert.

I saw this error yesterday and used the above workaround, and it worked.

yep good idea, it's work fine with http.
Good thing that the website doesn't use redirect to https.

I was able to install php7.4-fpm without any problem.
Good job for the repos maintainer !

Offline

#58 2020-06-07 22:37:17

tdrnetworks
Member
Registered: 2020-02-29
Posts: 11  

Re: deb.sury.org now requires systemd

Sich wrote:

Err:5 https://pkgs.tdrnetworks.com/apt/devuan beowulf Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 213.155.26.146 443]
Reading package lists... Done                         
E: The repository 'https://pkgs.tdrnetworks.com/apt/devuan beowulf Release' does not have a Release file.

An idea ?

The SSL certificate, CA bundle has been updated, so this error should have now gone away.

The issue;  https://www.ssl.com/blogs/addtrust-exte … y-30-2020/

The SSL certificate in use, was issued from Sectigo, and one of their upstream root CA's had expired since May 30th.   We have deployed an alternative CA bundle so the https issue should now start to sort itself out.

TDR

Offline

#59 2020-06-12 14:56:54

tdrnetworks
Member
Registered: 2020-02-29
Posts: 11  

Re: deb.sury.org now requires systemd

We've updated our repo today, with new upstream builds.

Currently serving:  PHP 7.2.31,    7.3.19,   and 7.4.7. 

Regards,

TDR Networks


The repo offers AMD64 debs, and DPKG sources.

### PHP Rebuilds for Devuan Jessie
deb https://pkgs.tdrnetworks.com/apt/devuan jessie main
deb-src https://pkgs.tdrnetworks.com/apt/devuan jessie main

### PHP Rebuilds for Devuan Ascii
deb https://pkgs.tdrnetworks.com/apt/devuan ascii main
deb-src https://pkgs.tdrnetworks.com/apt/devuan ascii main

### PHP Rebuilds for Devuan Beowulf
deb https://pkgs.tdrnetworks.com/apt/devuan beowulf main
deb-src https://pkgs.tdrnetworks.com/apt/devuan beowulf main

Offline

#60 2020-06-15 09:56:47

e_defranco
Member
Registered: 2020-06-15
Posts: 1  

Re: deb.sury.org now requires systemd

Hi, I discovered this topic when I searched a solution for my same problem with Raspberry: for my project usually I use a minimal version of raspbian (this: https://minibianpi.wordpress.com/) arranged by me for running in read only mode and without the "black beast" systemd.

Obviously, any project need a web server and php and I don't want systemd for many reasons.

What I would ask is: if I want make a php packages for arm similar as you have make for amd64 what can be the start point ? Can I use some of your adjusted source ? Have you any suggestion ?

Thank in advance,

Emilio

Offline

#61 2020-06-18 22:06:14

tdrnetworks
Member
Registered: 2020-02-29
Posts: 11  

Re: deb.sury.org now requires systemd

I don't see any reason why the packages wouldn't build on a arm system, but we're not in a position to have tested or to support this directly.

Unfortunately PHP is a bit of a monster, it's a large complicated language and the Debian based packaging system hasn't made it any simpler.

The sources I am working from, is basically sury's deb packaging, with a few of the crazy systemd-only breaking-changes reverted.

You can find all the dpkg sources in our repo, good luck!

e_defranco wrote:

What I would ask is: if I want make a php packages for arm similar as you have make for amd64 what can be the start point ? Can I use some of your adjusted source ? Have you any suggestion ?

Offline

#62 2020-06-19 10:50:21

IdeaFix
Member
Registered: 2020-01-02
Posts: 16  
Website

Re: deb.sury.org now requires systemd

tdrnetworks wrote:

We've updated our repo today, with new upstream builds.

Currently serving:  PHP 7.2.31,    7.3.19,   and 7.4.7.

Please, help me to install php-imagick. I see only php-imagick from original devuan ascii repo.

Offline

#63 2020-06-21 01:41:12

tdrnetworks
Member
Registered: 2020-02-29
Posts: 11  

Re: deb.sury.org now requires systemd

IdeaFix wrote:

Please, help me to install php-imagick. I see only php-imagick from original devuan ascii repo.


php-imagick should now be available from the pkgs.tdrnetworks.com repo.

Offline

#64 2020-06-26 00:14:12

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 84  

Re: deb.sury.org now requires systemd

tdrnetworks,

With jessie support scheduled to end June 30, 2020 (5 days from now), what is your plan for the jessie php builds?  Will you continue to build them after this date?

Do you have any plans to build php for Chimaera (current testing) any time soon?

I, and others, appreciate you building and offering your php builds to devuan.  Thank you.

Offline

#65 2020-07-01 14:51:58

mckaygerhard
Member
Registered: 2017-04-21
Posts: 216  
Website

Re: deb.sury.org now requires systemd

tdrnetworks wrote:

php-imagick should now be available from the pkgs.tdrnetworks.com repo.

hi great work.. i will make lighttpd packages due current php packages has hard conflicts with them! this problem was addressed to the sury shit but was closed inclusivelly other users wanted..

if you @tdrnetworks have problems and cannot mantain the repository.. ask to me.. i will make a mirror soon.. weantime i will upload to venenux ones in osb counter parts

Offline

#66 Today 14:01:08

tdrnetworks
Member
Registered: 2020-02-29
Posts: 11  

Re: deb.sury.org now requires systemd

nixer wrote:

tdrnetworks,

With jessie support scheduled to end June 30, 2020 (5 days from now), what is your plan for the jessie php builds?  Will you continue to build them after this date?

Do you have any plans to build php for Chimaera (current testing) any time soon?

I, and others, appreciate you building and offering your php builds to devuan.  Thank you.


We have no plans to stop building for Jessie,  we are still using this distro internally ourselves.

...  however if there is a breaking change, we may not have any choice.      -- We'll try to keep the jessie builds coming for the foreseeable.

Last edited by tdrnetworks (Today 14:01:22)

Offline

#67 Today 15:07:28

roluan17
Member
Registered: 2019-04-01
Posts: 27  

Re: deb.sury.org now requires systemd

I don't know whether my question has anything to do  with the problems described above ...
I did upgrade from ascii to beowulf.

when I do

apt-get upgrade

I get:

Die folgenden Pakete sind zurückgehalten worden:
  elogind libelogind0 libpam-elogind

meaning the following packages have been held back

Everything seems to work fine on my machine, but I'd like to know if I need to take action?
Which part of beowulf needs elogind, libelogind0 and  libpam-elogind?
How could I have found out for myself?

greetings

Offline

#68 Today 15:44:20

mckaygerhard
Member
Registered: 2017-04-21
Posts: 216  
Website

Re: deb.sury.org now requires systemd

tdrnetworks wrote:

We have no plans to stop building for Jessie,  we are still using this distro internally ourselves.

...  however if there is a breaking change, we may not have any choice.      -- We'll try to keep the jessie builds coming for the foreseeable.

i still use wheezy and jessie, please anunce when that happened and i will provide packages for.. currently i'm adapting php 5.6 to wheeze..


roluan17 wrote:

Die folgenden Pakete sind zurückgehalten worden:
  elogind libelogind0 libpam-elogind

your problem roluan17 are a devuan problem.. deprecated packages in repository AGAIN XD XD .. devuan are always behing debian and cos repositories are "proxied" when debian updates some packages devuan ones are superset!

Last edited by mckaygerhard (Today 15:45:05)

Offline

#69 Today 17:32:28

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 761  
Website

Re: deb.sury.org now requires systemd

roluan17 wrote:

I don't know whether my question has anything to do  with the problems described above ...

No, it does not. Perhaps use the report button and request that this be split into it's own thread.

roluan17 wrote:

I did upgrade from ascii to beowulf.

when I do

apt-get upgrade

I get:

Die folgenden Pakete sind zurückgehalten worden:
  elogind libelogind0 libpam-elogind

meaning the following packages have been held back

Use apt full-upgrade to allow those packages to be installed.

roluan17 wrote:

I'd like to know if I need to take action?

Yes, elogind should be installed to replace systemd-logind.

mckaygerhard wrote:

your problem roluan17 are a devuan problem.. deprecated packages in repository AGAIN

Nonsense.

Last edited by Head_on_a_Stick (Today 17:34:10)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

Board footer