The officially official Devuan Forum!

You are not logged in.

#1 2020-06-17 11:17:10

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Gnome 3.30 on Beowulf working in wayland & Xorg

Thankfully Gnome shell is working fine with Beowulf now. Hope everything is OK. OpenRC as init. I am using Gnome-3.30 in wayland. It works fine in both wayland or Xorg backends.

I had KDE5 on ASCII. I removed KDE packages and qt dependencies and cleared some config folder (. folders) in the ~/ . Using gdm3. Great to see libsystemd0 also removed. I have listed the installed packages.
https://paste.debian.net/1153051/
(Please mind that mine is bloated desktop with almost 1900 packages installed. It's just to give an idea of what Gnome packages are installed)

Although, there is a pseudo package "task-gnome-desktop" that seems to pull a lot of packages unrelated as well. I tried manually installing core Gnome packages.

But, it works only on X. No wayland support, I guess. Also, the lightdm options shows 3 Gnome options apart from fallback. None of them works except Gnome on X. Anyways, it is mounting partitions, usb drives all fine. Thanks for the elogind and it's developers for that wonderful piece of software that allowed to purge systemd deps completely. I did not try gdm3, since earlier HOWTO's in the forum suggest not to go for that.
If anyone figure out, a way to get Gnome to use wayland? I did not succeed.
EDIT: I changed to gdm3 as display manager and both wayland and Xorg sessions supported.

  • I am also using latest Firefox from ubuntuzilla repo.

  • For Pulseuadio to work, edit /etc/pulse/client.conf.d/00-disable-autospawn.conf and comment the line

    #autospawn=no

    (Thanks to @MiyoLinux for the heads up.)

Here are some screenshots from fresh upgrade from ASCII to Beowulf with Gnome 3.30:

Screenshot-from-2020-06-17-16-39-49.png
Screenshot-from-2020-06-17-16-39-32.png
Screenshot-from-2020-06-17-16-07-35.png
Screenshot-from-2020-06-17-16-06-58.png
upload pic

Last edited by Debuser2018 (2020-06-20 09:01:26)

Offline

#2 2020-06-17 12:26:09

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Debuser2018 wrote:

a way to get Gnome to use wayland?

First log out from the graphical session, login to a console and stop LightDM:

# service lightdm stop

Then try

MOZ_ENABLE_WAYLAND=1 QT_QPA_PLATFORM=wayland XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session

The first two variables are to make Firefox & Qt applications run under Wayland, the third variable should force GNOME to start a Wayland session.

If it works then create a file at ~/.xsession containing that line and select the "default X session" from LightDM. Not sure if LightDM can actually launch a Wayland session though so you might have to disable LightDM entirely and switch to a console login instead.

To automatically launch a Wayland GNOME session after a console login to TTY1 add this line to the end of the file at ~/.profile:

[ $(tty) = /dev/tty1 ] && MOZ_ENABLE_WAYLAND=1 QT_QPA_PLATFORM=wayland XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session

Black Lives Matter

Offline

#3 2020-06-17 12:49:41

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Thanks. Forgot to add that pulseaudio did not start at boot time.

Offline

#4 2020-06-17 14:26:58

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Head_on_a_Stick wrote:
Debuser2018 wrote:

a way to get Gnome to use wayland?

First log out from the graphical session, login to a console and stop LightDM:

# service lightdm stop

Then try

MOZ_ENABLE_WAYLAND=1 QT_QPA_PLATFORM=wayland XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session

The first two variables are to make Firefox & Qt applications run under Wayland, the third variable should force GNOME to start a Wayland session.

If it works then create a file at ~/.xsession containing that line and select the "default X session" from LightDM. Not sure if LightDM can actually launch a Wayland session though so you might have to disable LightDM entirely and switch to a console login instead.

To automatically launch a Wayland GNOME session after a console login to TTY1 add this line to the end of the file at ~/.profile:

[ $(tty) = /dev/tty1 ] && MOZ_ENABLE_WAYLAND=1 QT_QPA_PLATFORM=wayland XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session

It did not work out. Terminal output full about inotify error message.

Now, Pulseaudio works fine, if I run "pulseaudio -D". But, does pulseaudio has a init script or is there any config file where I need to enable startup.
EDIT: OK. I'm not an expert. I just put "pulseaudio -D" appended into the gnome-session file - /etc/X11/Xsession.d/55gnome-session_gnomerc . I don't know if pulseaudio config has option to do that. When I checked /etc/pulse/daemon.conf everything looked fine.

But,  start-pulseaudio-x11 inside /etc/xdg/autostart/pulseaudio.desktop fails, it seems - Failure: Module initialization failed

Regarding wayland. Any dependencies which may be needed?

Last edited by Debuser2018 (2020-06-17 14:47:20)

Offline

#5 2020-06-17 15:11:16

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

I selected gdm3 as display manager. Now, wayland session is working fine.

:~$ loginctl show-session 1 -p Type
Type=wayland

Now, the only thing is pulseaudio not starting at boot time.

:~$ start-pulseaudio-x11 
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Offline

#6 2020-06-17 15:47:33

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

That PA problem has cropped up a few times recently, search the boards for the solutions.


Black Lives Matter

Offline

#7 2020-06-18 03:52:15

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Head_on_a_Stick wrote:

That PA problem has cropped up a few times recently, search the boards for the solutions.

I'm using "pulseaudio -D" in the config file to fix this behaviour. If I pull the pulseaudio packages from Chimaera, any chances if this is fixed? Anyways, I'm happy that Devuan is just working fine so far now.  yikes

Offline

#8 2020-06-18 08:26:51

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,030  

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Look at the file...

/etc/pulse/client.conf.d/00-disable-autospawn.conf

...After following the instructions, reboot. wink


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#9 2020-06-18 19:32:01

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

MiyoLinux wrote:

Look at the file...

/etc/pulse/client.conf.d/00-disable-autospawn.conf

...After following the instructions, reboot. wink

Great! Thanks for that. So, this line needs to be commented out to get pulseaudio working.
--
Now, almost everything looks fine with Devuan.
I was almost convinced that Gnome 3.x will not work without systemd. But, proven wrong!

Offline

#10 2020-06-18 20:15:33

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Debuser2018 wrote:

I was almost convinced that Gnome 3.x will not work without systemd. But, proven wrong!

OpenBSD has had a port of GNOME for a long time and it's even available for Alpine Linux now thanks to elogind.


Black Lives Matter

Offline

#11 2020-06-20 08:16:47

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Does anyone packaged the last release of OpenRC (0.42.x) for Beowulf? OR is there any guide to build OpenRC debian packages including debianizing the source.

Debian has 0.42 version of OpenRC available. Can we use the sources from the Debian version of OpenRC and rebuild it? OR if the .debs are directly installable?
Thank you.

Last edited by Debuser2018 (2020-06-20 08:23:43)

Offline

#12 2020-06-20 10:54:07

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Debuser2018 wrote:

Debian has 0.42 version of OpenRC available. Can we use the sources from the Debian version of OpenRC and rebuild it?

That version is available from Devuan's ceres repositories so you can grab the source from there and rebuild it for a beowulf base, follow this Debian wiki guide:

https://wiki.debian.org/SimpleBackportCreation

I've just tried that in my Debian buster box and it builds fine.

I do actually have an old OpenRC version in my OBS repository but I can't remember my password and the reset facility isn't working at the moment, I'll edit this post with a link once I get into it and update the package.


Black Lives Matter

Offline

#13 2020-06-20 14:24:49

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Head_on_a_Stick wrote:
Debuser2018 wrote:

Debian has 0.42 version of OpenRC available. Can we use the sources from the Debian version of OpenRC and rebuild it?

That version is available from Devuan's ceres repositories so you can grab the source from there and rebuild it for a beowulf base, follow this Debian wiki guide:

https://wiki.debian.org/SimpleBackportCreation

I've just tried that in my Debian buster box and it builds fine.

I do actually have an old OpenRC version in my OBS repository but I can't remember my password and the reset facility isn't working at the moment, I'll edit this post with a link once I get into it and update the package.

I checked the pool and there is no openRC packages there for Ceres. From what I understands, Devuan repositories uses Debian repos for most other packages? Will you share the Ceres version of openRC?

apt source openrc/ceres

Reading package lists... Done
E: Unable to find a source package for openrc

Hmm.. I think I will have to get openRC source for Beowulf and patch it with Debian OpenRC?

Last edited by Debuser2018 (2020-06-20 14:26:58)

Offline

#14 2020-06-20 14:57:52

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Debuser2018 wrote:

I checked the pool and there is no openRC packages there for Ceres. From what I understands, Devuan repositories uses Debian repos for most other packages? Will you share the Ceres version of openRC?

I can't share a link but I've just managed to grab the source from ceres in a live version of beowulf so it does work.

Did you add the deb-src line for ceres to your sources and update the package database before using apt source?

Here's my full procedure for the backport (lines beginning with "#" should be run as root):

# apt install devscripts dpkg-dev
# tee -a /etc/apt/sources.list <<<'deb-src http://deb.devuan.org/merged ceres main'
# apt update
mkdir -p ~/builds/openrc && cd ~/builds/openrc
apt source openrc && cd openrc-0.42
dch --bpo # fill in changelog entry and save the file
# mk-build-deps --install --remove
debuild -us -uc

There should then be an openrc-0.42-1~bpo10+1_amd64.deb package in the ~/builds/openrc/ directory that can be installed safely in your beowulf system.

To clean up afterwards remove the unneeded build dependencies and build scripts:

# apt autoremove openrc-build-deps devscripts dpkg-dev

And also remove the ceres source repository:

# sed -i '/ceres/d' /etc/apt/sources.list

EDIT: and finally update the package database again:

# apt update

Last edited by Head_on_a_Stick (2020-06-20 15:00:01)


Black Lives Matter

Offline

#15 2020-06-20 15:19:54

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

@Head_on_a_Stick: I had added the ceres deb-src lines in sources.list and apt update ran. When I search, this is the output:

Reading package lists... Done
E: Unable to find a source package for openrc

I downloaded the source from Debian testing for openrc-0.42 and following packages are built. But..the build utility was warning about some useless dependencies may be removed?

libeinfo1_0.42-1~bpo10+1_amd64.deb
libeinfo1-dbgsym_0.42-1~bpo10+1_amd64.deb
libeinfo-dev_0.42-1~bpo10+1_amd64.deb
librc1_0.42-1~bpo10+1_amd64.deb
librc1-dbgsym_0.42-1~bpo10+1_amd64.deb
librc-dev_0.42-1~bpo10+1_amd64.deb
openrc_0.42-1~bpo10+1_amd64.deb
openrc_0.42-1~bpo10+1.debian.tar.xz
openrc_0.42-1.debian.tar.xz
openrc-dbgsym_0.42-1~bpo10+1_amd64.deb

dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/libeinfo1/lib/x86_64-linux-gnu/libeinfo.so.1 was not linked against libselinux.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/libeinfo1/lib/x86_64-linux-gnu/libeinfo.so.1 was not linked against libaudit.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/librc1/lib/x86_64-linux-gnu/librc.so.1 was not linked against libaudit.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/librc1/lib/x86_64-linux-gnu/librc.so.1 was not linked against libselinux.so.1 (it uses none of the library's symbols)

Last edited by Debuser2018 (2020-06-20 15:21:52)

Offline

#16 2020-06-20 15:25:31

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Do  I need to edit debian/control file to remove libaudit-dev,libselinux1-dev
//sorry for multiple q's since I last built deb binaries a long time ago.

Last edited by Debuser2018 (2020-06-20 15:26:11)

Offline

#17 2020-06-20 16:25:23

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Yes. Rebuilt packages. Thanks for the help @Head_on_a_Stick . I had added deb-src for ceres with "main non-free contrib" format. That may be why it did not work earlier.

Installed libeinfo1, librc1, openrc-0.42 and rebooted. It is working fine so far now. ?

openrc:
  Installed: 0.42-1~bpo10+1

Offline

#18 2020-06-20 16:44:13

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Debuser2018 wrote:

@Head_on_a_Stick: I had added the ceres deb-src lines in sources.list and apt update ran. When I search, this is the output:

Reading package lists... Done
E: Unable to find a source package for openrc

You should show the actual line that you used and also the output of the apt update command so that we could see if it was being read. I did build the package successfully from the ceres source in a Devuan beowulf live environment so it definitely works and you don't need to use any Debian sources.

But anyway that probably belongs in another thread, we've got diverted somewhat here.


Black Lives Matter

Offline

#19 2020-06-20 18:39:16

Debuser2018
Member
From: Muvattupuzha
Registered: 2018-01-24
Posts: 78  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

Head_on_a_Stick wrote:
Debuser2018 wrote:

@Head_on_a_Stick: I had added the ceres deb-src lines in sources.list and apt update ran. When I search, this is the output:

Reading package lists... Done
E: Unable to find a source package for openrc

You should show the actual line that you used and also the output of the apt update command so that we could see if it was being read. I did build the package successfully from the ceres source in a Devuan beowulf live environment so it definitely works and you don't need to use any Debian sources.

But anyway that probably belongs in another thread, we've got diverted somewhat here.

Problem already solved. smile Please check above post.  I built from Devuan Ceres sources. I added the single line:

deb-src http://deb.devuan.org/merged ceres main

and can pull the sources fine.

The problem earlier was, I uncommented so many lines in sources.list that looked like:

deb-src http://deb.devuan.org/merged ceres main non-free contrib
deb-src http://deb.devuan.org/merged ceres-security main non-free contrib
deb-src http://deb.devuan.org/merged ceres-updates main non-free contrib

Anyways, now everything works fine. Booting with openRC-0.42-1 .

Offline

#20 2020-06-20 21:01:18

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Gnome 3.30 on Beowulf working in wayland & Xorg

How strange, having the contrib & non-free components added to the deb-src line shouldn't render the packages in main unavailable.

And just FYI ceres doesn't have  -security or -updates repositories.


Black Lives Matter

Offline

Board footer