The officially official Devuan Forum!

You are not logged in.

#1 2020-06-08 12:05:41

devian
Member
Registered: 2019-11-08
Posts: 5  

KDE mixer doesn't display devices after upgrade to Beowulf [SOLVED]

I've just upgraded to Beowulf. Most stuff is okay, but the sound is broken.

I have to use alsamixer (as root in the console) to adjust volume which is a massive pain. I adjusted the headphone volume up (default is muted) and now I have both speakers and headphone audio working.

BUT, the audio mixer tray icon in KDE just shows the red "-" symbol meaning audio is muted. There are no devices shown when I click on the tray icon. This is clearly a regression compared to Devuan Ascii.

Additionally, none of my volume "hard" buttons on my laptop work.

Now, if I comment out the "autospawn=no" line in /etc/pulse/client.conf.d/00-disable-autospawn.conf as per https://files.devuan.org/devuan_beowulf … _notes.txt I see that my volume buttons now affect the KDE volume widget, however I now have no sound anywhere. alsamixer shows only one device which is the dummy mixer. The KDE mixer now shows a "dummy mixer" as my device.

I'm using a pretty common old Lenovo laptop so I'm sure other people must be seeing this too.

Anyone have any tips to make the tray icon allow me to change the audio volume in KDE? Thanks.

Last edited by devian (2020-06-08 13:38:09)

Offline

#2 2020-06-08 12:39:14

larsH
Member
Registered: 2020-05-05
Posts: 85  

Re: KDE mixer doesn't display devices after upgrade to Beowulf [SOLVED]

Hi

This is because pulseaudio is not running by default. You can get volumecontrol by installing something like qasmixer, a qt mixer for alsa or for gtk volumeicon-alsa. Another possibility is to get pulseaudio up and running as described in the release notes.

Have a nice day
Lars H

Last edited by larsH (2020-06-08 13:39:45)

Offline

#3 2020-06-08 13:37:41

devian
Member
Registered: 2019-11-08
Posts: 5  

Re: KDE mixer doesn't display devices after upgrade to Beowulf [SOLVED]

Thanks. I tried out both options but volumeicon-alsa is much better as it allows my hard buttons to be used.

I just run volumeicon at login time and everything works perfectly.

Offline

Board footer