The officially official Devuan Forum!

You are not logged in.

#1 2020-06-01 16:58:27

hmj
Member
Registered: 2020-03-04
Posts: 10  

Beowulf: user login software synaptic and pulseaudio using tor-browser

After installing the beta-dvd of beowulf (today upgraded to stable) I noticed two problems:

1. I use XFCE. Invoking synaptic normally I get a window to write root's password, then synaptic is opened. Now: nothing. I solved the problem by creating a button in the panel, setting a "sudo" before "synaptic-pkexec" and using "execute in a terminal".

So my question ist not: how to get access as a normal user (as root there is no problem), but; why don't I get the usual window.

Testing the behavior I opened a teminal and wrote "synaptic-pkexec". I got these messages:

==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: <full name>,,, (>system user>j)
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

Using ascii this problem did not exist. Anyone can propose me a solution?

2. Using tor-browser pulseaudio gives no sound. Using pulseaudio in the system-mode tor-browser has sound, but this mode is not recommended.

Pulseaudio has a lot of dependencies, I deleted pulseaudio in a test-installation (I have 3 different devuan installations bootable) to use alsa instead, but I got no effect. I suppose some reconfiguring may be necessary. What is to do?

For the future I think of a combination of alsa and jack.

Thank you for your answers.

Last edited by hmj (2020-06-01 23:56:18)

Offline

#2 2020-06-01 18:26:27

larsH
Member
Registered: 2020-05-05
Posts: 96  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

Hi

What does alsamixer in a terminal show. Is your device listed in a terminal with "amixer". If it works consider instaling "volumeicon-alsa".

Have a nice day
lars H

Online

#3 2020-06-01 18:31:45

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,595  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

1. Make sure policykit-1-gnome is installed. If that doesn't do it, I'll have more questions about what is or isn't installed.

2. tor-browser requires pulseaudio for sound. If you remove pulseaudio (as I have) you can install and use apulse. I made a panel button to start tor-browser and edited the command to begin with apulse.

3. I've been wishing for years that someone would make a jack plugin for firefox.

Offline

#4 2020-06-01 18:51:42

larsH
Member
Registered: 2020-05-05
Posts: 96  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

Hi fsmithred

In gentoo you can build firefox wwith support for jackd. So you should be able to do it by compiling it yourself.

Have a nice day
Lars H

Online

#5 2020-06-01 23:50:34

hmj
Member
Registered: 2020-03-04
Posts: 10  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

@fsmithred

policykit-gnome is installed, version 0.105-7
policykit-1 has version 0.105-25+devuan8

@larsH
Invoking amixer I get:

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 5621 [9%] [off]
  Front Right: Playback 5621 [9%] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 3547 [5%] [on]
  Front Right: Capture 3547 [5%] [on]

After the test I installed volumeicon-alsa. I suppose that it is necessary to delete pulseaudio to make it work?

Thank you

hmj

Offline

#6 2020-06-02 05:45:24

larsH
Member
Registered: 2020-05-05
Posts: 96  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

No. deleting pulseaudio is not required. But volumicon needs to be started from a terminal with "volumeicon".

You can also adjust levels using alsamixer (also in a terminal). Hopefully you will be able to adjust the volume

Have a nice day
Lars H

Online

#7 2020-06-02 11:03:57

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 129  
Website

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

larsH wrote:

But volumicon needs to be started from a terminal with "volumeicon".

Depending on what DE/WM you use, you can also launch it from start programs of your environment. Quite useful when you are already confident that it works for you.

Offline

#8 2020-06-02 11:56:00

larsH
Member
Registered: 2020-05-05
Posts: 96  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

Hi PedroReina

That would have been my next suggestion, when confirmed sound is working. One step at a time ;-))

Have a nice day

Online

#9 2020-06-02 18:23:34

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 129  
Website

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

larsH wrote:

One step at a time ;-))

Agreed! smile

Offline

#10 2020-06-03 17:53:47

hmj
Member
Registered: 2020-03-04
Posts: 10  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

I changed to my installation for tests. there I deleted pulseaudio and load some alsa packages.

My mainboard uses an Intel-HD chip. I have to select between duplex-stereo and multichannel-
HDMI. For my hardware, normal stereo, I use line-output stereo rear (green), front headphones.

Using QasMixer I chose card 1, HD-Audio Realtek. So I can change the different levels - but without effect.

Using gnome-mpv I get the information:
Playback was terminated abnormally. Reason: audio output initialization failed.

Trying a "apulse" before the command to invoke gnome-mpv: gnome-mpv chrashes when starting.

This is the reason why I asked whether there is the need to reconfigure packages.

In my working-installation I continue with pulseaudio.

Offline

#11 2020-06-03 18:20:54

larsH
Member
Registered: 2020-05-05
Posts: 96  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

Hi

Does alsamixer in a terminal work

To get pulseaudio to work you need according to the Release Notes do the following:

Pulseaudio
- If you have no sound, make sure the following line in
   /etc/pulse/client.conf.d/00-disable-autospawn.conf is commented as
   shown here:

   #autospawn=no

Have a nice day
Lars H

Online

#12 2020-06-04 17:39:06

hmj
Member
Registered: 2020-03-04
Posts: 10  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

@LarsH
In my working installation I added a line to load pulseaudio in the system-mode to /etc/rc.local (we work with init, so this is possible).

Because we don't use systemd there is of course the need to write "#autospawn=no". This ist done.

I wrote about my other devuan-installation that exists to test changes of my configuration. There I deleted pulseaudio.

The gui for alsamixer, using gtk, shows two levels, that are not to movable In my last post I described a program for alsa, where it seems that the different channels are ruled, but nothing happens. Maybe a problem of the hardware.

Thank you for your answer
hmj

Offline

#13 2020-06-06 17:50:03

hmj
Member
Registered: 2020-03-04
Posts: 10  

Re: Beowulf: user login software synaptic and pulseaudio using tor-browser

Finally I took the decision to invoke pulseaudio in the file /etc/rc.local in the local mode.

I start the X-Server manually. That's why I have no problem with a running pulseaudio in normal mode, that should be stopped before aktivating pulseaudio in the system mode. It may be not recommended, but it runs. So we can close this theme.

@fsmithred
I wrote about my installations with policykit. When noticing the difficulty to access to synaptic, I just had installed Beowulf after the information on devuan's website, that it is the new stable distribution. The policykit-packages were installed automatically. So I wonder why I don't get a small window to write root's password.

I remember that some years ago I had a similar problem with a former debian installation. As I have written: Using sudo and opening a terminal, I get the access. But I would like to know by principle reasons why this happens.

Offline

Board footer