The officially official Devuan Forum!

You are not logged in.

#1 2020-05-29 09:08:18

LU344928
Member
Registered: 2020-02-13
Posts: 20  

[Solved] Problem editing grub

Greetings. I'm on ascii 2.1 and I tried editing grub to a timeout of 0 as it always waits for me to hit enter. Despite there being a value of 5 it just waits for my input. Then, also as root, I ran update-grub and rebooted but no change. Here it is after the edit (I chose the hidden option as there's just the one OS on this machine):

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

Tia.

Last edited by LU344928 (2020-05-30 08:06:54)

Offline

#2 2020-05-29 10:33:04

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 431  

Re: [Solved] Problem editing grub

It seems grub is one of those packages where it's stupidly hard to find documentation, with man pages that just say that "this is documented somewhere else and I'm not telling where"... it turns out that you need to have grub-legacy-doc installed, which provides the texinfo file with documentation using the info system.

Anyhow, according to that you should also use

GRUB_TIMEOUT=0

Afaict GRUB_HIDDEN_TIMEOUT is the time to wait before showing the menu, and GRUB_TIMEOUT is the time to wait (in addition) before booting to the default choice.

If you also have

GRUB_TIMEOUT_STYLE=hidden

then the menu is not actually shown, but the time logic remains the same.

Online

#3 2020-05-29 19:13:25

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: [Solved] Problem editing grub

LU344928 wrote:

I tried editing grub to a timeout of 0 as it always waits for me to hit enter. Despite there being a value of 5 it just waits for my input

Can we see your /boot/grub/grub.cfg? Or more specifically:

grep timeout /boot/grub/grub.cfg
ralph.ronnquist wrote:

It seems grub is one of those packages where it's stupidly hard to find documentation

Here it is: https://www.gnu.org/software/grub/manua … index.html

And this bit is for the options in /etc/default/grub: https://www.gnu.org/software/grub/manua … figuration

ralph.ronnquist wrote:

Anyhow, according to that you should also use

GRUB_TIMEOUT=0

Actually that is the only option needed, GRUB_HIDDEN_TIMEOUT should remain unset.

ralph.ronnquist wrote:

If you also have

GRUB_TIMEOUT_STYLE=hidden

then the menu is not actually shown, but the time logic remains the same.

Not quite — if that option is set then GRUB will pause for the time specified in GRUB_TIMEOUT unless the <escape> key is pressed, at which point GRUB will wait indefinitely for user input.

GRUB_TIMEOUT_STYLE=hidden is the replacement for the deprecated GRUB_HIDDEN_TIMEOUT option so both should not be used at the same time.


Black Lives Matter

Offline

#4 2020-05-30 00:23:46

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 431  

Re: [Solved] Problem editing grub

Here it is: https://www.gnu.org/software/grub/manua … index.html

Yes. I'm just troubled by, again, a utility not having a proper man page, and secondly that proper documentation is not installed together with the utility. All sorts of other places of documentation is good (the man page would point them out). But all that is of course just one of the "wheels" that needs to be regularly reinvented and done differently, either just because it's possible or because the controlling generation doesn't bother to learn. It's a personal beweiling, basically irrelevant for the topic, so I'm not sure why I keep going with it.

Hopefully the @OP now finds it resolved.

Online

#5 2020-05-30 07:54:06

LU344928
Member
Registered: 2020-02-13
Posts: 20  

Re: [Solved] Problem editing grub

G'day Ralph, thanks for the reply. For the record the source I used for that was this.

ralph.ronnquist wrote:

It seems grub is one of those packages where it's stupidly hard to find documentation, with man pages that just say that "this is documented somewhere else and I'm not telling where"... it turns out that you need to have grub-legacy-doc installed, which provides the texinfo file with documentation using the info system.

That's interesting.

ralph.ronnquist wrote:

Anyhow, according to that you should also use

GRUB_TIMEOUT=0

Afaict GRUB_HIDDEN_TIMEOUT is the time to wait before showing the menu, and GRUB_TIMEOUT is the time to wait (in addition) before booting to the default choice.

If you also have

GRUB_TIMEOUT_STYLE=hidden

then the menu is not actually shown, but the time logic remains the same.

So I just changed it to   GRUB_TIMEOUT=0   then rebooted and all was hunky dory. Now there's no need to add any hidden option as it booted straight away with no splash screen, just what I was looking for. Good onya mate! smile

Offline

#6 2020-05-30 08:00:56

LU344928
Member
Registered: 2020-02-13
Posts: 20  

Re: [Solved] Problem editing grub

Head_on_a_Stick wrote:

Can we see your /boot/grub/grub.cfg? Or more specifically:

grep timeout /boot/grub/grub.cfg
root@devuan:~# grep timeout /boot/grub/grub.cfg
  set timeout=30
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=5
  # Fallback normal timeout code in case the timeout_style feature is
    set timeout=5
root@devuan:~# 

That was before the last edit following Ralph's advice. I did that again after editing and got a much longer result which I can post if you wish.

Thanks for your help.

Offline

#7 2020-05-30 10:58:14

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: [Solved] Problem editing grub

LU344928 wrote:

I did that again after editing and got a much longer result which I can post if you wish.

No, that's fine, don't bother if it's all working now. I was just confused as to why the (default) timeout=5 setting wasn't being obeyed, that's all.


Black Lives Matter

Offline

Board footer