The officially official Devuan Forum!

You are not logged in.

#1 2020-03-31 08:01:07

HevyDevy
Member
Registered: 2019-09-06
Posts: 194  

[solved] firejail + firefox sound issue

Hiya all,

I dont usually ask for help but this one has me stumped. Up until today ive used firejail with firefox and the sound has worked fine using only alsa. I dont have pulseaudio installed. sound returns when i stop using firejail with firefox so ive narrowed it down to an issue with firejail but unsure how to fix or find the bug if there is one, any pointers where to start?

Im using the latest beowulf beta with no dbus , i dont think that should be the issue as sound returns when i un firejail firefox.

Has anyone else experienced this using firejail with firefox?

Last edited by HevyDevy (2020-04-01 03:09:22)

Offline

#2 2020-03-31 11:37:31

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,503  

Re: [solved] firejail + firefox sound issue

Confirmed. I can reproduce this in a beowulf nodbus live iso.

In another live iso with xfce and dbus, sound in firefox-esr works with or without firejail.

I don't really know how to debug this. Maybe something in the firejail profile files would give a clue, or maybe running with strace would show something.

Offline

#3 2020-03-31 12:23:18

HevyDevy
Member
Registered: 2019-09-06
Posts: 194  

Re: [solved] firejail + firefox sound issue

Thanks fsmithred.

I think ive fixed the issue, dont really understand the problem though. Sound is now working with firefox firejailed.

See here: https://github.com/netblue30/firejail/issues/2042
and here: https://github.com/netblue30/firejail/issues/3303

"noroot removes all user groups, nogroups redundant"

in

/etc/firejail/firefox-common.profile 

go to line 40 and comment "nogroups".

see if that works for you ?

Last edited by HevyDevy (2020-03-31 12:31:12)

Offline

#4 2020-03-31 16:57:12

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,503  

Re: [solved] firejail + firefox sound issue

Good job! That worked. Commenting 'nogroups' fixed it. I tried commenting 'noroot' but that didn't help.

Offline

#5 2020-04-01 03:08:52

HevyDevy
Member
Registered: 2019-09-06
Posts: 194  

Re: [solved] firejail + firefox sound issue

fsmithred wrote:

Good job! That worked. Commenting 'nogroups' fixed it. I tried commenting 'noroot' but that didn't help.

Cheers, will mark as solved then.

Offline

Board footer