The officially official Devuan Forum!

You are not logged in.

#1 2020-03-13 03:27:14

erdos
Member
Registered: 2018-06-04
Posts: 29  

how to turn off screensaver on kodi 17

i'm running kodi 17 on devuan2.0.

while on kodi, devuan's screensaver kicks in every time, how do i prevent screensaver turning itself on?

Offline

#2 2020-03-13 19:25:20

bgstack15
Member
Registered: 2018-02-04
Posts: 135  

Re: how to turn off screensaver on kodi 17

Well, are you looking to just disable the screensaver completely? Just remove xscreensaver from whatever startup scripts or xdg autostart type stuff you have.
If you want it disabled only when running kodi, you could investigate running the command

xscreensaver-command -deactivate

periodically somehow.
I found that at https://wiki.archlinux.org/index.php/XS … a_playback, which had other ideas. It looks like Arch Linux also bundles up https://github.com/graysky2/kodi-prevent-xscreensaver which is really just a shell script which runs the above command every so many seconds.


This space intentionally left blank.

Offline

#3 2020-03-13 19:53:51

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: how to turn off screensaver on kodi 17

From the author's FAQ:

jwz wrote:

When you want to watch a movie, fire up xscreensaver-demo and select Mode: Disable Screen Saver from the option menu, which means not to blank the screen at all. When you're done watching the movie, re-select your previous mode.

https://www.jwz.org/xscreensaver/faq.html#dvd

And yes, jwz knows this is lame...

EDIT: better version of graysky's script:

#!/bin/sh
[ -z $(which xscreensaver-command) ] && exit 1
while sleep 49; do
   if [ -n "$(pgrep kodi)" ]; then
      xscreensaver-command -deactivate > /dev/null 2>&1
   fi
done

POSIX ftw!

Last edited by Head_on_a_Stick (2020-03-13 20:16:18)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

Board footer