The officially official Devuan Forum!

You are not logged in.

#1 2020-03-13 11:39:02

kapqa
Member
Registered: 2019-01-02
Posts: 141  

gecko-mediaplayer for buster/beowulf?

Hello ,

i would like to use gecko-mediaplayer as npapi plugin for firefox 52.

it seeems that for some reason this package (like totem-mozilla) is no longer being included/developed in recent distro.


is it enough to install it by downloading it from here

https://packages.debian.org/jessie/gecko-mediaplayer

and putting the files in the respective folders as listed here

https://packages.debian.org/jessie/amd6 … r/filelist



for some reason with debian there is no retrocompatibility guaranteed, and very often a package that was for jessie would no longer be installable on a higher iteration like stretch or buster, which is a real pity.

Offline

#2 2020-03-13 11:52:05

kapqa
Member
Registered: 2019-01-02
Posts: 141  

Re: gecko-mediaplayer for buster/beowulf?

i have installed the plugins, but it would not show up in firefox.

it seems that it is missing gnome-mplayer which is also deprecated since jessie

Depends: libc6 (>= 2.4), libcurl3-gnutls (>= 7.16.2), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.31.8), libgmlib1 (>= 1.0.7), libstdc++6 (>= 4.1.1), gnome-mplayer (>= 1.0.7) 

Offline

#3 2020-03-13 12:00:57

kapqa
Member
Registered: 2019-01-02
Posts: 141  

Re: gecko-mediaplayer for buster/beowulf?

thanks, i switched to latest firefox-esr,
this can be solved.

Offline

Board footer