The officially official Devuan Forum!

You are not logged in.

#1 2020-02-17 04:15:23

Micronaut
Member
Registered: 2019-07-04
Posts: 88  

Ascii does not respect /etc/adjtime settings

According to all of the documentation I can find, setting line 3 of /etc/adjtime to LOCAL tells the system that your BIOS time is local rather than GMT/UTC. But every time I reboot it during a single day, I get that complaint from fsck about the file system superblock being ahead of the real time. Yes, this is a dual boot system with Windows on the other side. Windows system time works properly. You might think that Windows is 'fscking' with something, but this happens even when Windows has not been booted even once that day. It looks like the Linux system is not reading the config file it is supposed to be reading. Has something changed recently in how system time is tracked and/or set?

Offline

#2 2020-02-17 13:17:27

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 664  
Website

Re: Ascii does not respect /etc/adjtime settings

Are you running ntp or any other program that would synchronise your computer's clock from the internet? Sounds like perhaps your motherboard's CMOS battery is dead.

And anyway you shouldn't configure GNU/Linux to use a stupid time standard, configuring Windows to use a sane time standard is a *much* better approach:

https://wiki.archlinux.org/index.php/Sy … in_Windows


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#3 2020-02-17 15:00:13

HevyDevy
Member
Registered: 2019-09-06
Posts: 192  

Re: Ascii does not respect /etc/adjtime settings

An interesting thread over at linux questions.

https://www.linuxquestions.org/question … page3.html

Offline

#4 2020-02-17 22:20:04

Micronaut
Member
Registered: 2019-07-04
Posts: 88  

Re: Ascii does not respect /etc/adjtime settings

Well, yes, I thought ntp was a good thing for any system to have. How much could it adjust the system time? Only a minute or two, I'd think. And I would have thought it would adjust the hardware clock when it did so.

Still, it might be a good idea to use the known Windows registry tweak to make it use UTC. I've been making other changes to align Wind'ohs with real OSes, such as running my own account as a normal user and having a separate admin account. smile

Offline

Board footer