The officially official Devuan Forum!

You are not logged in.

#1 2019-10-10 18:46:09

brownh
Member
Registered: 2019-10-10
Posts: 1  

SSL error

I have the problem that I can't get email to authenticate (quite sure my mutt/exim4 are set up correctly). A perhaps related problem of immediate concern is that I was unable to log into Dev1Galaxy. So I asked for password update, but the password sent did not work. I ended by re-registering to the web site with a new UID and email address. When I tried to log in with this password that was sent when I re-registered, it failed as well.

It turned out that while I could not log in with  my Basilisk browser, I finally managed it with torBrowser.

Because my basic problem is that mutt fails because my downloads or outgoing messages can't be authenticated, I am anxious to solve the dev1Galaxy login problem with Basilisk in the hope its encryption problem is related to email authentication. I'm running Beowulf, but the dev1Galaxy problem also exists with a laptop running Debian Stretch and the PaleMoon browser.

I get: "Error during connection to dev1galaxy.org/ SSL received a record that exceeded the maximum possible length (Error code: SSL_ERROR_RX_RECORD_TOO_LONG)" Also "Authenticity of the received data could not be verified." 
Is SSL enabled automatically in mutt/Beowulf? I had no problem with Ascii. Have things changed in this regard?

Offline

#2 2019-10-11 12:56:39

xinomilo
Member
Registered: 2017-07-02
Posts: 78  

Re: SSL error

ssl works in beowulf as before. just check your openssl version (apt policy openssl)

dev1galaxy.org supports TLSv1, TLSv1.1 & TLSv1.2 so it should work on most browsers, at least from jessie release onwards.
this sounds like something different.. custom setup/changes, not synchronised clock, outdated browsers, or something else...

Basilisk (never used it personally) supposedly supports TLS up to newest TLSv1.3, so it should work without trouble.
Does Basilisk and/or Palemoon open other ssl websites correctly?

what's the output from the command below? 

openssl s_client -connect dev1galaxy.org:443

Offline

#3 2019-10-12 23:23:07

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 382  

Re: SSL error

brownh wrote:

"Error during connection to dev1galaxy.org/ SSL received a record that exceeded the maximum possible length (Error code: SSL_ERROR_RX_RECORD_TOO_LONG)"

When your SSL client says the above, most likely the actual response from dev1galaxy is (in clear text):

Your IP address has been tagged as dubious. If this is in error,
please contact dev1galaxy forum adminstrators on #d1g-users at freenode.

Like many/most forum sites, dev1galaxy includes a couple of attempted barriers against spam and unwanted intrusions, which results in IP addresses becoming tagged as "dubious". Due to being fully automated, it sometimes (but rarely) makes a false positive judgement, and then it requires some corrective hands-on.

Offline

Board footer