The officially official Devuan Forum!

You are not logged in.

#1 2019-08-19 21:38:55

sgage
Member
Registered: 2016-12-01
Posts: 177  

[beowulf] Packages being held back.

For the past week or two, I've been getting this:

# apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  elogind libblkid1:i386 libelogind0 libmount1:i386 libpam-elogind
  libuuid1:i386
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

Is there a problem somewhere, or do I just have to wait for some dependency issue to be resolved?

Offline

#2 2019-08-19 22:20:59

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 373  

Re: [beowulf] Packages being held back.

Perhaps it's due to the version disagreement of libuuid1:amd64 and libuuid1:i386 (in beowulf) (and in unstable).

Online

#3 2019-08-19 22:33:30

sgage
Member
Registered: 2016-12-01
Posts: 177  

Re: [beowulf] Packages being held back.

ralph.ronnquist wrote:

Perhaps it's due to the version disagreement of libuuid1:amd64 and libuuid1:i386 (in beowulf) (and in unstable).

Ah, perhaps. :amd64 is 2.32.1-0.12.32.1, while the upgrade candidate for :i386 is 2.32.1-0.12.33.1, and cascading dependencies takes care of the rest. Best to just wait for :amd64 to 'catch up'?

Last edited by sgage (2019-08-19 22:33:53)

Offline

#4 2019-08-20 11:47:27

bgstack15
Member
Registered: 2018-02-04
Posts: 66  

Re: [beowulf] Packages being held back.

I have the same problem, where elogind and related packages in my multiarch setup are being held back. This problem affects wine32 which depends on one of these. I also like using elogind versus consolekit which I think might also be related/affected.

Offline

#5 2019-08-29 12:30:11

sgage
Member
Registered: 2016-12-01
Posts: 177  

Re: [beowulf] Packages being held back.

bgstack15 wrote:

I have the same problem, where elogind and related packages in my multiarch setup are being held back. This problem affects wine32 which depends on one of these. I also like using elogind versus consolekit which I think might also be related/affected.

I removed wine32 and its hangers-on, and the upgrade completed successfully. I only use wine32 for one program that isn't essential in daily use, so I'll just wait until this gets sorted.

This is a beowulf system updated from ascii. Is there a proper beowulf installer so I could try a clean install?

Offline

#6 2019-08-30 14:12:24

bgstack15
Member
Registered: 2018-02-04
Posts: 66  

Re: [beowulf] Packages being held back.

Perusing http://deb.devuan.org/devuan-cd/, it appears that the answer is no. I'm a little surprised, frankly. I can't really keep straight all these silly debian/devuan version numbers. I wish they would just use actual numbers...

Offline

Board footer