The officially official Devuan Forum!

You are not logged in.

#1 2019-08-16 18:16:00

mtbvfr
Member
Registered: 2017-07-29
Posts: 33  

Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

Hi Folks,

I marked All Upgrades this morning and clicked the Apply button.

There was errors regarding the Linux Image which I thought I had copied but after closing Synaptic there was nothing to paste into a Text Editor.

I tried again and was able to copy the following error.

W: Failed to fetch http://deb.debian.org/debian-security/p … _amd64.deb

The following package is listed as having a Broken Dependency.

linux-image-amd64

It only has 1 dependency listed which is the following.

linux-image-4.9.0-9-amd64

The Enabled Repositories are the following.

URI: http://pkgmaster.devuan.org/merged/
Distribution: ascii
Section(s): main 

URI: http://pkgmaster.devuan.org/merged/
Distribution: ascii-updates
Section(s): main

URI: http://pkgmaster.devuan.org/merged/
Distribution: ascii-security
Section(s): main

I found the following in /var/log/apt/term.log.

dpkg: dependency problems prevent configuration of linux-image-amd64:
linux-image-amd64 depends on linux-image-4.9.0-9-amd64; however:
  Package linux-image-4.9.0-9-amd64 is not installed.

dpkg: error processing package linux-image-amd64 (--configure):
dependency problems - leaving unconfigured

Thanks, MTB.

Offline

#2 2019-08-16 19:39:43

Dutch_Master
Member
Registered: 2018-05-31
Posts: 97  

Re: Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

If you manually download the package from the link provided, does that work for you? If you can, you can install it with dpkg.

Alternatively, what's the output of the commands

uname -a
dpkg --get-selections | grep linux-image

Offline

#3 2019-08-16 20:02:08

mtbvfr
Member
Registered: 2017-07-29
Posts: 33  

Re: Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

Dutch_Master wrote:

Alternatively, what's the output of the commands

uname -a
dpkg --get-selections | grep linux-image

"uname -a" results in the following.

Linux Dev1Ascii 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux

"dpkg --get-selections | grep linux-image" results in the following.

linux-image-4.9.0-6-amd64			install
linux-image-4.9.0-8-amd64			install
linux-image-amd64				install

"wget -v http://deb.debian.org/debian-security/pool/updates/main/l/linux/linux-image-4.9.0-9-amd64_4.9.168-1+deb9u2_amd64.deb" results in the following.

--2019-08-16 14:59:49--  http://deb.debian.org/debian-security/pool/updates/main/l/linux/linux-image-4.9.0-9-amd64_4.9.168-1+deb9u2_amd64.deb
Resolving deb.debian.org (deb.debian.org)... 2001:67c:2564:a119::148:14, 2001:41c8:1000:21::21:4, 2001:4f8:1:c::15, ...
Connecting to deb.debian.org (deb.debian.org)|2001:67c:2564:a119::148:14|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://cdn-fastly.deb.debian.org/debian-security/pool/updates/main/l/linux/linux-image-4.9.0-9-amd64_4.9.168-1+deb9u2_amd64.deb [following]
--2019-08-16 14:59:50--  http://cdn-fastly.deb.debian.org/debian-security/pool/updates/main/l/linux/linux-image-4.9.0-9-amd64_4.9.168-1+deb9u2_amd64.deb
Resolving cdn-fastly.deb.debian.org (cdn-fastly.deb.debian.org)... 2a04:4e42:1::204, 151.101.4.204
Connecting to cdn-fastly.deb.debian.org (cdn-fastly.deb.debian.org)|2a04:4e42:1::204|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-08-16 14:59:50 ERROR 404: Not Found.

Offline

#4 2019-08-16 20:45:00

Dutch_Master
Member
Registered: 2018-05-31
Posts: 97  

Re: Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

Odd. I found this one:
http://cdn-fastly.deb.debian.org/debian … _amd64.deb

Did you update the package list?

apt-get update

Offline

#5 2019-08-19 03:30:09

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 130  

Re: Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

1. Update repo list of packages via apt-get update

2. If there is still error try to install a package with aptitude. Aptitude can help to solve broken dependencies easily.

Offline

#6 2019-08-19 18:58:01

mtbvfr
Member
Registered: 2017-07-29
Posts: 33  

Re: Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

Dutch_Master wrote:

Odd. I found this one:
http://cdn-fastly.deb.debian.org/debian … _amd64.deb

Did you update the package list?

apt-get update

Duh, thanks for the Heads Up!

I forgot about trying that. It had been a while since I last checked for upgrades. I just selected the Installed (upgradeable) Status and Marked the associated packages before clicking on the Apply button.

After clicking on the Reload button and a couple of goes at reinstalling the package with the Broken Dependencies and another Reload, I think, the problem was fixed.

It would be good if there was a Setting in Preferences for Synaptic to activate the Reload function when it starts.

Offline

#7 2019-08-19 18:59:10

mtbvfr
Member
Registered: 2017-07-29
Posts: 33  

Re: Synaptic - Upgrade - Failed to fetch Linux Image 4.9.0-9 AMD64

ToxicExMachina wrote:

1. Update repo list of packages via apt-get update

2. If there is still error try to install a package with aptitude. Aptitude can help to solve broken dependencies easily.

Thanks, see Post #6.

Offline

Board footer