The officially official Devuan Forum!

You are not logged in.

#1 2019-04-19 13:28:05

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Help on deuvan derivate exelinux on old compaq evo N1005v

Hi everybody!
I' m very happy to announce the install of a deuvan derivative on my old laptop, but I have some problems with opengl and soundcard.
for example after installing mesa package and launcing glxgears I obtain segmentation fault...
Is it possible to find some informations from the configuration of an old kubuntu 8.04 in other partition? It works fine ma there are no package online more and no security upgrades so I can't use it
Thank you very much
best regards

Offline

#2 2019-04-19 16:51:09

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 313  
Website

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

What is your graphics hardware?

Exe GNU/Linux doesn't include any non-free firmware but AMD, NVIDIA and recent Intel graphics cards require that to work properly.

And did you verify the md5sums after downloading the image?

You can check for a bad USB stick by copying the image back to a file:

# cp /dev/sdX check.img ; sync

And then compare the checksums again.


Fabricando fit faber

Offline

#3 2019-04-22 04:13:25

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 130  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

According to specs the GPU in your laptop is ATI Mobility U1. It's ATI IGP 320M aka R100. You can try "radeon" driver but i am not sure it will work, however your GPU may be supported: https://www.x.org/wiki/RadeonFeature/

On segfault:

try

glxinfo | grep direct

You also have to check kernel modules.

Last edited by ToxicExMachina (2019-04-22 04:13:44)

Offline

#4 2019-04-24 11:15:27

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

Hi, thanks for all!!

this is the output  :

glxinfo | grep direct
direct rendering: Yes
    GL_ARB_direct_state_access, GL_ARB_draw_buffers,
    GL_ARB_draw_indirect, GL_ARB_draw_instanced, GL_ARB_enhanced_layouts,
    GL_ARB_multi_draw_indirect, GL_ARB_occlusion_query2,

I think it'll be useful this..

 lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS100 Host Bridge (rev 13)
00:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RS100 AGP Bridge (rev 01)
00:02.0 USB controller: ULi Electronics Inc. USB 1.1 Controller (rev 03)
00:07.0 ISA bridge: ULi Electronics Inc. M1533/M1535/M1543 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Multimedia audio controller: ULi Electronics Inc. M5451 PCI AC-Link Controller Audio Device (rev 02)
00:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 20)
00:0c.0 Communication controller: Conexant Systems, Inc. HSF 56k HSFi Modem (rev 01)
00:0f.0 USB controller: ULi Electronics Inc. USB 1.1 Controller (rev 03)
00:10.0 IDE interface: ULi Electronics Inc. M5229 IDE (rev c4)
00:11.0 Bridge: ULi Electronics Inc. M7101 Power Management Controller [PMU]
00:13.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS100 [Radeon IGP 320M]

what I have to do to load athlon driver?

thanks

Offline

#5 2019-04-24 13:45:48

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

I resolved soundcard problem, now audio works well.
It was a kmix graphical configuration problem.

other outputs:

:~$glxheads
glxheads: exercise multiple GLX connections (any key = exit)
Usage:
  glxheads xdisplayname ...
Example:
  glxheads :0 mars:0 venus:1
Name: :0
  Display:     0xf96e18
  Window:      0x3800002
  Context:     0xf98810
  GL_VERSION:  3.0 Mesa 13.0.6
  GL_VENDOR:   VMware, Inc.
  GL_RENDERER: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
Segmentation fault
:~$glxgears
Segmentation fault

problems with other graphical programs:

:~$ xaos
Illegal instruction

Last edited by T-rex (2019-04-24 13:53:26)

Offline

#6 2019-04-24 18:20:47

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 313  
Website

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

Have you installed the non-free firmware required by the AMD graphics card?

You can use gbd to investigate the segfault (if the firmware is already installed or doesn't fix them), I think Devuan has debug repositories containing packages compiled with the debug flags enabled.

https://wiki.debian.org/HowToGetABacktrace


Fabricando fit faber

Offline

#7 2019-04-25 04:18:17

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 130  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

T-rex wrote:

  GL_RENDERER: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)

So the renderer working on your laptop now is software renderer. Do you have /etc/X11/xorg.conf file?

Offline

#8 2019-04-28 08:15:28

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

Do you have /etc/X11/xorg.conf file?

xorg.conf is empty

Now I'm tryiing to find the firmware i need ... is correct?

Tank you for all!  smile

Offline

#9 2019-04-29 05:04:06

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 130  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

T-rex wrote:

Do you have /etc/X11/xorg.conf file?

xorg.conf is empty

Now I'm tryiing to find the firmware i need ... is correct?

Tank you for all!  smile

1. Try to install firmware

apt-get install firmware-amd-graphics

Then reboot system just in case. If hardware acceleration does not work follow the next step.

2. Try to create the following file:

/etc/X11/xorg.conf.d/20-radeon.conf

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
EndSection

3. If direct rendering via hardware is still not enabled see Xorg.0.log file (you can copy contents to pastebin and give a link)

Last edited by ToxicExMachina (2019-04-29 05:05:02)

Offline

#10 2019-04-29 06:40:03

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

Hi! 
Yesterday I worked over the problem, but before to give you a summary of my attempts ,I have a little question:
what is the difference  between writing in

/etc/X11/xorg.conf

and

/etc/X11/xorg.conf.d/20-radeon.conf

???
I used the first option and now I ll' try to change to see if there are some improvements...
Summary of yesterday:

In the morning i tried to follow that howtos :

https://wiki.debian.org/AtiHowTo

and

https://wiki.debian.org/ATIProprietary 

but I didn't solve it, I probably had something wrong ...

in the afternoon I was at a meeting of my nearest LUG and they try to help me.

They find an error like this,

radeon_cp: Failed to load firmware "radeon/R100_cp.bin

a guy find that there is a bug over R100 and kernel but now I dont find the webpage.
I dont' exacty understand but there was a problem with the loading of the firmware by the kernel(it tries to load something before the mounting of filesystem) ,so  they move it into initramfs and it works, badly and slowly...probably due to my morning mistakes and the meetein time that was ending...

Now I'm trying to repeat the procedure correctly and to clean up any wrong configuration files

thank you so much for your help!

Offline

#11 2019-04-29 07:19:41

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

my first step  today...

# apt-get install firmware-amd-graphics
Reading package lists... Done
Building dependency tree
Reading state information... Done
firmware-amd-graphics is already the newest version (20161130-5).
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

Last edited by T-rex (2019-04-29 07:20:14)

Offline

#12 2019-04-29 19:25:46

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 313  
Website

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

T-rex wrote:

They find an error like this,

radeon_cp: Failed to load firmware "radeon/R100_cp.bin

The kernel runs through a list of firmware until it finds one it can load for the device so check the full dmesg(1) output to see if any firmware is actually loaded:

# dmesg | grep firmware

Fabricando fit faber

Offline

#13 2019-04-30 17:28:38

T-rex
Member
Registered: 2019-04-19
Posts: 7  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

dmesg | grep firmware
[    5.926824] radeon 0000:01:05.0: firmware: failed to load radeon/R100_cp.bin (-2)
[    5.926889] radeon 0000:01:05.0: Direct firmware load for radeon/R100_cp.bin failed with e
[    5.927231] [drm:r100_cp_init [radeon]] *ERROR* Failed to load firmware!
[    5.967989] radeon 0000:01:05.0: firmware: failed to load radeon/R100_cp.bin (-2)
[    5.968155] radeon 0000:01:05.0: Direct firmware load for radeon/R100_cp.bin failed with e
[    5.968507] [drm:r100_cp_init [radeon]] *ERROR* Failed to load firmware!

thanks

Offline

#14 2019-06-17 17:37:15

wdq
Member
Registered: 2018-03-15
Posts: 44  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

Have you installed

apt-get install firmware-linux-nonfree 

a reboot and try again a

dmesg | grep firmware

Offline

#15 2019-07-12 15:14:17

omnio
Member
Registered: 2019-07-12
Posts: 10  

Re: Help on deuvan derivate exelinux on old compaq evo N1005v

problems with other graphical programs:

:~$ xaos
Illegal instruction

This happens often when the program was compiled with SSE/SSE2 flags but the CPU running (or trying to run) the program doesn't have those flags (often with GTK3 or QT apps). You can check your CPU for SSE/SSE2 flags:

grep flags /proc/cpuinfo

Offline

Board footer