The officially official Devuan Forum!

You are not logged in.

#1 2019-02-28 17:15:20

lumumbria
Member
Registered: 2019-02-28
Posts: 2  

Neovim upgrade

I'm new on Devuan system through Miyo and Star distros installed on laptops for coding and general programming development.  Both systems works fine and fast till now, and the workflow of the systems are very very well. Congrats to both teams. But I have a heavy request to make: Please, update soon the Neovim cli-editor to the current 0.3 update because I need the Neovim specific Deoplete package plugin (a basic aid to syntax Autocomplete). And, Vim needs update to 8.1 to works well with the Youcompleteme autocomplete plugin. Please, consider this issues seriously. Thanks, and greetings.

Offline

#2 2019-03-05 12:06:40

bgstack15
Member
Registered: 2018-02-04
Posts: 16  

Re: Neovim upgrade

Do you know which release/branch of Devuan your downstream distros are based on? I am using devuan ceres (unstable or sid), and I've got vim 8.1. And neovim 0.3.4 is in the ceres/main apt repo.

One of the benefits and the downsides to the stable releases (jessie and ascii) is that the stable software sometimes lags, to remain stable.

Offline

#3 2019-03-07 18:30:20

lumumbria
Member
Registered: 2019-02-28
Posts: 2  

Re: Neovim upgrade

That's correct and that's the problem when a new user come here from Arch (AUR is God). I need to reinstall this to a sid branch or a testing branch of devuan to get a minimum update software. I don't care about kernels or fancy GUI stuffs. All I need are my text editors (Neovim and Emacs) and my binary compilers (...i need to check this too: Haskell, Clojure, Elixir).... Thanks for your help.

Offline

Board footer