The officially official Devuan Forum!

You are not logged in.

#1 2018-12-05 20:05:34

Registered: 2017-05-07
Posts: 146  

Shutdown problem - e1000 driver bug?


My Sun Microsystems Ultra24 rig has a problem which up to now I’ve chalked up to a crap BIOS.
It happened with the previous original version it came with and with this one, which is the latest one available.

I'm on Devuan latest:

groucho@devuan:~$ uname -a
Linux devuan 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux
[root@devuan groucho]# apt-get update
Hit:1 ascii InRelease
Get:2 ascii-updates InRelease [25.6 kB]
Hit:3 ascii-security InRelease
Fetched 25.6 kB in 5s (4944 B/s)
Reading package lists... Done
[root@devuan groucho]#
[root@devuan groucho]# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[root@devuan groucho]# 
[root@devuan groucho]# 
[root@devuan groucho]# apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done
[root@devuan groucho]# 


On shutdown, the rig will do one of three things:

1. shut down properly
2. shut down properly and after about 5s. reboot start reboot and freeze
3. freeze during the shutdown at this point ...

e1000e: EEE Tx LPI Timer
Preparing to enter sleep state S5
Reboot: Power Down 

… with the fans blowing at full speed.
This happens ocasionally and I have not been able to reliably reproduce the behaviour, no idea what causes it.
It happened when I only had wireless access ie: before I had a wired connection and it also happens now.

Unfortunately, there’s no way of disabling the on board e1000e controller (you see, as this Sun MoBo has IME, that would be a no-no).

Could it be that (at least part of the issue) is caused by this bug: … e/34986431

Apparently it was solved from kernel 3.16.49 on, but the behaviour is very similar.

See: … ux-3-16-49

My power settings (Xfce Power Manager) are:

When power button is pressed: Shutdown
When sleep button is pressed:  Do nothing
When hibernate button is pressed: Do nothing

System sleep mode: Suspend
Put sytem to sleep when inactive for: Never

This also happened with other distros I have tried before settling here with Devuan.
Previous owner of the rig used a a Gates OS but I don’t think he would have mentioned this anyway.

I have not found a way to log what is happening so as to be able to get a better idea of what is happening.
I’d appreciate any suggestions you may have as this is a real PITA.

Thanks in advance.



Board footer