The officially official Devuan Forum!

You are not logged in.

#1 2018-10-20 01:52:54

Giorgos
Member
From: Greece
Registered: 2018-06-12
Posts: 28  

Problem encrypting the swap partition with cryptsetup [SOLVED].

Hi! :-)

I tried cryptsetup for encrypting my swap and indeed I was successful, but I'm getting the message (at boot time): "gave up waiting for suspend/resume device"  (and the respective delay).

My initial crypttab (according to the FAQ) was: "cswap1        /dev/sda6    /dev/urandom    swap,cipher=aes-xts-plain64,size=256,hash=sha1" and I even tried the options nodelay and noauto, bat they didn't make any difference.

Again, later on boot process I'm getting the message that cswap1 is mounted as swap and indeed the encrypted setup is fully functional after the bott process is finished.

Is it a bug?
Is there any way to avoid the "gave up..." error message or at least the delay on boot?
TIA!
G.

Last edited by Giorgos (2018-10-23 00:21:01)

Offline

#2 2018-10-20 11:32:23

fsmithred
Administrator
Registered: 2016-11-25
Posts: 928  

Re: Problem encrypting the swap partition with cryptsetup [SOLVED].

My first guess is that the uuid in the resume file in your initrd needs to be changed. Try running update-initramfs -u and see if that fixes it.

Offline

#3 2018-10-20 12:35:37

Giorgos
Member
From: Greece
Registered: 2018-06-12
Posts: 28  

Re: Problem encrypting the swap partition with cryptsetup [SOLVED].

The resume file, still holds the uuid of the unencrypted partition.
Seems like this is normal (according to the cryptsetup documentation, if I'm not wrong), since the uuid of the encrypted partition, changes to a different one, in every boot.

EDIT:

What needed was setting it to none.
RESUME=none

Of course (as root) you have to update initramfs:
# update-initramfs -u

Now everything's in place.
On next boot you won't be bothered with it.

Thanks for the solution and greets flies to the guys from cryptsetup maillist! ;-)

Last edited by Giorgos (2018-10-23 00:28:18)

Offline

#4 2018-10-23 15:15:17

fsmithred
Administrator
Registered: 2016-11-25
Posts: 928  

Re: Problem encrypting the swap partition with cryptsetup [SOLVED].

What needed was setting it to none.
RESUME=none

Where did you set that?

Offline

#5 2018-10-23 15:48:40

Giorgos
Member
From: Greece
Registered: 2018-06-12
Posts: 28  

Re: Problem encrypting the swap partition with cryptsetup [SOLVED].

Here: /etc/initramfs-tools/conf.d/resume

Its the  resume text file on the  /etc/initramfs-tools/conf.d/ directory.

I gave "kdesu kate" and opened it and changed the given UUID (from Devuan's installation time) -> none.
(The only line, this file have, is: RESUME=none).
I saved and exited Kate. Updated initramfs and voilà! :-)

Last edited by Giorgos (2018-10-23 15:50:30)

Offline

Board footer