The officially official Devuan Forum!

You are not logged in.

#1 2018-07-08 19:12:09

Haines
Member
Registered: 2017-04-29
Posts: 1  

No mail out: hostname inconsistent

I put ascii on new hardware, but can't get mutt to send mail. Mail sent out has "Return-path: <>" in header.

The /etc/hosts, /etc/resolv.conf/etc/hostname, and emacs4 configuration are the same as they were under Devuan jessie except for the change in hostname.

When I do $ hostname --fqdn on both machines I get a proper fully qualified domain name. But when I do $ hostname -A, I get simply  the hostname of current machine without provider's domain, but on old machine it returned hostname.frontier.com .

Offline

#2 2018-07-31 04:08:39

PeteGozz
Member
From: Woodside South Australia
Registered: 2017-06-21
Posts: 72  

Re: No mail out: hostname inconsistent

I quite possibly don't understand how you get your hostname  or mailname ....
The empty <>
(return / from / reply ) all not useful or this mail is going nowhere bat signal..

Is correct.

aside:
A MTA (mail server) should refuse to accept such a thing ... so you get the mail bounced back.

Here are some ?reasonable?  guesses and hints

1.  setting the formal system mail name in
               

 /etc/mailname

guess: 
$HOSTNAME.frontier.com

(you will know the real name)

2. set mutts (from) email variable

export EMAIL=you@yours.on.net

see the mutt config stuff later / last in this message.
 

More Waffle::
An email _requires_  a  complete header called  From:
 
Either mutt is configured to use some  You@DOMAIN.foo
(per MUTT mail account???? )

Or it  looks it up in /etc/mailname
or
It constructs one from your login and  hostname

or

It hands that problem to mail or sendmail

A quick look at man mutt seems to indicate that it can use "sendmail" or "xmail"
which would hint that it has a reasonable chance of honoring the /etc/mailname file.

Next ::
Gather some data and hints

Test your system sends ::

$ cat  /etc/devuan_version  | mail -v  -s "A test Mail"  haines@localhost haines-external@the.real.internet.net

which is assuming you have "/usr/bin/mail" onboard.

(( cat whatever Text file you feel comfortable ending up at your ISP admins account smile .))

Test your "sendmail"   (which will probably be exim4 or postfix providing the sendmail command as an alias)

 cat /etc/hosts | /usr/sbin/sendmail ${USER}@localhost 

see also:
((Every sane Mail Transfer Agent reads this:))

/etc/aliases 

This NEXT is where you can set different  "home mail domains" per user.
(it may be exim4 specific ?)

/etc/email-addresses
If its there it has instructions in it ... but

 
#This file contains email addresses to use for outgoing mail. Any local
# part not in here will be qualified by the system domain as normal.
#
# It should contain lines of the form:
#
#user: someone@isp.com
#otheruser: someoneelse@anotherisp.com

root: you@some.place

Finally I would suggest that there would be a way to tell mutt your mail domain for external mail (per mail account) .

I found this is the muttrc manual

 from
              Type: e-mail address
              Default: ""

              When set, this variable contains a default from address.  It can
              be  overridden using "my_hdr" (including from a "send-hook") and
              $reverse_name.  This variable is ignored if $use_from is unset.

              This setting defaults to the contents of the  environment  vari-
              able $EMAIL.

So I tried the easy way smile

$export EMAIL=anotheremail@another.place.net
$mutt
press m 
          compose mail
press y
(wait a moment or three)

check new mail 

press q

I rarely use mutt anymore.

Though it is still an excellent Mail User Agent .


Hopefully this was some help and not too confusing.

Last edited by PeteGozz (2018-07-31 06:21:41)

Offline

Board footer