The officially official Devuan Forum!

You are not logged in.

#1 2017-05-29 00:44:14

zapper
Member
Registered: 2017-05-29
Posts: 60  

Has anyone here installed nextcloud from source successfully? SOLVED!

this error I keep getting when I go to run nextcloud through terminal emulator stays with me no matter what...

nextcloud: error while loading shared libraries: libnextcloudsync.so.0: cannot open shared object file: No such file or directory

this error was easily squashed in debian but not devuan...

whether it is debian 8 or debian 9... same result.

devuan jessie and ascii not so much...

can anyone tell me how to squash it?

owncloud doesn't have this error suspiciously... that I know of...

SOLVED! thank you! smile

Last edited by zapper (2017-05-30 01:50:23)

Offline

#2 2017-05-29 11:02:01

smoki
Member
Registered: 2017-05-15
Posts: 56  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

Probably lib is not on right location or something... Seems happen on any distro, making a link looks like do a job:

https://github.com/nextcloud/client_theming/issues/48

Offline

#3 2017-05-29 14:18:38

zapper
Member
Registered: 2017-05-29
Posts: 60  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

ln: failed to create symbolic link '/usr/lib64/libnextcloudsync.so.0': File exists

happens when I used,

ln -s /usr/local/lib64/libnextcloudsync.so.0 /usr/lib64/libnextcloudsync.so.0

so knowing this, I wondered if anyone here knows a fix

I wouldn't know where to begin. I am intermediate but I am by no means an expert at gnu/linux.

Offline

#4 2017-05-29 22:04:09

lazlo
Member
From: the Top Left of the Noosphere
Registered: 2017-05-15
Posts: 31  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

EDIT:  At first I was thinking that this could a $PATH issue, but we are talking about a library not an executable program.

In my VM there is no lib64 listed under /usr or /usr/local.  There is a /lib64 right off of / though.  Perhaps nextcloud expects the file to be there?  There must be a config file or a line of code that tells nextcloud where to install and/or look for it's libraries. I have no clue where that would be.

I hope that helps,



lazlo

Last edited by lazlo (2017-05-29 22:15:05)

Offline

#5 2017-05-29 23:44:54

smoki
Member
Registered: 2017-05-15
Posts: 56  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

zapper wrote:

ln: failed to create symbolic link '/usr/lib64/libnextcloudsync.so.0': File exists

happens when I used,

ln -s /usr/local/lib64/libnextcloudsync.so.0 /usr/lib64/libnextcloudsync.so.0

so knowing this, I wondered if anyone here knows a fix

I wouldn't know where to begin. I am intermediate but I am by no means an expert at gnu/linux.

  you can strace that as mentioned in a bug to see where it expect lib to be, did you followed their build instruction for Debian from github?... anyway if you are not an expert may i ask why did you compiling it? Also, at first does their repo packages for Debian 8 works for you? This one:

http://download.opensuse.org/repositori … ebian_8.0/

Repo line goes like this:

deb http://download.opensuse.org/repositories/home:/ivaradi//Debian_8.0/ /

I tried this and it works here, at least started. No idea for further, only spotted that have dependancy on libqtwebkit4 which is not anymore supported by Debian security on jessie, just as info for you and so on.

Last edited by smoki (2017-05-30 00:06:09)

Offline

#6 2017-05-30 01:22:30

zapper
Member
Registered: 2017-05-29
Posts: 60  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

Now I have only one problem remaining, the key isn't being accepted. and I am not sure why...

but it gives this error.

W: GPG error: http://download.opensuse.org/repositori … Debian_9.0  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 97E98EAFE52838E6
E: The repository 'http://download.opensuse.org/repositories/home:/ivaradi//Debian_9.0  Release' is not signed.
E: Failed to download some files

I am using ascii so debian 9 version is no doubt needed

I don't really import keys with command line... that would be why. heh.

Edit: I did it manually and it worked. so thanks for giving me the link. wink

gdebi did the job pretty well.

smile

Last edited by zapper (2017-05-30 01:43:30)

Offline

#7 2017-05-30 07:56:37

smoki
Member
Registered: 2017-05-15
Posts: 56  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

Cool, anyway for adding keys of this repo to cite:

https://software.opensuse.org/download. … oud-client

For Debian 8.0 run the following as root:

echo 'deb http://download.opensuse.org/repositories/home:/ivaradi/Debian_8.0/ /' > /etc/apt/sources.list.d/nextcloud-client.list 
apt-get update
apt-get install nextcloud-client

You can add the repository key to apt. Keep in mind that the owner of the key may distribute updates, packages and repositories that your system will trust (more information). To add the key, run:

wget -nv http://download.opensuse.org/repositories/home:ivaradi/Debian_8.0/Release.key -O Release.key
apt-key add - < Release.key
apt-get update

Last edited by smoki (2017-05-30 07:58:42)

Offline

#8 2017-05-30 13:34:02

zapper
Member
Registered: 2017-05-29
Posts: 60  

Re: Has anyone here installed nextcloud from source successfully? SOLVED!

smoki wrote:

Cool, anyway for adding keys of this repo to cite:

https://software.opensuse.org/download. … oud-client

For Debian 8.0 run the following as root:

echo 'deb http://download.opensuse.org/repositories/home:/ivaradi/Debian_8.0/ /' > /etc/apt/sources.list.d/nextcloud-client.list 
apt-get update
apt-get install nextcloud-client

You can add the repository key to apt. Keep in mind that the owner of the key may distribute updates, packages and repositories that your system will trust (more information). To add the key, run:

wget -nv http://download.opensuse.org/repositories/home:ivaradi/Debian_8.0/Release.key -O Release.key
apt-key add - < Release.key
apt-get update

even better! now I can upgrade it when needed!

hehe...

SOLVED IN FULL!  wink

Offline

Board footer