The officially official Devuan Forum!

You are not logged in.

#1 2020-09-29 21:14:11

kapqa
Member
Registered: 2019-01-02
Posts: 209  

(AMD A10-9700 APU) OpenCL > OpenCL subsystem isn't available

Hello ,


today i tried to install this software Svp4linux on devuan beowulf on pc with amd a10 apu (bristol ridge).

it seems the APU is not very good supported on Debian / Devuan, but maybe i just made an error during installation.


however, the program would not start and i get the following error


21:09:19.633 [I]: OS: Linux 4.19.0-11-amd64 #1 SMP Debian 4.19.146-1 (2020-09-17) x86_64
21:09:19.649 [I]: Desktop environment:  / xfce
21:09:19.675 [I]: CPU: AMD A10-9700 RADEON R7, 10 COMPUTE CORES 4C+6G [base frequency 1540 MHz, 4 threads]
21:09:19.677 [W]: Video: OpenCL subsystem isn't available, try to reinstall video drivers
21:09:19.679 [I]: Memory:  15026  MB total,  14476 MB free

i have installed the firmware-amd-graphics and also firmware-xorg-video-ati or similar , as this was done during installation (went from ascii to beowulf).



If anyone know an help, please post.


thank you very much.

Offline

#2 2020-09-29 21:36:42

rolfie
Member
Registered: 2017-11-25
Posts: 415  

Re: (AMD A10-9700 APU) OpenCL > OpenCL subsystem isn't available

Online

#3 2020-09-30 07:06:49

kapqa
Member
Registered: 2019-01-02
Posts: 209  

Re: (AMD A10-9700 APU) OpenCL > OpenCL subsystem isn't available

Thank you very much Rolfie,

this has been solved!


firmware-linux

was missing, the one-liner filled it up.

Now the program starts!

Offline

Board footer