The officially official Devuan Forum!

You are not logged in.

#1 2020-09-19 06:42:58

erdos
Member
Registered: 2018-06-04
Posts: 48  

Kodi help

hi, i have kodi installed on beowulf and tried to use it to watch IPTVs.

but some live channels aren't playing and it seems i need to have enable rtmp support from 'VideoPlayer InputStream', but the latter doesn't appear in menu,  so i searched online and run the following commands :

sudo apt-get install kodi-inputstream-adaptive

sudo apt-get install kodi-inputstream-rtmp

it came back saying 'unable to locate package...'

question is how to install the packages needed to play live IPTV in kodi?

Offline

#2 2020-09-19 07:52:24

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Kodi help

Those package aren't available in the official repositories (AFAICT). The deb-multimedia repositories have them but we've had lots of problem threads over at forums.debian.net about dependency hell caused by those repositories so perhaps just install the .debs individually instead of adding the repositories.

https://www.deb-multimedia.org/pool/mai … _amd64.deb

https://www.deb-multimedia.org/pool/mai … _amd64.deb

EDIT: or add the deb-multimedia repositories then pin them to 100 (the same as backports) to prevent inadvertent upgrades.

Last edited by Head_on_a_Stick (2020-09-19 07:55:51)


Black Lives Matter

Offline

#3 2020-09-19 10:05:29

HevyDevy
Member
Registered: 2019-09-06
Posts: 358  

Re: Kodi help

offtopic but ive found it easier to use a dedicated multimedia distro like batocera linux to have kodi up and running on separate partition.

https://batocera.org/ is a retro gaming os and has kodi preinstalled.

Have a look at https://wiki.batocera.org/kodi

Offline

#4 2020-09-22 14:48:18

erdos
Member
Registered: 2018-06-04
Posts: 48  

Re: Kodi help

Head_on_a_Stick wrote:

Those package aren't available in the official repositories (AFAICT). The deb-multimedia repositories have them but we've had lots of problem threads over at forums.debian.net about dependency hell caused by those repositories so perhaps just install the .debs individually instead of adding the repositories.

https://www.deb-multimedia.org/pool/mai … _amd64.deb

https://www.deb-multimedia.org/pool/mai … _amd64.deb

EDIT: or add the deb-multimedia repositories then pin them to 100 (the same as backports) to prevent inadvertent upgrades.


Thanks for the reply!  This is what I need.

Offline

#5 2020-09-27 03:29:14

erdos
Member
Registered: 2018-06-04
Posts: 48  

Re: Kodi help

It seems that dependency is not satisfied with direct installation of .deb package


erdos@htpc-devuan:~/Downloads$ sudo apt install ./kodi-inputstream-adaptive_2.4.5-dmo0+deb10u1_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'kodi-inputstream-adaptive' instead of './kodi-inputstream-adaptive_2.4.5-dmo0+deb10u1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-inputstream-adaptive : Depends: kodi (>= 5:18~) but 2:17.6+dfsg1-4+b1 is to be installed
E: Unable to correct problems, you have held broken packages.
erdos@htpc-devuan:~/Downloads$

o0+deb10u1_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'kodi-inputstream-rtmp' instead of './kodi-inputstream-rtmp_2.0.9-dmo0+deb10u1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-inputstream-rtmp : Depends: kodi (>= 5:18~) but 2:17.6+dfsg1-4+b1 is to be installed
E: Unable to correct problems, you have held broken packages.

Offline

#6 2020-09-27 03:44:10

GlennW
Member
Registered: 2019-07-18
Posts: 39  

Re: Kodi help

Not that I have kodi setup yet, but I managed to install these debian packages with,

dpkg -i --force-depends (packages location and name)

edit..this one needed "--force-depends". /home/glenn/Downloads/kodi-inputstream-adaptive_2.4.5-dmo0+deb10u1_amd64.deb

hope this helps

regards Glenn

I recreated the output...

root@GamesBox:~# dpkg -i --force-depends /home/glenn/Downloads/*.deb
Selecting previously unselected package kodi-inputstream-adaptive.
(Reading database ... 421747 files and directories currently installed.)
Preparing to unpack .../kodi-inputstream-adaptive_2.4.5-dmo0+deb10u1_amd64.deb ...
Unpacking kodi-inputstream-adaptive (2.4.5-dmo0+deb10u1) ...
Preparing to unpack .../kodi-inputstream-rtmp_2.0.9-dmo0+deb10u1_amd64.deb ...
Unpacking kodi-inputstream-rtmp (2.0.9-dmo0+deb10u1) over (2.0.9-dmo0+deb10u1) ...
dpkg: kodi-inputstream-adaptive: dependency problems, but configuring anyway as you requested:
 kodi-inputstream-adaptive depends on kodi (>= 5:18~); however:
  Version of kodi on system is 2:17.6+dfsg1-4+b1.

Setting up kodi-inputstream-adaptive (2.4.5-dmo0+deb10u1) ...
dpkg: kodi-inputstream-rtmp: dependency problems, but configuring anyway as you requested:
 kodi-inputstream-rtmp depends on kodi (>= 5:18~); however:
  Version of kodi on system is 2:17.6+dfsg1-4+b1.

Setting up kodi-inputstream-rtmp (2.0.9-dmo0+deb10u1) ...
root@GamesBox:~# 

Last edited by GlennW (2020-09-27 03:50:41)

Offline

#7 2020-09-27 14:17:01

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Kodi help

GlennW wrote:

Not that I have kodi setup yet, but I managed to install these debian packages with,

dpkg -i --force-depends (packages location and name)

Does the plugin actually work with the Debian version of Kodi?

Looks like the add-on can be installed from Kodi without relying on the DMO package: https://kodi.wiki/view/Add-on:InputStream_Adaptive


Black Lives Matter

Offline

#8 2020-09-27 21:51:18

GlennW
Member
Registered: 2019-07-18
Posts: 39  

Re: Kodi help

I'm not sure forcing the install is feasible. The packages are stopping the system until the broken packages are removed. So forcing the installations got me no-where, really.

Offline

#9 2020-09-28 17:11:30

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 150  
Website

Re: Kodi help

GlennW wrote:

I'm not sure forcing the install is feasible. The packages are stopping the system until the broken packages are removed.

I don't know if my experience is convenient to do in your case, but I will explain it:

In a few boxes with Devuan Beowulf 64 bits I used a --force-all to install a deb file for an old printer. All the package management programs complained from this point on about not met dependencies. I edited by hand the file /var/lib/dpkg/status and removed the claimed dependencies. So far, so good.

Offline

#10 2020-09-29 18:27:15

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,064  
Website

Re: Kodi help

You could grab the DMO source and modify debian/control so the dependencies are satisfied by the beowulf Kodi version but the add-on might not work for that.


Black Lives Matter

Offline

Board footer