The officially official Devuan Forum!

You are not logged in.

#1 2020-06-21 19:18:28

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Sound with Beowulf - always trouble?

It took quite a while to get Audacious to play sound on my X470 board. Finally it does. Here is a summary. Don't know yet if the result is persistant, but thats the next post probably.

Beowulf is installed in parallel to ASCII, where sound is working fine. I'm running Mate on an encrypted LVM, and since today with backports kernel 5.6. HW is a Prime X470 Pro mainboard with Realtek Audio and a RX570 Pulse AMD graphics card.

Copied my Audacious playlist from ASCII to Beowulf.

Per default libpulse0 and libpulse-mainloop-glib0, and if I am not mistaken, I can't get rid of them because Mate (mate-settings-daemon) depends on them.

alsamixer allows to select either HDMI from the RX570 as device 0 or the Realtek as device 1. The crucial thing is that I haven't found any way to set the Realtek as default. Audacious would react with the error message ALSA error: snd_pcm_open failed.

Searched this forum and the internet for hints to a solution, and was about to try to write a conf file, when I had the idea first to check the Audacious settings. And that did the job. Selecting the 5.1 Analog device from a very long list did the job, at least for the time being. Music is playing while I am typing this.

qasmixer is installed, but not visible as a tray icon. I guess I have to add this program to the startup folder.

Conclusion: there seems to be no easy way to configure nowadays sound systems under ALSA.

rolfie

Online

#2 2020-06-21 20:04:54

larsH
Member
Registered: 2020-05-05
Posts: 85  

Re: Sound with Beowulf - always trouble?

Hi

Many people has these problems with sound on Devuan. Should in my opinion be fixed (and optimal without using pulseaudio)

As you are using a gtk environment, i would install volumeicon-alsa and add it to the startuplist. This is one of a few guis for pure ALSA. And it works and integrates well. And no need for deteriorating sound through pulseaudio which mostly add latency.

Have a nice say
Lars H

Offline

#3 2020-06-21 20:07:53

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Re: Sound with Beowulf - always trouble?

A few reboots later: Audacious still working, volumeicon-alsa is in the tray, Firefox plays Youtube videos without sound.

Audacious seems to remember the settings which is perfect.

Mean thing about volumeicon-alsa is that you have to call (/usr/bin/)volumeicon in the Startup files.

Firefox seems to depend on the ALSA default, which still is not set.

Need to go on.

rolfie

Online

#4 2020-06-21 20:21:27

larsH
Member
Registered: 2020-05-05
Posts: 85  

Re: Sound with Beowulf - always trouble?

Hi

I am using my for serious sound production (I am a pro musician). In voulmeicon (wich are solely using alsa) you can in preferences set your device. I am sure it will rembember it.  And yes you will have to add it the startup of your desktop. In alsamixer F6 will allow you to do the same.

have a nice day

Offline

#5 2020-06-21 21:05:39

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Re: Sound with Beowulf - always trouble?

Hi Lars,

larsH wrote:

In voulmeicon (wich are solely using alsa) you can in preferences set your device. I am sure it will rembember it.  And yes you will have to add it the startup of your desktop. In alsamixer F6 will allow you to do the same.

Don't know how you do that. Under Beowulf I do not get the option to change the soundcard in volumeicon. And no way to modify the default in alsamixer. I can select a device and configure the channels, the settings are remembered, but no way to assign the Realtek Analogue to default.

I found a way to get audio in Firefox working. Created a /etc/asound.conf with this contents:

defaults.pcm.!card Generic
defaults.ctl.!card Generic
defaults.pcm.!device 0
defaults.ctl.!device 0

where Generic points to my Realtek Audio chip on the main board, and device 0 to the Analogue output. And changed the Firefox starter to apulse /opt/firefox/firefox. Currently I am listening to a Youtube video playing Summer Wine from Nancy Sinatra & Lee Hazlewood......

Such a fiddeling.....

rolfie

Last edited by rolfie (2020-06-21 21:06:12)

Online

#6 2020-06-21 21:14:08

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: Sound with Beowulf - always trouble?

There are several ways to set the default audio device for ALSA: https://wiki.archlinux.org/index.php/Ad … sound_card


Black Lives Matter

Offline

#7 2020-06-22 19:41:27

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Re: Sound with Beowulf - always trouble?

Head_on_a_Stick wrote:

There are several ways to set the default audio device for ALSA: https://wiki.archlinux.org/index.php/Ad … sound_card

Thanks, I have been through that document several times. Its informative but does not cover all the issues.

rolfie

Online

#8 2020-06-22 19:55:22

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Re: Sound with Beowulf - always trouble?

Here is the output of a set of collected commands from my Beowulf setup. X470 mainboard with encrypted LVM on openrc with Mate desktop, manually installed from a cli minimal install using apt install xorg lightdm mate-desktop-environment-extras.

# lspci -knn | grep -A2 Audio
0c:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580] [1002:aaf0]
	Subsystem: Sapphire Technology Limited Ellesmere [Radeon RX 580] [1da2:aaf0]
	Kernel driver in use: snd_hda_intel
--
0e:00.3 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller [1022:1457]
	Subsystem: ASUSTeK Computer Inc. Family 17h (Models 00h-0fh) HD Audio Controller [1043:8733]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
# aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA ATI HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 9: HDMI 3 [HDMI 3]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 10: HDMI 4 [HDMI 4]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 11: HDMI 5 [HDMI 5]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 0: ALC1220 Analog [ALC1220 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 1: ALC1220 Digital [ALC1220 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

List cleaned out to only show the installed packages.

# apt list *alsa*
Auflistung... Fertig
alsa-tools/stable,now 1.1.7-1 amd64  [installiert]
alsa-utils/stable,now 1.1.8-2 amd64  [installiert]
alsamixergui/stable,now 0.9.0rc2-1-10 amd64  [installiert]
gstreamer1.0-alsa/stable,now 1.14.4-2 amd64  [installiert]
volumeicon-alsa/stable,now 0.5.1+git20170117-1 amd64  [installiert]
# apt list *pulse*
Auflistung... Fertig
libpulse-mainloop-glib0/stable,now 12.2-4+deb10u1 amd64  [Installiert,automatisch]
libpulse0/stable,now 12.2-4+deb10u1 amd64  [Installiert,automatisch]
# apt list *jack*
Auflistung... Fertig
libjack-jackd2-0/stable,now 1.9.12~dfsg-2 amd64  [Installiert,automatisch]

Looks like volumicon-alsa is overwritten by the Mate sound setting applet. Also qasmixer does not show up in the panel.

In this setup I have no chance to setup defaults. The Mate sound applet looks poor, I don't have the controls I have in ASCII. The Realtek is displayed as having a Mono speaker. Too bad, I have pasted some screenshots in a LO document together with the output from a lot of commands, should have saved them individually.

rolfie

Last edited by rolfie (2020-06-22 20:02:23)

Online

#9 2020-06-22 20:01:21

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Re: Sound with Beowulf - always trouble?

And here is the same from my ASCII installation.

# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.19.0-0.bpo.8-amd64.
# apt list *alsa*
Auflistung... Fertig
alsa-utils/oldstable,now 1.1.3-1 amd64  [Installiert,automatisch]
alsamixergui/oldstable,now 0.9.0rc2-1-10 amd64  [installiert]
alsaplayer-alsa/oldstable,now 0.99.81-2 amd64  [Installiert,automatisch]
alsaplayer-common/oldstable,now 0.99.81-2 amd64  [Installiert,automatisch]
alsaplayer-gtk/oldstable,now 0.99.81-2 amd64  [installiert]
libalsaplayer0/oldstable,now 0.99.81-2 amd64  [Installiert,automatisch]
volumeicon-alsa/oldstable,now 0.4.6-2.2+b1 amd64  [installiert]
# apt list *pulse*
Auflistung... Fertig
apulse/oldstable,now 0.1.9-6 amd64  [installiert]
gstreamer1.0-pulseaudio/oldstable,now 1.10.4-1 amd64  [installiert]
libpulse-mainloop-glib0/oldstable,now 10.0-1+deb9u1 amd64  [Installiert,automatisch]
libpulse0/oldstable,now 10.0-1+deb9u1 amd64  [Installiert,automatisch]
libpulsedsp/oldstable,now 10.0-1+deb9u1 amd64  [Installiert,automatisch]
pulseaudio/oldstable,now 10.0-1+deb9u1 amd64  [installiert]
pulseaudio-utils/oldstable,now 10.0-1+deb9u1 amd64  [Installiert,automatisch]
# apt list *jack*
Auflistung... Fertig
libjack-jackd2-0/oldstable,now 1.9.10+20150825git1ed50c92~dfsg-5 amd64  [Installiert,automatisch]
# aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA ATI HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 9: HDMI 3 [HDMI 3]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 10: HDMI 4 [HDMI 4]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA ATI HDMI], Gerät 11: HDMI 5 [HDMI 5]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 0: ALC1220 Analog [ALC1220 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 1: ALC1220 Digital [ALC1220 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
# cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfce60000 irq 106
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfcd00000 irq 108

The Mate sound applet shows much more selections and a 5.1 loudspeaker system I have installed.

rolfie

Online

#10 2020-06-22 20:05:25

rolfie
Member
Registered: 2017-11-25
Posts: 364  

Re: Sound with Beowulf - always trouble?

Without knowing that fact, I now see that under ASCII pulse was installed. Maybe thats why the setup was quite easy and comfortable.

My conclusion: pure ALSA is not really comfortable, it lacks a reasonable control center that allows to setup the sound system according to the real HW and the users demands.

rolfie

Online

#11 2020-06-22 20:23:01

larsH
Member
Registered: 2020-05-05
Posts: 85  

Re: Sound with Beowulf - always trouble?

Hi

And this is a problem. Unfortunately allmost every gui to day are using pulseaudio, and thereby reducing latency for sound (it makes the sound worse). I know only two current gui programs that  works with alsa. Volumicon-alsa for gtk (wich I use myself) and as far as I know it qasmixer for qt. I think it is a shame people think they need pulseaudio. It is actually just a software layer that was added to solve some old problems with pure ALSA, that is not there today. I my humble opinion these two alternatives should be default in Devuan, and pulseaudio completely removed. I have it removed on my system because i use it for sound production with jack. At least as this is the most asked quatstion the alternatives should have been mentioned in the relsenotes.

Have a nice day
Lars H

Offline

#12 2020-06-26 05:06:04

LU344928
Member
Registered: 2020-02-13
Posts: 20  

Re: Sound with Beowulf - always trouble?

larsH wrote:

these two alternatives should be default in Devuan, and pulseaudio completely removed.

That will probably happen eventually. We just have to be patient. The team have a lot on their plate.

EDIT: Or maybe not... https://dev1galaxy.org/viewtopic.php?id=2934

Now I've confused myself smile

Last edited by LU344928 (2020-06-26 05:39:58)

Offline

#13 2020-06-26 09:28:29

steve_v
Member
Registered: 2018-01-11
Posts: 35  

Re: Sound with Beowulf - always trouble?

larsH wrote:

Unfortunately allmost every gui to day are using pulseaudio, and thereby reducing latency for sound (it makes the sound worse). I know only two current gui programs that  works with alsa. Volumicon-alsa for gtk (wich I use myself) and as far as I know it qasmixer for qt.

Fortunately almost every GUI today (with the notable exception of anything related to GNOME) works just fine with plain ALSA... So long as you don't compile it against pulseaudio, which unfortunately Devuan has, and it doesn't assume pulseaudio is available because libpulse0 was installed, which unfortunately Devuan does.


LU344928 wrote:

That will probably happen eventually. We just have to be patient. The team have a lot on their plate.

EDIT: Or maybe not... https://dev1galaxy.org/viewtopic.php?id=2934

I'm going to go with "not".

Pretty much every sound-related application in the repos which can be linked to pulseaudio has been...

Because apparently upstream Debian just loves needless bloat these days, and dubious "features" like lobotomising your ability to configure your system properly by burying everything behind a GUI and a wall of XML or JSON (then adding a daemon or two and a dbus interface for good measure) is progress.

This is one of the reasons I'm not running Devuan (or any "modern" binary distro for that matter) on my desktops.
A minimal server install is still quite feasible, but as soon as you want a usable web browser or a DE, the tendency for distro maintainers to compile in everything including the kitchen sink bites you in the ass.

Devuan:
apt install <pretty much anything>
...
I see you're installing $software, would you like bloat with that? Too bad, we compiled everything we could find with '--install-lennart --enable-bloat --enforce-more-latency --everyone-uses-laptops --bug-policy=redhat'
The following 900 packages you don't need or want will be installed...

Gentoo:
USE="-pulseaudio alsa" emerge --newuse @world && emerge --depclean
...
Bask in the complete and satisfying eradication of libpulse, Firefox without nasty LD_PRELOAD hacks, XFCE with full ALSA support, etc. etc. smile

Last edited by steve_v (2020-06-26 10:05:48)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

Board footer